summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--PHPINFO11
-rw-r--r--REFLECTION125
-rw-r--r--php-pecl-pinpoint.spec175
-rw-r--r--pinpoint_php-cxx.patch30
6 files changed, 354 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..94f77df
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,11 @@
+
+pinpoint_php
+
+pinpoint_php support => enabled
+
+Directive => Local Value => Master Value
+pinpoint_php.SendSpanTimeOutMs => 0 => 0
+pinpoint_php.CollectorHost => unix:/tmp/collector.sock => unix:/tmp/collector.sock
+pinpoint_php.UnitTest => no => no
+pinpoint_php.TraceLimit => -1 => -1
+pinpoint_php.DebugReport => no => no
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..a0be6ba
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,125 @@
+Extension [ <persistent> extension #86 pinpoint_php version 0.5.2 ] {
+
+ - INI {
+ Entry [ pinpoint_php.SendSpanTimeOutMs <ALL> ]
+ Current = '0'
+ }
+ Entry [ pinpoint_php.CollectorHost <ALL> ]
+ Current = 'unix:/tmp/collector.sock'
+ }
+ Entry [ pinpoint_php.UnitTest <ALL> ]
+ Current = 'no'
+ }
+ Entry [ pinpoint_php.TraceLimit <ALL> ]
+ Current = '-1'
+ }
+ Entry [ pinpoint_php.DebugReport <ALL> ]
+ Current = 'no'
+ }
+ }
+
+ - Functions {
+ Function [ <internal:pinpoint_php> function _pinpoint_start_trace ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $nodeid = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_end_trace ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $nodeid = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_unique_id ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:pinpoint_php> function pinpoint_get_this ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:pinpoint_php> function pinpoint_get_caller_arg ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $index = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function pinpoint_status ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_drop_trace ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $nodeid = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_start_time ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_set_context ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ Parameter #2 [ <optional> $nodeid = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_get_context ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <optional> $nodeid = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_trace_limit ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timestamp = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_mark_as_error ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $msg ]
+ Parameter #1 [ <required> $filename ]
+ Parameter #2 [ <optional> $lineno = <default> ]
+ Parameter #3 [ <optional> $nodeid = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_add_clue ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ Parameter #2 [ <optional> $nodeid = <default> ]
+ Parameter #3 [ <optional> $flag = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_add_clues ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $key ]
+ Parameter #1 [ <required> $value ]
+ Parameter #2 [ <optional> $nodeid = <default> ]
+ Parameter #3 [ <optional> $flag = <default> ]
+ }
+ }
+ Function [ <internal:pinpoint_php> function _pinpoint_join_cut ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $joinable ]
+ Parameter #1 [ <required> $onBefore ]
+ Parameter #2 [ <required> $onEnd ]
+ Parameter #3 [ <required> $onException ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-pinpoint.spec b/php-pecl-pinpoint.spec
new file mode 100644
index 0000000..f1efa29
--- /dev/null
+++ b/php-pecl-pinpoint.spec
@@ -0,0 +1,175 @@
+# remirepo spec file for php-pecl-pinpoint
+#
+# Copyright (c) 2024 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%{?scl:%scl_package php-pecl-pinpoint}
+
+%global pecl_name pinpoint_php
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+%global upstream_version 0.5.2
+#global upstream_prever RC2
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
+
+Summary: PHP extension for pinpoint-apm<
+Name: %{?scl_prefix}php-pecl-pinpoint
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: Apache-2.0
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+Patch0: %{pecl_name}-cxx.patch
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?dtsprefix}gcc-c++
+BuildRequires: %{?scl_prefix}php-devel >= 7.1
+BuildRequires: %{?scl_prefix}php-pear
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+
+
+%description
+This extension provides an API pinpoint-apm and built-in function
+auto-injection.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -q -c
+
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ -e '/LICENSE/s/role="doc"/role="src"/' \
+ -i package.xml
+
+cd %{sources}
+sed -e 's/\r//' -i config.m4
+%patch -P0 -p1 -b .pr655
+
+# Sanity check, really often broken
+extver=$(sed -n '/PHP_PINPOINT_PHP_VERSION/{s/.* "//;s/".*$//;p}' php_pinpoint_php.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
+ exit 1
+fi
+cd ..
+
+mkdir NTS
+%if %{with_zts}
+mkdir ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable "%{summary}" extension module
+extension=%{pecl_name}.so
+
+; Configuration
+;pinpoint_php.SendSpanTimeOutMs =0
+;pinpoint_php.CollectorHost = unix:/tmp/collector.sock
+;pinpoint_php.UnitTest = no
+;pinpoint_php.TraceLimit = -1
+;pinpoint_php.DebugReport = no
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+%configure \
+ --enable-pinpoint_php \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
+
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%configure \
+ --enable-pinpoint_php \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__ztsphpconfig}
+
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+: Minimal load test for NTS extension
+cd NTS
+%{__php} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+cd ../ZTS
+%{__ztsphp} --no-php-ini \
+ --define extension=modules/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%endif
+
+
+%files
+%license %{sources}/LICENSE
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Mon Jul 29 2024 Remi Collet <remi@remirepo.net> - 0.5.2-1
+- initial package
+- open https://github.com/pinpoint-apm/pinpoint-c-agent/issues/656 license
+- open https://github.com/pinpoint-apm/pinpoint-c-agent/pull/655 use cxx
diff --git a/pinpoint_php-cxx.patch b/pinpoint_php-cxx.patch
new file mode 100644
index 0000000..1eb0f3a
--- /dev/null
+++ b/pinpoint_php-cxx.patch
@@ -0,0 +1,30 @@
+From 27d46dcca6d74a30cd2df81b3f23977b8131957c Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 29 Jul 2024 10:28:12 +0200
+Subject: [PATCH] This is cxx extension
+
+---
+ config.m4 | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/config.m4 b/config.m4
+index 2dbfbff9..fcbc2aa6 100644
+--- a/config.m4
++++ b/config.m4
+@@ -11,7 +11,6 @@ if test "$PHP_PINPOINT_PHP" != "no"; the
+
+ PHP_REQUIRE_CXX()
+ PHP_SUBST(PINPOINT_PHP_SHARED_LIBADD)
+- PHP_ADD_LIBRARY(stdc++, 1, PINPOINT_PHP_SHARED_LIBADD)
+ PHP_ADD_INCLUDE(PHP_EXT_SRCDIR()/common/include)
+ PHP_ADD_INCLUDE(PHP_EXT_SRCDIR()/common/jsoncpp/include)
+ PHP_ADD_INCLUDE(PHP_EXT_SRCDIR()/common/jsoncpp/include)
+@@ -47,5 +46,5 @@ if test "$PHP_PINPOINT_PHP" != "no"; the
+
+ PINPOINT_PHP_SHARED_LIBADD="$PINPOINT_PHP_SHARED_LIBADD -lrt"
+
+- PHP_NEW_EXTENSION(pinpoint_php,$PINPOINT_SRCS, $ext_shared)
+-fi
+\ No newline at end of file
++ PHP_NEW_EXTENSION(pinpoint_php,$PINPOINT_SRCS, $ext_shared,,, cxx)
++fi