summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-22 12:25:57 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-22 12:25:57 +0200
commitb06c3f0b6bfd66a0c4a2d7bf94bd5182c836ab38 (patch)
treefebf719ec6cf8456c7f4deca37a61815b87e7eb2
parentf16cba76bd1f3bdf5c2154ef9b6eceeccd223b51 (diff)
php-pecl-pdflib: 4.0.0 (beta)
-rw-r--r--REFLECTION-DEV30
-rw-r--r--php-pecl-pdflib-dev.spec17
-rw-r--r--php-pecl-pdflib.spec2
3 files changed, 35 insertions, 14 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 703b23c..22614eb 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 PDFlib version 3.0.4 ] {
+Extension [ <persistent> extension #107 PDFlib version 4.0.0 ] {
- Functions {
Function [ <internal:PDFlib> function pdf_activate_item ] {
@@ -316,7 +316,7 @@ Extension [ <persistent> extension #113 PDFlib version 3.0.4 ] {
}
- Classes [2] {
- Class [ <internal:PDFlib> class PDFlibException extends Exception ] {
+ Class [ <internal:PDFlib> class PDFlibException extends Exception implements Throwable ] {
- Constants [0] {
}
@@ -335,7 +335,7 @@ Extension [ <persistent> extension #113 PDFlib version 3.0.4 ] {
Property [ <default> protected $apiname ]
}
- - Methods [12] {
+ - Methods [13] {
Method [ <internal:PDFlib> public method get_apiname ] {
}
@@ -354,28 +354,31 @@ Extension [ <persistent> extension #113 PDFlib version 3.0.4 ] {
}
}
- Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
}
- Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
}
- Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
}
- Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
}
- Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
}
- Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
}
- Method [ <internal:Core, inherits Exception> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
@@ -394,7 +397,7 @@ Extension [ <persistent> extension #113 PDFlib version 3.0.4 ] {
- Properties [0] {
}
- - Methods [131] {
+ - Methods [132] {
Method [ <internal:PDFlib> final public method activate_item ] {
}
@@ -787,6 +790,9 @@ Extension [ <persistent> extension #113 PDFlib version 3.0.4 ] {
Method [ <internal:PDFlib> final public method show_boxed ] {
}
+
+ Method [ <internal:PDFlib, dtor> final public method __destruct ] {
+ }
}
}
}
diff --git a/php-pecl-pdflib-dev.spec b/php-pecl-pdflib-dev.spec
index a11e740..1afe510 100644
--- a/php-pecl-pdflib-dev.spec
+++ b/php-pecl-pdflib-dev.spec
@@ -19,8 +19,8 @@
Summary: Package for generating PDF files
Name: %{?scl_prefix}php-pecl-pdflib
-Version: 3.0.4
-Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+Version: 4.0.0
+Release: 1%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
# https://bugs.php.net/60396 ask license file
License: PHP
Group: Development/Languages
@@ -41,8 +41,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter private shared
@@ -64,6 +66,14 @@ Obsoletes: php55w-pecl-%{pecl_name}
Obsoletes: php56u-pecl-%{pecl_name}
Obsoletes: php56w-pecl-%{pecl_name}
%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name}
+Obsoletes: php70w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name}
+Obsoletes: php71w-pecl-%{pecl_name}
+%endif
%endif
@@ -188,6 +198,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Sep 22 2016 Remi Collet <remi@fedoraproject.org> - 4.0.0-1
+- update to 4.0.0 (beta) for PHP 7
+
* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 3.0.4-4
- adapt for F24
diff --git a/php-pecl-pdflib.spec b/php-pecl-pdflib.spec
index a11e740..9ce4f88 100644
--- a/php-pecl-pdflib.spec
+++ b/php-pecl-pdflib.spec
@@ -41,8 +41,10 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
# Filter private shared