summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-22 12:03:32 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-22 12:03:32 +0200
commitf16cba76bd1f3bdf5c2154ef9b6eceeccd223b51 (patch)
treead0ed60a958c832bdbb0012ac88e854ac70e54e2
parent2d723a03f25746fb73bb8f635afa3bf074f3eca0 (diff)
php-pecl-pdflib: dup the spec
-rw-r--r--REFLECTION-DEV794
-rw-r--r--php-pecl-pdflib-dev.spec280
2 files changed, 1074 insertions, 0 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
new file mode 100644
index 0000000..703b23c
--- /dev/null
+++ b/REFLECTION-DEV
@@ -0,0 +1,794 @@
+Extension [ <persistent> extension #113 PDFlib version 3.0.4 ] {
+
+ - Functions {
+ Function [ <internal:PDFlib> function pdf_activate_item ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_bookmark ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_launchlink ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_locallink ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_nameddest ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_note ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_pdflink ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_table_cell ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_textflow ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_thumbnail ] {
+ }
+ Function [ <internal:PDFlib> function pdf_add_weblink ] {
+ }
+ Function [ <internal:PDFlib> function pdf_arc ] {
+ }
+ Function [ <internal:PDFlib> function pdf_arcn ] {
+ }
+ Function [ <internal:PDFlib> function pdf_attach_file ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_document ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_font ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_glyph ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_item ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_layer ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_mc ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_page_ext ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_pattern ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_template ] {
+ }
+ Function [ <internal:PDFlib> function pdf_begin_template_ext ] {
+ }
+ Function [ <internal:PDFlib> function pdf_circle ] {
+ }
+ Function [ <internal:PDFlib> function pdf_clip ] {
+ }
+ Function [ <internal:PDFlib> function pdf_close ] {
+ }
+ Function [ <internal:PDFlib> function pdf_close_image ] {
+ }
+ Function [ <internal:PDFlib> function pdf_close_pdi ] {
+ }
+ Function [ <internal:PDFlib> function pdf_close_pdi_document ] {
+ }
+ Function [ <internal:PDFlib> function pdf_close_pdi_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_closepath ] {
+ }
+ Function [ <internal:PDFlib> function pdf_closepath_fill_stroke ] {
+ }
+ Function [ <internal:PDFlib> function pdf_closepath_stroke ] {
+ }
+ Function [ <internal:PDFlib> function pdf_concat ] {
+ }
+ Function [ <internal:PDFlib> function pdf_continue_text ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_3dview ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_action ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_annotation ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_bookmark ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_field ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_fieldgroup ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_gstate ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_pvf ] {
+ }
+ Function [ <internal:PDFlib> function pdf_create_textflow ] {
+ }
+ Function [ <internal:PDFlib> function pdf_curveto ] {
+ }
+ Function [ <internal:PDFlib> function pdf_define_layer ] {
+ }
+ Function [ <internal:PDFlib> function pdf_delete_pvf ] {
+ }
+ Function [ <internal:PDFlib> function pdf_delete_table ] {
+ }
+ Function [ <internal:PDFlib> function pdf_delete_textflow ] {
+ }
+ Function [ <internal:PDFlib> function pdf_encoding_set_char ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_document ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_font ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_glyph ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_item ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_layer ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_mc ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_page_ext ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_pattern ] {
+ }
+ Function [ <internal:PDFlib> function pdf_end_template ] {
+ }
+ Function [ <internal:PDFlib> function pdf_endpath ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fill ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fill_imageblock ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fill_pdfblock ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fill_stroke ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fill_textblock ] {
+ }
+ Function [ <internal:PDFlib> function pdf_findfont ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fit_image ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fit_pdi_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fit_table ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fit_textflow ] {
+ }
+ Function [ <internal:PDFlib> function pdf_fit_textline ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_apiname ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_buffer ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_errmsg ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_errnum ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_parameter ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_pdi_value ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_value ] {
+ }
+ Function [ <internal:PDFlib> function pdf_info_font ] {
+ }
+ Function [ <internal:PDFlib> function pdf_info_matchbox ] {
+ }
+ Function [ <internal:PDFlib> function pdf_info_table ] {
+ }
+ Function [ <internal:PDFlib> function pdf_info_textflow ] {
+ }
+ Function [ <internal:PDFlib> function pdf_info_textline ] {
+ }
+ Function [ <internal:PDFlib> function pdf_initgraphics ] {
+ }
+ Function [ <internal:PDFlib> function pdf_lineto ] {
+ }
+ Function [ <internal:PDFlib> function pdf_load_3ddata ] {
+ }
+ Function [ <internal:PDFlib> function pdf_load_font ] {
+ }
+ Function [ <internal:PDFlib> function pdf_load_iccprofile ] {
+ }
+ Function [ <internal:PDFlib> function pdf_load_image ] {
+ }
+ Function [ <internal:PDFlib> function pdf_makespotcolor ] {
+ }
+ Function [ <internal:PDFlib> function pdf_mc_point ] {
+ }
+ Function [ <internal:PDFlib> function pdf_moveto ] {
+ }
+ Function [ <internal:PDFlib> function pdf_open_ccitt ] {
+ }
+ Function [ <internal:PDFlib> function pdf_open_file ] {
+ }
+ Function [ <internal:PDFlib> function pdf_open_image_file ] {
+ }
+ Function [ <internal:PDFlib> function pdf_open_pdi_document ] {
+ }
+ Function [ <internal:PDFlib> function pdf_open_pdi_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_pcos_get_number ] {
+ }
+ Function [ <internal:PDFlib> function pdf_pcos_get_string ] {
+ }
+ Function [ <internal:PDFlib> function pdf_pcos_get_stream ] {
+ }
+ Function [ <internal:PDFlib> function pdf_place_image ] {
+ }
+ Function [ <internal:PDFlib> function pdf_place_pdi_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_process_pdi ] {
+ }
+ Function [ <internal:PDFlib> function pdf_rect ] {
+ }
+ Function [ <internal:PDFlib> function pdf_restore ] {
+ }
+ Function [ <internal:PDFlib> function pdf_resume_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_rotate ] {
+ }
+ Function [ <internal:PDFlib> function pdf_save ] {
+ }
+ Function [ <internal:PDFlib> function pdf_scale ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_border_color ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_border_dash ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_border_style ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_gstate ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_info ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_layer_dependency ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_parameter ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_text_pos ] {
+ }
+ Function [ <internal:PDFlib> function pdf_set_value ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setcolor ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setdash ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setdashpattern ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setflat ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setfont ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setgray ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setgray_fill ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setgray_stroke ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setlinecap ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setlinejoin ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setlinewidth ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setmatrix ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setmiterlimit ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setrgbcolor ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setrgbcolor_fill ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setrgbcolor_stroke ] {
+ }
+ Function [ <internal:PDFlib> function pdf_shading ] {
+ }
+ Function [ <internal:PDFlib> function pdf_shading_pattern ] {
+ }
+ Function [ <internal:PDFlib> function pdf_shfill ] {
+ }
+ Function [ <internal:PDFlib> function pdf_show ] {
+ }
+ Function [ <internal:PDFlib> function pdf_show_xy ] {
+ }
+ Function [ <internal:PDFlib> function pdf_skew ] {
+ }
+ Function [ <internal:PDFlib> function pdf_stringwidth ] {
+ }
+ Function [ <internal:PDFlib> function pdf_stroke ] {
+ }
+ Function [ <internal:PDFlib> function pdf_suspend_page ] {
+ }
+ Function [ <internal:PDFlib> function pdf_translate ] {
+ }
+ Function [ <internal:PDFlib> function pdf_utf16_to_utf8 ] {
+ }
+ Function [ <internal:PDFlib> function pdf_utf32_to_utf16 ] {
+ }
+ Function [ <internal:PDFlib> function pdf_new ] {
+ }
+ Function [ <internal:PDFlib> function pdf_delete ] {
+ }
+ Function [ <internal:PDFlib> function pdf_get_pdi_parameter ] {
+ }
+ Function [ <internal:PDFlib> function pdf_open_image ] {
+ }
+ Function [ <internal:PDFlib> function pdf_open_pdi ] {
+ }
+ Function [ <internal:PDFlib> function pdf_setpolydash ] {
+ }
+ Function [ <internal:PDFlib> function pdf_show_boxed ] {
+ }
+ }
+
+ - Classes [2] {
+ Class [ <internal:PDFlib> class PDFlibException extends Exception ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ Property [ <default> protected $apiname ]
+ }
+
+ - Methods [12] {
+ Method [ <internal:PDFlib> public method get_apiname ] {
+ }
+
+ Method [ <internal:PDFlib> public method get_errmsg ] {
+ }
+
+ Method [ <internal:PDFlib> public method get_errnum ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:PDFlib> class PDFlib ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [131] {
+ Method [ <internal:PDFlib> final public method activate_item ] {
+ }
+
+ Method [ <internal:PDFlib> final public method add_nameddest ] {
+ }
+
+ Method [ <internal:PDFlib> final public method add_table_cell ] {
+ }
+
+ Method [ <internal:PDFlib> final public method add_textflow ] {
+ }
+
+ Method [ <internal:PDFlib> final public method add_thumbnail ] {
+ }
+
+ Method [ <internal:PDFlib> final public method arc ] {
+ }
+
+ Method [ <internal:PDFlib> final public method arcn ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_document ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_font ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_glyph ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_item ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_layer ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_mc ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_page_ext ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_pattern ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_template ] {
+ }
+
+ Method [ <internal:PDFlib> final public method begin_template_ext ] {
+ }
+
+ Method [ <internal:PDFlib> final public method circle ] {
+ }
+
+ Method [ <internal:PDFlib> final public method clip ] {
+ }
+
+ Method [ <internal:PDFlib> final public method close_image ] {
+ }
+
+ Method [ <internal:PDFlib> final public method close_pdi ] {
+ }
+
+ Method [ <internal:PDFlib> final public method close_pdi_document ] {
+ }
+
+ Method [ <internal:PDFlib> final public method close_pdi_page ] {
+ }
+
+ Method [ <internal:PDFlib> final public method closepath ] {
+ }
+
+ Method [ <internal:PDFlib> final public method closepath_fill_stroke ] {
+ }
+
+ Method [ <internal:PDFlib> final public method closepath_stroke ] {
+ }
+
+ Method [ <internal:PDFlib> final public method concat ] {
+ }
+
+ Method [ <internal:PDFlib> final public method continue_text ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_3dview ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_action ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_annotation ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_bookmark ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_field ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_fieldgroup ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_gstate ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_pvf ] {
+ }
+
+ Method [ <internal:PDFlib> final public method create_textflow ] {
+ }
+
+ Method [ <internal:PDFlib> final public method curveto ] {
+ }
+
+ Method [ <internal:PDFlib> final public method define_layer ] {
+ }
+
+ Method [ <internal:PDFlib> final public method delete_pvf ] {
+ }
+
+ Method [ <internal:PDFlib> final public method delete_table ] {
+ }
+
+ Method [ <internal:PDFlib> final public method delete_textflow ] {
+ }
+
+ Method [ <internal:PDFlib> final public method encoding_set_char ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_document ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_font ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_glyph ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_item ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_layer ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_mc ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_page_ext ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_pattern ] {
+ }
+
+ Method [ <internal:PDFlib> final public method end_template ] {
+ }
+
+ Method [ <internal:PDFlib> final public method endpath ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fill ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fill_imageblock ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fill_pdfblock ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fill_stroke ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fill_textblock ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fit_image ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fit_pdi_page ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fit_table ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fit_textflow ] {
+ }
+
+ Method [ <internal:PDFlib> final public method fit_textline ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_apiname ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_buffer ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_errmsg ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_errnum ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_parameter ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_pdi_value ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_value ] {
+ }
+
+ Method [ <internal:PDFlib> final public method info_font ] {
+ }
+
+ Method [ <internal:PDFlib> final public method info_matchbox ] {
+ }
+
+ Method [ <internal:PDFlib> final public method info_table ] {
+ }
+
+ Method [ <internal:PDFlib> final public method info_textflow ] {
+ }
+
+ Method [ <internal:PDFlib> final public method info_textline ] {
+ }
+
+ Method [ <internal:PDFlib> final public method initgraphics ] {
+ }
+
+ Method [ <internal:PDFlib> final public method lineto ] {
+ }
+
+ Method [ <internal:PDFlib> final public method load_3ddata ] {
+ }
+
+ Method [ <internal:PDFlib> final public method load_font ] {
+ }
+
+ Method [ <internal:PDFlib> final public method load_iccprofile ] {
+ }
+
+ Method [ <internal:PDFlib> final public method load_image ] {
+ }
+
+ Method [ <internal:PDFlib> final public method makespotcolor ] {
+ }
+
+ Method [ <internal:PDFlib> final public method mc_point ] {
+ }
+
+ Method [ <internal:PDFlib> final public method moveto ] {
+ }
+
+ Method [ <internal:PDFlib> final public method open_pdi_document ] {
+ }
+
+ Method [ <internal:PDFlib> final public method open_pdi_page ] {
+ }
+
+ Method [ <internal:PDFlib> final public method pcos_get_number ] {
+ }
+
+ Method [ <internal:PDFlib> final public method pcos_get_string ] {
+ }
+
+ Method [ <internal:PDFlib> final public method pcos_get_stream ] {
+ }
+
+ Method [ <internal:PDFlib> final public method process_pdi ] {
+ }
+
+ Method [ <internal:PDFlib> final public method rect ] {
+ }
+
+ Method [ <internal:PDFlib> final public method restore ] {
+ }
+
+ Method [ <internal:PDFlib> final public method resume_page ] {
+ }
+
+ Method [ <internal:PDFlib> final public method rotate ] {
+ }
+
+ Method [ <internal:PDFlib> final public method save ] {
+ }
+
+ Method [ <internal:PDFlib> final public method scale ] {
+ }
+
+ Method [ <internal:PDFlib> final public method set_gstate ] {
+ }
+
+ Method [ <internal:PDFlib> final public method set_info ] {
+ }
+
+ Method [ <internal:PDFlib> final public method set_layer_dependency ] {
+ }
+
+ Method [ <internal:PDFlib> final public method set_parameter ] {
+ }
+
+ Method [ <internal:PDFlib> final public method set_text_pos ] {
+ }
+
+ Method [ <internal:PDFlib> final public method set_value ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setcolor ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setdash ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setdashpattern ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setflat ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setfont ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setlinecap ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setlinejoin ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setlinewidth ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setmatrix ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setmiterlimit ] {
+ }
+
+ Method [ <internal:PDFlib> final public method shading ] {
+ }
+
+ Method [ <internal:PDFlib> final public method shading_pattern ] {
+ }
+
+ Method [ <internal:PDFlib> final public method shfill ] {
+ }
+
+ Method [ <internal:PDFlib> final public method show ] {
+ }
+
+ Method [ <internal:PDFlib> final public method show_xy ] {
+ }
+
+ Method [ <internal:PDFlib> final public method skew ] {
+ }
+
+ Method [ <internal:PDFlib> final public method stringwidth ] {
+ }
+
+ Method [ <internal:PDFlib> final public method stroke ] {
+ }
+
+ Method [ <internal:PDFlib> final public method suspend_page ] {
+ }
+
+ Method [ <internal:PDFlib> final public method translate ] {
+ }
+
+ Method [ <internal:PDFlib> final public method utf16_to_utf8 ] {
+ }
+
+ Method [ <internal:PDFlib> final public method utf32_to_utf16 ] {
+ }
+
+ Method [ <internal:PDFlib, ctor> <visibility error> method __construct ] {
+ }
+
+ Method [ <internal:PDFlib> final public method delete ] {
+ }
+
+ Method [ <internal:PDFlib> final public method get_pdi_parameter ] {
+ }
+
+ Method [ <internal:PDFlib> final public method open_pdi ] {
+ }
+
+ Method [ <internal:PDFlib> final public method open_image ] {
+ }
+
+ Method [ <internal:PDFlib> final public method setpolydash ] {
+ }
+
+ Method [ <internal:PDFlib> final public method show_boxed ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-pdflib-dev.spec b/php-pecl-pdflib-dev.spec
new file mode 100644
index 0000000..a11e740
--- /dev/null
+++ b/php-pecl-pdflib-dev.spec
@@ -0,0 +1,280 @@
+# remirepo spec file for php-pecl-pdflib
+#
+# Copyright (c) 2006-2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%{?scl: %scl_package php-pecl-pdflib}
+
+%global with_zts 0%{?__ztsphp:1}
+%global pecl_name pdflib
+%global extname pdf
+%if "%{php_version}" < "5.6"
+%global ini_name %{extname}.ini
+%else
+%global ini_name 40-%{extname}.ini
+%endif
+
+Summary: Package for generating PDF files
+Name: %{?scl_prefix}php-pecl-pdflib
+Version: 3.0.4
+Release: 4%{?dist}%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}
+# https://bugs.php.net/60396 ask license file
+License: PHP
+Group: Development/Languages
+URL: http://pecl.php.net/package/pdflib
+
+Source0: http://pecl.php.net/get/pdflib-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: pdflib-lite-devel
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter private shared
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name}
+Obsoletes: php53u-pecl-%{pecl_name}
+Obsoletes: php54-pecl-%{pecl_name}
+Obsoletes: php54w-pecl-%{pecl_name}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name}
+Obsoletes: php55w-pecl-%{pecl_name}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name}
+Obsoletes: php56w-pecl-%{pecl_name}
+%endif
+%endif
+
+
+%description
+This PHP extension wraps the PDFlib programming library
+for processing PDF on the fly.
+
+More info on how to use PDFlib with PHP can be found at
+http://www.pdflib.com/developer-center/technical-documentation/php-howto
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -c -q
+
+# Check version
+extver=$(sed -n '/#define PHP_PDFLIB_VERSION/{s/.* "//;s/".*$//;p}' %{pecl_name}-%{version}/php_pdflib.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream version is ${extver}, expecting %{version}.
+ exit 1
+fi
+
+%if %{with_zts}
+cp -pr %{pecl_name}-%{version} %{pecl_name}-zts
+%endif
+
+# Create the config file
+cat > %{ini_name} << 'EOF'
+; Enable PDFlib extension module
+extension=%{extname}.so
+EOF
+
+
+%build
+cd %{pecl_name}-%{version}
+%{_bindir}/phpize
+%configure --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../%{pecl_name}-zts
+%{_bindir}/zts-phpize
+%configure --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C %{pecl_name}-%{version} install-modules INSTALL_ROOT=%{buildroot}
+
+# Drop in the bit of configuration
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C %{pecl_name}-zts install-modules INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Test & Documentation
+cd %{pecl_name}-%{version}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+%{__php} -n \
+ -d extension_dir=%{pecl_name}-%{version}/modules \
+ -d extension=%{extname}.so \
+ -m | grep -i %{extname}
+
+%if %{with_zts}
+%{__ztsphp} -n \
+ -d extension_dir=%{pecl_name}-zts/modules \
+ -d extension=%{extname}.so \
+ -m | grep -i %{extname}
+%endif
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-, root, root, -)
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{extname}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{extname}.so
+%endif
+
+
+%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 3.0.4-4
+- adapt for F24
+
+* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 3.0.4-3.1
+- Fedora 21 SCL mass rebuild
+
+* Mon Aug 25 2014 Remi Collet <remi@fedoraproject.org> - 3.0.4-3
+- allow SCL build
+
+* Wed Apr 16 2014 Remi Collet <remi@fedoraproject.org> - 3.0.4-2
+- add numerical prefix to extension configuration file (php 5.6)
+
+* Thu Jan 16 2014 Remi Collet <remi@fedoraproject.org> - 3.0.4-1
+- Update to 3.0.4 (stable)
+
+* Mon Dec 30 2013 Remi Collet <remi@fedoraproject.org> - 3.0.3-1
+- Update to 3.0.3 (stable)
+
+* Thu Dec 19 2013 Remi Collet <remi@fedoraproject.org> - 3.0.2-1
+- Update to 3.0.2 (stable)
+- move doc to pecl_docdir
+
+* Thu Jul 25 2013 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
+- Update to 3.0.1
+
+* Tue Apr 09 2013 Remi Collet <remi@fedoraproject.org> - 2.1.10-1
+- Update to 2.1.10
+
+* Wed Mar 20 2013 Remi Collet <RPMS@FamilleCollet.com> 2.1.9-2
+- cleanups
+
+* Sat Jun 09 2012 Remi Collet <RPMS@FamilleCollet.com> 2.1.9-1
+- update to 2.1.9
+
+* Sun Nov 27 2011 Remi Collet <RPMS@FamilleCollet.com> 2.1.8-3
+- php 5.4 build
+- add ZTS extension
+- add patch for PHP 5.4 https://bugs.php.net/60397
+- request upstream to provides LICENSE file https://bugs.php.net/60396
+
+* Sat Jul 23 2011 Remi Collet <rpmfusion@FamilleCollet.com> 2.1.8-2.1
+- fix %%check (php 5.1 doesnt have --modules)
+
+* Sat Jul 23 2011 Remi Collet <rpmfusion@FamilleCollet.com> 2.1.8-2
+- fix private-shared-object-provides rpmlint warning
+- fix macro usage
+- add %%check, minimal load test
+
+* Thu May 06 2010 Remi Collet <rpmfusion@FamilleCollet.com> 2.1.8-1
+- update to 2.1.8
+
+* Sat Oct 24 2009 Remi Collet <rpmfusion@FamilleCollet.com> 2.1.7-2
+- rebuild
+
+* Tue Jul 14 2009 Remi Collet <rpmfusion@FamilleCollet.com> 2.1.7-1
+- update to 2.1.7, rebuild against php 5.3.0
+
+* Sun Mar 29 2009 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 2.1.6-2
+- rebuild for new F11 features
+
+* Thu Mar 19 2009 Remi Collet <RPMS@FamilleCollet.com> 2.1.6-1
+- update to 2.1.6
+
+* Sun Sep 28 2008 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info - 2.1.5-2
+- rebuild
+
+* Fri Mar 28 2008 Remi Collet <RPMS@FamilleCollet.com> 2.1.5-2
+- rebuild against pdflib-lite-7.0.3
+
+* Sat Mar 15 2008 Remi Collet <RPMS@FamilleCollet.com> 2.1.5-1
+- update to 2.1.5
+
+* Tue Sep 25 2007 Remi Collet <RPMS@FamilleCollet.com> 2.1.4-2
+- add missing BR php-pear
+
+* Tue Sep 25 2007 Remi Collet <RPMS@FamilleCollet.com> 2.1.4-1
+- update to 2.1.4
+- convert package from v1 to v2
+- register extension (new PHP Guidelines)
+- remove License file (not provided upstream)
+
+* Sat Mar 17 2007 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-2
+- rebuild againt pdflib-lite-7.0.1
+
+* Fri Mar 9 2007 Remi Collet <RPMS@FamilleCollet.com> 2.1.3-1
+- requires php(zend-abi) and php(api) when available
+- update to 2.1.3
+
+* Sat Dec 09 2006 Remi Collet <RPMS@FamilleCollet.com> 2.1.2-1
+- initial spec for Livna