summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-01 14:24:46 +0100
committerRemi Collet <remi@remirepo.net>2018-03-01 14:24:46 +0100
commitfc345af2e08bac220d8a3482a7f74bf88a65befd (patch)
tree90335125ecdb0b14ca146b775e51ec6c98bedfd5
parentab85dfac00aa6e219f75477ae59ec97cc40b191d (diff)
add patch to fix build with gcc 8 from https://github.com/weltling/parle/pull/13
-rw-r--r--0001-fix-12-error-return-statement-with-a-value-in-functi.patch25
-rw-r--r--php-pecl-parle.spec22
2 files changed, 39 insertions, 8 deletions
diff --git a/0001-fix-12-error-return-statement-with-a-value-in-functi.patch b/0001-fix-12-error-return-statement-with-a-value-in-functi.patch
new file mode 100644
index 0000000..0838914
--- /dev/null
+++ b/0001-fix-12-error-return-statement-with-a-value-in-functi.patch
@@ -0,0 +1,25 @@
+From 96d67113f86be5ef8aea4eb072391146e3fd0aff Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 1 Mar 2018 14:12:38 +0100
+Subject: [PATCH] fix #12 - error: return-statement with a value, in function
+ returning 'void'
+
+---
+ lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp b/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp
+index 5033172..b3626cb 100644
+--- a/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp
++++ b/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp
+@@ -76,7 +76,6 @@ struct basic_re_tokeniser_state
+ _paren_count = rhs_._paren_count;
+ _in_string = rhs_._in_string;
+ _nl_id = rhs_._nl_id;
+- return this;
+ }
+
+ inline bool next(char_type &ch_)
+--
+2.14.3
+
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index 31f81c6..c38981d 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -1,11 +1,15 @@
# remirepo spec file for php-pecl-parle
#
-# Copyright (c) 2017 Remi Collet
+# Copyright (c) 2017-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%scl_package php-pecl-parle
%global sub_prefix %{scl_prefix}
@@ -27,13 +31,14 @@ BuildRequires: devtoolset-6-toolchain
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.7.3
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
-Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Patch0: 0001-fix-12-error-return-statement-with-a-value-in-functi.patch
+
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -106,6 +111,8 @@ mv NTS/lib/parsertl14/parsertl/licence_1_0.txt NTS/LICENSE.parsertl14
%endif
cd NTS
+%patch0 -p1
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -199,11 +206,6 @@ make test
%endif
%endif
-%if %{with_tests}
-# Upstream test suite
-make test
-%endif
-
%if 0%{?fedora} < 24
# when pear installed alone, after us
@@ -240,6 +242,10 @@ fi
%changelog
+* Thu Mar 1 2018 Remi Collet <remi@remirepo.net> - 0.7.3-2
+- add patch to fix build with gcc 8
+ from https://github.com/weltling/parle/pull/13
+
* Sun Nov 12 2017 Remi Collet <remi@remirepo.net> - 0.7.3-1
- Update to 0.7.3