summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-12 08:13:41 +0100
committerRemi Collet <remi@remirepo.net>2017-11-12 08:13:41 +0100
commitab85dfac00aa6e219f75477ae59ec97cc40b191d (patch)
tree623d8ce1e6a2f0545925c983b226f54cb398ec8a
parentd4dfc0412f57d8f7c695472c3932793667cee330 (diff)
v0.7.3
-rw-r--r--REFLECTION26
-rw-r--r--php-pecl-parle.spec5
2 files changed, 27 insertions, 4 deletions
diff --git a/REFLECTION b/REFLECTION
index adfa660..8e22352 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,8 @@
-Extension [ <persistent> extension #116 parle version 0.7.1 ] {
+Extension [ <persistent> extension #118 parle version 0.7.3 ] {
+
+ - Constants [1] {
+ Constant [ boolean Parle\INTERNAL_UTF32 ] { }
+ }
- Classes [10] {
Class [ <internal:parle> class Parle\ErrorInfo ] {
@@ -69,7 +73,7 @@ Extension [ <persistent> extension #116 parle version 0.7.1 ] {
Property [ <default> public $cursor ]
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:parle> public method push ] {
}
@@ -114,6 +118,14 @@ Extension [ <persistent> extension #116 parle version 0.7.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:parle> public method callout ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> integer $id ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
}
}
@@ -141,7 +153,7 @@ Extension [ <persistent> extension #116 parle version 0.7.1 ] {
Property [ <default> public $cursor ]
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:parle> public method push ] {
}
@@ -194,6 +206,14 @@ Extension [ <persistent> extension #116 parle version 0.7.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:parle> public method callout ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> integer $id ]
+ Parameter #1 [ <required> $callback ]
+ }
+ }
}
}
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index 2034bea..31f81c6 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -26,7 +26,7 @@ BuildRequires: devtoolset-6-toolchain
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.7.1
+Version: 0.7.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
@@ -240,6 +240,9 @@ fi
%changelog
+* Sun Nov 12 2017 Remi Collet <remi@remirepo.net> - 0.7.3-1
+- Update to 0.7.3
+
* Mon Oct 30 2017 Remi Collet <remi@remirepo.net> - 0.7.1-1
- Update to 0.7.1