summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-20 06:58:01 +0200
committerRemi Collet <remi@remirepo.net>2017-09-20 06:58:01 +0200
commit99fb05b855e082a090b5559d9f4d9db494860ccb (patch)
tree13190ea0473277fd8e9919a110772a3b519837af
parent3498c952f346fac399ce548c4040bdde5eb325e3 (diff)
v0.6.2
-rw-r--r--REFLECTION34
-rw-r--r--php-pecl-parle.spec5
2 files changed, 28 insertions, 11 deletions
diff --git a/REFLECTION b/REFLECTION
index 774e8c7..30358fe 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 parle version 0.6.1 ] {
+Extension [ <persistent> extension #115 parle version 0.6.2 ] {
- Classes [9] {
Class [ <internal:parle> class Parle\ErrorInfo ] {
@@ -12,8 +12,9 @@ Extension [ <persistent> extension #115 parle version 0.6.1 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [3] {
Property [ <default> public $id ]
+ Property [ <default> public $position ]
Property [ <default> public $token ]
}
@@ -25,8 +26,8 @@ Extension [ <persistent> extension #115 parle version 0.6.1 ] {
- Constants [3] {
Constant [ integer EOI ] { 0 }
- Constant [ integer UNKNOWN ] { -1 }
- Constant [ integer SKIP ] { -2 }
+ Constant [ integer UNKNOWN ] { 65535 }
+ Constant [ integer SKIP ] { 65534 }
}
- Static properties [0] {
@@ -35,10 +36,9 @@ Extension [ <persistent> extension #115 parle version 0.6.1 ] {
- Static methods [0] {
}
- - Properties [3] {
+ - Properties [2] {
Property [ <default> public $id ]
Property [ <default> public $value ]
- Property [ <default> public $offset ]
}
- Methods [0] {
@@ -61,7 +61,12 @@ Extension [ <persistent> extension #115 parle version 0.6.1 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [5] {
+ Property [ <default> public $bol ]
+ Property [ <default> public $flags ]
+ Property [ <default> public $state ]
+ Property [ <default> public $marker ]
+ Property [ <default> public $cursor ]
}
- Methods [8] {
@@ -128,7 +133,12 @@ Extension [ <persistent> extension #115 parle version 0.6.1 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [5] {
+ Property [ <default> public $bol ]
+ Property [ <default> public $flags ]
+ Property [ <default> public $state ]
+ Property [ <default> public $marker ]
+ Property [ <default> public $cursor ]
}
- Methods [9] {
@@ -206,7 +216,9 @@ Extension [ <persistent> extension #115 parle version 0.6.1 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [2] {
+ Property [ <default> public $action ]
+ Property [ <default> public $reduceId ]
}
- Methods [15] {
@@ -330,7 +342,9 @@ Extension [ <persistent> extension #115 parle version 0.6.1 ] {
- Static methods [0] {
}
- - Properties [0] {
+ - Properties [2] {
+ Property [ <default> public $empty ]
+ Property [ <default> public $size ]
}
- Methods [5] {
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index 520107f..71bf4b7 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -26,7 +26,7 @@ BuildRequires: devtoolset-6-toolchain
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.6.1
+Version: 0.6.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
@@ -240,6 +240,9 @@ fi
%changelog
+* Wed Sep 20 2017 Remi Collet <remi@remirepo.net> - 0.6.2-1
+- Update to 0.6.2
+
* Mon Sep 18 2017 Remi Collet <remi@remirepo.net> - 0.6.1-1
- Update to 0.6.1