summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-03-05 05:46:21 +0100
committerRemi Collet <remi@remirepo.net>2018-03-05 05:46:21 +0100
commit74c0cef4d8df724b921b09f75a731c1e0d777a2f (patch)
tree65ef7e0a2ef4167372099f1876d5c5a8a397f09a
parentfc345af2e08bac220d8a3482a7f74bf88a65befd (diff)
v0.8.1
-rw-r--r--0001-fix-12-error-return-statement-with-a-value-in-functi.patch25
-rw-r--r--REFLECTION60
-rw-r--r--php-pecl-parle.spec11
3 files changed, 35 insertions, 61 deletions
diff --git a/0001-fix-12-error-return-statement-with-a-value-in-functi.patch b/0001-fix-12-error-return-statement-with-a-value-in-functi.patch
deleted file mode 100644
index 0838914..0000000
--- a/0001-fix-12-error-return-statement-with-a-value-in-functi.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 96d67113f86be5ef8aea4eb072391146e3fd0aff Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 1 Mar 2018 14:12:38 +0100
-Subject: [PATCH] fix #12 - error: return-statement with a value, in function
- returning 'void'
-
----
- lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp b/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp
-index 5033172..b3626cb 100644
---- a/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp
-+++ b/lib/lexertl14/lexertl/parser/tokeniser/re_tokeniser_state.hpp
-@@ -76,7 +76,6 @@ struct basic_re_tokeniser_state
- _paren_count = rhs_._paren_count;
- _in_string = rhs_._in_string;
- _nl_id = rhs_._nl_id;
-- return this;
- }
-
- inline bool next(char_type &ch_)
---
-2.14.3
-
diff --git a/REFLECTION b/REFLECTION
index 8e22352..a69a0dd 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #118 parle version 0.7.3 ] {
+Extension [ <persistent> extension #119 parle version 0.8.1 ] {
- Constants [1] {
Constant [ boolean Parle\INTERNAL_UTF32 ] { }
@@ -29,9 +29,9 @@ Extension [ <persistent> extension #118 parle version 0.7.3 ] {
Class [ <internal:parle> class Parle\Token ] {
- Constants [3] {
- Constant [ integer EOI ] { 0 }
- Constant [ integer UNKNOWN ] { 65535 }
- Constant [ integer SKIP ] { 65534 }
+ Constant [ public integer EOI ] { 0 }
+ Constant [ public integer UNKNOWN ] { 65535 }
+ Constant [ public integer SKIP ] { 65534 }
}
- Static properties [0] {
@@ -52,11 +52,11 @@ Extension [ <persistent> extension #118 parle version 0.7.3 ] {
Class [ <internal:parle> class Parle\Lexer ] {
- Constants [5] {
- Constant [ integer ICASE ] { 1 }
- Constant [ integer DOT_NOT_LF ] { 2 }
- Constant [ integer DOT_NOT_CRLF ] { 4 }
- Constant [ integer SKIP_WS ] { 8 }
- Constant [ integer MATCH_ZERO_LEN ] { 16 }
+ Constant [ public integer ICASE ] { 1 }
+ Constant [ public integer DOT_NOT_LF ] { 2 }
+ Constant [ public integer DOT_NOT_CRLF ] { 4 }
+ Constant [ public integer SKIP_WS ] { 8 }
+ Constant [ public integer MATCH_ZERO_LEN ] { 16 }
}
- Static properties [0] {
@@ -132,11 +132,11 @@ Extension [ <persistent> extension #118 parle version 0.7.3 ] {
Class [ <internal:parle> class Parle\RLexer ] {
- Constants [5] {
- Constant [ integer ICASE ] { 1 }
- Constant [ integer DOT_NOT_LF ] { 2 }
- Constant [ integer DOT_NOT_CRLF ] { 4 }
- Constant [ integer SKIP_WS ] { 8 }
- Constant [ integer MATCH_ZERO_LEN ] { 16 }
+ Constant [ public integer ICASE ] { 1 }
+ Constant [ public integer DOT_NOT_LF ] { 2 }
+ Constant [ public integer DOT_NOT_CRLF ] { 4 }
+ Constant [ public integer SKIP_WS ] { 8 }
+ Constant [ public integer MATCH_ZERO_LEN ] { 16 }
}
- Static properties [0] {
@@ -220,14 +220,14 @@ Extension [ <persistent> extension #118 parle version 0.7.3 ] {
Class [ <internal:parle> class Parle\Parser ] {
- Constants [8] {
- Constant [ integer ACTION_ERROR ] { 0 }
- Constant [ integer ACTION_SHIFT ] { 1 }
- Constant [ integer ACTION_REDUCE ] { 2 }
- Constant [ integer ACTION_GOTO ] { 3 }
- Constant [ integer ACTION_ACCEPT ] { 4 }
- Constant [ integer ERROR_SYNTAX ] { 0 }
- Constant [ integer ERROR_NON_ASSOCIATIVE ] { 1 }
- Constant [ integer ERROR_UNKOWN_TOKEN ] { 2 }
+ Constant [ public integer ACTION_ERROR ] { 0 }
+ Constant [ public integer ACTION_SHIFT ] { 1 }
+ Constant [ public integer ACTION_REDUCE ] { 2 }
+ Constant [ public integer ACTION_GOTO ] { 3 }
+ Constant [ public integer ACTION_ACCEPT ] { 4 }
+ Constant [ public integer ERROR_SYNTAX ] { 0 }
+ Constant [ public integer ERROR_NON_ASSOCIATIVE ] { 1 }
+ Constant [ public integer ERROR_UNKNOWN_TOKEN ] { 2 }
}
- Static properties [0] {
@@ -363,14 +363,14 @@ Extension [ <persistent> extension #118 parle version 0.7.3 ] {
Class [ <internal:parle> class Parle\RParser ] {
- Constants [8] {
- Constant [ integer ACTION_ERROR ] { 0 }
- Constant [ integer ACTION_SHIFT ] { 1 }
- Constant [ integer ACTION_REDUCE ] { 2 }
- Constant [ integer ACTION_GOTO ] { 3 }
- Constant [ integer ACTION_ACCEPT ] { 4 }
- Constant [ integer ERROR_SYNTAX ] { 0 }
- Constant [ integer ERROR_NON_ASSOCIATIVE ] { 1 }
- Constant [ integer ERROR_UNKOWN_TOKEN ] { 2 }
+ Constant [ public integer ACTION_ERROR ] { 0 }
+ Constant [ public integer ACTION_SHIFT ] { 1 }
+ Constant [ public integer ACTION_REDUCE ] { 2 }
+ Constant [ public integer ACTION_GOTO ] { 3 }
+ Constant [ public integer ACTION_ACCEPT ] { 4 }
+ Constant [ public integer ERROR_SYNTAX ] { 0 }
+ Constant [ public integer ERROR_NON_ASSOCIATIVE ] { 1 }
+ Constant [ public integer ERROR_UNKNOWN_TOKEN ] { 2 }
}
- Static properties [0] {
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index c38981d..02ecb26 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -30,15 +30,13 @@ BuildRequires: devtoolset-6-toolchain
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.7.3
+Version: 0.8.1
Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-Patch0: 0001-fix-12-error-return-statement-with-a-value-in-functi.patch
-
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
@@ -111,8 +109,6 @@ mv NTS/lib/parsertl14/parsertl/licence_1_0.txt NTS/LICENSE.parsertl14
%endif
cd NTS
-%patch0 -p1
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -207,7 +203,7 @@ make test
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -242,6 +238,9 @@ fi
%changelog
+* Mon Mar 5 2018 Remi Collet <remi@remirepo.net> - 0.8.1-1
+- Update to 0.8.1
+
* Thu Mar 1 2018 Remi Collet <remi@remirepo.net> - 0.7.3-2
- add patch to fix build with gcc 8
from https://github.com/weltling/parle/pull/13