summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-09 17:40:36 +0200
committerRemi Collet <remi@remirepo.net>2017-09-09 17:40:36 +0200
commit41f435ef2f82a049dea60f71f8d5311a703c7927 (patch)
tree2154100abb0259a52282179f2f2deecfa2e02f6a
parentb23ca0c48d9f564ba9833d26f0639773f4476e03 (diff)
Update to 0.5.3
open https://github.com/weltling/parle/pull/8 - cxx extension drop devel sub-package open https://github.com/weltling/parle/pull/7 - PHP 7.2 build error
-rw-r--r--REFLECTION100
-rw-r--r--licence_1_0.txt24
-rw-r--r--php-pecl-parle.spec60
3 files changed, 73 insertions, 111 deletions
diff --git a/REFLECTION b/REFLECTION
index e6bc66b..49c000a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,6 +1,50 @@
-Extension [ <persistent> extension #115 parle version 0.5.1 ] {
+Extension [ <persistent> extension #115 parle version 0.5.3 ] {
+
+ - Classes [8] {
+ Class [ <internal:parle> class Parle\ErrorInfo ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ <default> public $id ]
+ Property [ <default> public $token ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:parle> class Parle\Token ] {
+
+ - Constants [3] {
+ Constant [ integer EOI ] { 0 }
+ Constant [ integer UNKNOWN ] { -1 }
+ Constant [ integer SKIP ] { -2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ <default> public $id ]
+ Property [ <default> public $value ]
+ Property [ <default> public $offset ]
+ }
+
+ - Methods [0] {
+ }
+ }
- - Classes [6] {
Class [ <internal:parle> class Parle\Lexer ] {
- Constants [5] {
@@ -20,7 +64,7 @@ Extension [ <persistent> extension #115 parle version 0.5.1 ] {
- Properties [0] {
}
- - Methods [13] {
+ - Methods [10] {
Method [ <internal:parle> public method push ] {
}
@@ -28,7 +72,7 @@ Extension [ <persistent> extension #115 parle version 0.5.1 ] {
- Parameters [0] {
}
- - Return [ array ]
+ - Return [ object ]
}
Method [ <internal:parle> public method build ] {
@@ -44,33 +88,12 @@ Extension [ <persistent> extension #115 parle version 0.5.1 ] {
}
}
- Method [ <internal:parle> public method skip ] {
-
- - Parameters [0] {
- }
- - Return [ integer ]
- }
-
- Method [ <internal:parle> public method eoi ] {
-
- - Parameters [0] {
- }
- - Return [ integer ]
- }
-
Method [ <internal:parle> public method advance ] {
- Parameters [0] {
}
}
- Method [ <internal:parle> public method npos ] {
-
- - Parameters [0] {
- }
- - Return [ integer ]
- }
-
Method [ <internal:parle> public method bol ] {
- Parameters [1] {
@@ -124,7 +147,7 @@ Extension [ <persistent> extension #115 parle version 0.5.1 ] {
- Properties [0] {
}
- - Methods [15] {
+ - Methods [12] {
Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method push ] {
}
@@ -132,7 +155,7 @@ Extension [ <persistent> extension #115 parle version 0.5.1 ] {
- Parameters [0] {
}
- - Return [ array ]
+ - Return [ object ]
}
Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method build ] {
@@ -148,33 +171,12 @@ Extension [ <persistent> extension #115 parle version 0.5.1 ] {
}
}
- Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method skip ] {
-
- - Parameters [0] {
- }
- - Return [ integer ]
- }
-
- Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method eoi ] {
-
- - Parameters [0] {
- }
- - Return [ integer ]
- }
-
Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method advance ] {
- Parameters [0] {
}
}
- Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method npos ] {
-
- - Parameters [0] {
- }
- - Return [ integer ]
- }
-
Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method bol ] {
- Parameters [1] {
@@ -365,7 +367,7 @@ Extension [ <persistent> extension #115 parle version 0.5.1 ] {
- Parameters [0] {
}
- - Return [ array ]
+ - Return [ object ]
}
}
}
diff --git a/licence_1_0.txt b/licence_1_0.txt
deleted file mode 100644
index d1c4c6c..0000000
--- a/licence_1_0.txt
+++ /dev/null
@@ -1,24 +0,0 @@
-Boost Software License - Version 1.0 - August 17th, 2003
-
-Permission is hereby granted, free of charge, to any person or organization
-obtaining a copy of the software and accompanying documentation covered by
-this license (the "Software") to use, reproduce, display, distribute,
-execute, and transmit the Software, and to prepare derivative works of the
-Software, and to permit third-parties to whom the Software is furnished to
-do so, all subject to the following:
-
-The copyright notices in the Software and this entire statement, including
-the above license grant, this restriction and the following disclaimer,
-must be included in all copies of the Software, in whole or in part, and
-all derivative works of the Software, unless such copies or derivative
-works are solely in the form of machine-executable object code generated by
-a source language processor.
-
-THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT
-SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE
-FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE,
-ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
-DEALINGS IN THE SOFTWARE.
-
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
index c3fcd4c..28549ef 100644
--- a/php-pecl-parle.spec
+++ b/php-pecl-parle.spec
@@ -26,15 +26,13 @@ BuildRequires: devtoolset-6-toolchain
Summary: Parsing and lexing
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 0.5.1
+Version: 0.5.3
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# Extension is BSD, libraries are Boost
License: BSD and Boost
Group: Development/Languages
URL: http://pecl.php.net/package/%{pecl_name}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
-# https://github.com/weltling/parle/pull/1
-Source1: https://raw.githubusercontent.com/weltling/parle/master/lib/lexertl14/lexertl/licence_1_0.txt
BuildRequires: %{?scl_prefix}php-devel >= 7
BuildRequires: %{?scl_prefix}php-pear
@@ -60,6 +58,8 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
+Obsoletes: %{name}-devel < %{version}
+
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
@@ -88,34 +88,22 @@ generator tools for C/C++.
Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
-%package devel
-Summary: %{name} developer files (header)
-Group: Development/Libraries
-Requires: %{name}%{?_isa} = %{version}-%{release}
-Requires: %{?scl_prefix}php-devel%{?_isa}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
-%endif
-
-%description devel
-These are the files needed to compile programs using %{name}
-and upstream test suite.
-
-
%prep
%setup -qc
mv %{pecl_name}-%{version} NTS
-# Don't install/register
-# see https://github.com/weltling/parle/pull/2
-sed %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/;/license/s/role="doc"/role="src"/'} \
- -e '/tests/s/role=".*"/role="test"/'\
+# Don't install/register tests
+sed -e '/tests/s/role="test"/role="src"/'\
-i package.xml
-cd NTS
-cp %{SOURCE1} lib/lexertl14/lexertl/licence_1_0.txt
+%if 0%{?_licensedir:1}
+sed -e '/LICENSE/s/role="doc"/role="src"/;/licence/s/role="doc"/role="src"/' \
+ -i package.xml
+mv NTS/lib/lexertl14/lexertl/licence_1_0.txt NTS/LICENSE.lexert14
+mv NTS/lib/parsertl14/parsertl/licence_1_0.txt NTS/LICENSE.parsertl14
+%endif
+cd NTS
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -175,10 +163,7 @@ make -C ZTS install INSTALL_ROOT=%{buildroot}
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-# Test & Documentation
-for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
-done
+# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -239,8 +224,7 @@ fi
%files
-%{?_licensedir:%license NTS/LICENSE}
-%{?_licensedir:%license NTS/lib/lexertl14/lexertl/licence_1_0.txt}
+%{?_licensedir:%license NTS/LICENSE*}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
@@ -253,16 +237,16 @@ fi
%endif
-%files devel
-%doc %{pecl_testdir}/%{pecl_name}
-%{php_incldir}/ext/%{pecl_name}
-
-%if %{with_zts}
-%{php_ztsincldir}/ext/%{pecl_name}
-%endif
+%changelog
+* Sat Sep 9 2017 Remi Collet <remi@remirepo.net> - 0.5.3-1
+- Update to 0.5.3
+- open https://github.com/weltling/parle/pull/8 - cxx extension
+* Sat Sep 9 2017 Remi Collet <remi@remirepo.net> - 0.5.2-1
+- Update to 0.5.2
+- drop devel sub-package
+- https://github.com/weltling/parle/pull/7 - PHP 7.2 build error
-%changelog
* Sat Sep 9 2017 Remi Collet <remi@remirepo.net> - 0.5.1-1
- initial package, version 0.5.1 (alpha)
- open https://github.com/BenHanson/parsertl14/issues/1 license file