summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-09 07:59:22 +0200
committerRemi Collet <remi@remirepo.net>2017-09-09 07:59:22 +0200
commitb23ca0c48d9f564ba9833d26f0639773f4476e03 (patch)
tree267b448ebac59a0b94469dd11b443e6075700cb4
initial package, version 0.5.1 (alpha)
open https://github.com/BenHanson/parsertl14/issues/1 license file open https://github.com/weltling/parle/pull/1 missing license file open https://github.com/weltling/parle/pull/2 fix roles open https://github.com/weltling/parle/issues/3 is header needed
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--REFLECTION539
-rw-r--r--licence_1_0.txt24
-rw-r--r--php-pecl-parle.spec271
5 files changed, 846 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..e6bc66b
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,539 @@
+Extension [ <persistent> extension #115 parle version 0.5.1 ] {
+
+ - Classes [6] {
+ Class [ <internal:parle> class Parle\Lexer ] {
+
+ - Constants [5] {
+ Constant [ integer FLAG_REGEX_ICASE ] { 1 }
+ Constant [ integer FLAG_REGEX_DOT_NOT_LF ] { 2 }
+ Constant [ integer FLAG_REGEX_DOT_NOT_CR_LF ] { 4 }
+ Constant [ integer FLAG_REGEX_SKIP_WS ] { 8 }
+ Constant [ integer FLAG_REGEX_MATCH_ZERO_LEN ] { 16 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [13] {
+ Method [ <internal:parle> public method push ] {
+ }
+
+ Method [ <internal:parle> public method getToken ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:parle> public method build ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle> public method consume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ }
+
+ Method [ <internal:parle> public method skip ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method eoi ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method advance ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle> public method npos ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method bol ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> boolean $bol ]
+ }
+ - Return [ boolean or NULL ]
+ }
+
+ Method [ <internal:parle> public method restart ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> integer $pos ]
+ }
+ }
+
+ Method [ <internal:parle> public method insertMacro ] {
+ }
+
+ Method [ <internal:parle> public method dump ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle> public method flags ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $state ]
+ }
+ - Return [ integer ]
+ }
+ }
+ }
+
+ Class [ <internal:parle> class Parle\RLexer extends Parle\Lexer ] {
+
+ - Constants [5] {
+ Constant [ integer FLAG_REGEX_ICASE ] { 1 }
+ Constant [ integer FLAG_REGEX_DOT_NOT_LF ] { 2 }
+ Constant [ integer FLAG_REGEX_DOT_NOT_CR_LF ] { 4 }
+ Constant [ integer FLAG_REGEX_SKIP_WS ] { 8 }
+ Constant [ integer FLAG_REGEX_MATCH_ZERO_LEN ] { 16 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [15] {
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method push ] {
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method getToken ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method build ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method consume ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method skip ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method eoi ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method advance ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method npos ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method bol ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> boolean $bol ]
+ }
+ - Return [ boolean or NULL ]
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method restart ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> integer $pos ]
+ }
+ }
+
+ Method [ <internal:parle> public method pushState ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $state ]
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method state ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method insertMacro ] {
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method dump ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle, overwrites Parle\Lexer, prototype Parle\Lexer> public method flags ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $state ]
+ }
+ - Return [ integer ]
+ }
+ }
+ }
+
+ Class [ <internal:parle> class Parle\Parser ] {
+
+ - Constants [8] {
+ Constant [ integer ACTION_ERROR ] { 0 }
+ Constant [ integer ACTION_SHIFT ] { 1 }
+ Constant [ integer ACTION_REDUCE ] { 2 }
+ Constant [ integer ACTION_GOTO ] { 3 }
+ Constant [ integer ACTION_ACCEPT ] { 4 }
+ Constant [ integer ERROR_SYNTAX ] { 0 }
+ Constant [ integer ERROR_NON_ASSOCIATIVE ] { 1 }
+ Constant [ integer ERROR_UNKOWN_TOKEN ] { 2 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [17] {
+ Method [ <internal:parle> public method token ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tok ]
+ }
+ }
+
+ Method [ <internal:parle> public method left ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tok ]
+ }
+ }
+
+ Method [ <internal:parle> public method right ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tok ]
+ }
+ }
+
+ Method [ <internal:parle> public method nonassoc ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tok ]
+ }
+ }
+
+ Method [ <internal:parle> public method precedence ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tok ]
+ }
+ }
+
+ Method [ <internal:parle> public method build ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle> public method push ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> string $rule ]
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method validate ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:parle> public method tokenId ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tok ]
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method reduceId ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method action ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method sigil ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> integer $idx ]
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:parle> public method advance ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle> public method consume ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $data ]
+ Parameter #1 [ <required> $lexer ]
+ }
+ }
+
+ Method [ <internal:parle> public method dump ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle> public method trace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:parle> public method errorInfo ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:parle> class Parle\Stack ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [5] {
+ Method [ <internal:parle> public method empty ] {
+
+ - Parameters [0] {
+ }
+ - Return [ boolean ]
+ }
+
+ Method [ <internal:parle> public method pop ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:parle> public method push ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $item ]
+ }
+ }
+
+ Method [ <internal:parle> public method size ] {
+
+ - Parameters [0] {
+ }
+ - Return [ integer ]
+ }
+
+ Method [ <internal:parle> public method top ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $new_top ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:parle> class Parle\LexerException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:parle> class Parle\ParserException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+ }
+}
+
diff --git a/licence_1_0.txt b/licence_1_0.txt
new file mode 100644
index 0000000..d1c4c6c
--- /dev/null
+++ b/licence_1_0.txt
@@ -0,0 +1,24 @@
+Boost Software License - Version 1.0 - August 17th, 2003
+
+Permission is hereby granted, free of charge, to any person or organization
+obtaining a copy of the software and accompanying documentation covered by
+this license (the "Software") to use, reproduce, display, distribute,
+execute, and transmit the Software, and to prepare derivative works of the
+Software, and to permit third-parties to whom the Software is furnished to
+do so, all subject to the following:
+
+The copyright notices in the Software and this entire statement, including
+the above license grant, this restriction and the following disclaimer,
+must be included in all copies of the Software, in whole or in part, and
+all derivative works of the Software, unless such copies or derivative
+works are solely in the form of machine-executable object code generated by
+a source language processor.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE, TITLE AND NON-INFRINGEMENT. IN NO EVENT
+SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE SOFTWARE BE LIABLE
+FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR OTHERWISE,
+ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+DEALINGS IN THE SOFTWARE.
+
diff --git a/php-pecl-parle.spec b/php-pecl-parle.spec
new file mode 100644
index 0000000..c3fcd4c
--- /dev/null
+++ b/php-pecl-parle.spec
@@ -0,0 +1,271 @@
+# remirepo spec file for php-pecl-parle
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%scl_package php-pecl-parle
+%global sub_prefix %{scl_prefix}
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global with_tests 0%{!?_without_tests:1}
+%global pecl_name parle
+# After json
+%global ini_name 40-%{pecl_name}.ini
+
+%if 0%{?rhel}
+# Always use DTS as c++14 is required
+BuildRequires: devtoolset-6-toolchain
+%global dtsenable source /opt/rh/devtoolset-6/enable
+%global dtsprefix devtoolset-6-
+%endif
+
+Summary: Parsing and lexing
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 0.5.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+# Extension is BSD, libraries are Boost
+License: BSD and Boost
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+# https://github.com/weltling/parle/pull/1
+Source1: https://raw.githubusercontent.com/weltling/parle/master/lib/lexertl14/lexertl/licence_1_0.txt
+
+BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
+BuildRequires: %{?dtsprefix}gcc-c++
+BuildRequires: %{?dtsprefix}libstdc++-devel
+
+# bundled libraries
+Provides: bundled(parsertl)
+Provides: bundled(lexertl)
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: %{?scl_prefix}php-json%{?_isa}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+With Parle, it is possible to implement lexing and parsing in PHP
+while relying on features and principles of the parser/lexer
+generator tools for C/C++.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%package devel
+Summary: %{name} developer files (header)
+Group: Development/Libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: %{?scl_prefix}php-devel%{?_isa}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
+%endif
+
+%description devel
+These are the files needed to compile programs using %{name}
+and upstream test suite.
+
+
+%prep
+%setup -qc
+mv %{pecl_name}-%{version} NTS
+
+# Don't install/register
+# see https://github.com/weltling/parle/pull/2
+sed %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/;/license/s/role="doc"/role="src"/'} \
+ -e '/tests/s/role=".*"/role="test"/'\
+ -i package.xml
+
+cd NTS
+cp %{SOURCE1} lib/lexertl14/lexertl/licence_1_0.txt
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_PARLE_VERSION/{s/.* "//;s/".*$//;p}' php_parle.h)
+if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?prever:-%{prever}}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+peclbuild() {
+%configure \
+ --enable-parle \
+ --with-php-config=$1
+
+make %{?_smp_mflags}
+}
+
+cd NTS
+%{_bindir}/phpize
+peclbuild %{_bindir}/php-config
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+peclbuild %{_bindir}/zts-php-config
+%endif
+
+
+%install
+%{?dtsenable}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Test & Documentation
+for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+done
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+export NO_INTERACTION=1
+export REPORT_EXIT_STATUS=1
+
+: Minimal load test for NTS extension
+cd NTS
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite
+make test
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite
+make test
+%endif
+%endif
+
+%if %{with_tests}
+# Upstream test suite
+make test
+%endif
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license NTS/lib/lexertl14/lexertl/licence_1_0.txt}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%files devel
+%doc %{pecl_testdir}/%{pecl_name}
+%{php_incldir}/ext/%{pecl_name}
+
+%if %{with_zts}
+%{php_ztsincldir}/ext/%{pecl_name}
+%endif
+
+
+%changelog
+* Sat Sep 9 2017 Remi Collet <remi@remirepo.net> - 0.5.1-1
+- initial package, version 0.5.1 (alpha)
+- open https://github.com/BenHanson/parsertl14/issues/1 license file
+- open https://github.com/weltling/parle/pull/1 missing license file
+- open https://github.com/weltling/parle/pull/2 fix roles
+- open https://github.com/weltling/parle/issues/3 is header needed