summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-25 07:55:40 +0100
committerRemi Collet <remi@php.net>2022-01-25 07:55:40 +0100
commitdf14bc9fb8b8f3f91a7bc67b018d720b85447d2c (patch)
treeee1d8fd20dcd51dbe2737d6c14124d2b4e23c7aa
parent965222743cd637bc0d5087cd530eb8cac141e920 (diff)
update to 4.10.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION56
-rw-r--r--php-pecl-openswoole.spec7
3 files changed, 52 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index b00c6cf..732805f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ openswoole
Open Swoole => enabled
Author => Open Swoole Group <hello@openswoole.com>
-Version => 4.9.1
-Built => Dec 27 2021 00:00:00
+Version => 4.10.0
+Built => Jan 25 2022 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index f8ab67d..f4b9f5d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
+Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
- Dependencies {
Dependency [ swoole (Conflicts) ]
@@ -30,11 +30,11 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
}
- Constants [381] {
- Constant [ string SWOOLE_VERSION ] { 4.9.1 }
- Constant [ int SWOOLE_VERSION_ID ] { 40901 }
+ Constant [ string SWOOLE_VERSION ] { 4.10.0 }
+ Constant [ int SWOOLE_VERSION_ID ] { 41000 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
- Constant [ int SWOOLE_MINOR_VERSION ] { 9 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
+ Constant [ int SWOOLE_MINOR_VERSION ] { 10 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
@@ -2274,7 +2274,7 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
- Static properties [0] {
}
- - Static methods [38] {
+ - Static methods [40] {
Method [ <internal:openswoole> static public method create ] {
- Parameters [2] {
@@ -2432,6 +2432,16 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
- Return [ Swoole\Coroutine\Iterator ]
}
+ Method [ <internal:openswoole> static public method select ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> array $read = [] ]
+ Parameter #1 [ <optional> array $write = [] ]
+ Parameter #2 [ <optional> float $timeout = -1 ]
+ }
+ - Return [ mixed ]
+ }
+
Method [ <internal:openswoole> static public method listCoroutines ] {
- Parameters [0] {
@@ -2484,7 +2494,15 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
Method [ <internal:openswoole> static public method sleep ] {
- Parameters [1] {
- Parameter #0 [ <required> float $seconds ]
+ Parameter #0 [ <required> int $seconds ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:openswoole> static public method usleep ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $microseconds ]
}
- Return [ bool ]
}
@@ -3097,7 +3115,7 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
- Static properties [0] {
}
- - Static methods [15] {
+ - Static methods [16] {
Method [ <internal:openswoole> static public method gethostbyname ] {
- Parameters [3] {
@@ -3129,7 +3147,15 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
Method [ <internal:openswoole> static public method sleep ] {
- Parameters [1] {
- Parameter #0 [ <required> int|float $seconds ]
+ Parameter #0 [ <required> int $seconds ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:openswoole> static public method usleep ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $microseconds ]
}
- Return [ bool ]
}
@@ -3314,12 +3340,13 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
- Static methods [0] {
}
- - Properties [2] {
+ - Properties [3] {
+ Property [ public $id = 0 ]
Property [ public $capacity = 0 ]
Property [ public $errCode = 0 ]
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:openswoole, ctor> public method __construct ] {
- Parameters [1] {
@@ -3372,6 +3399,13 @@ Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
- Return [ array ]
}
+ Method [ <internal:openswoole> public method getId ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
+ }
+
Method [ <internal:openswoole> public method length ] {
- Parameters [0] {
diff --git a/php-pecl-openswoole.spec b/php-pecl-openswoole.spec
index 8433321..a7c9269 100644
--- a/php-pecl-openswoole.spec
+++ b/php-pecl-openswoole.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-swoole4
#
-# Copyright (c) 2013-2021 Remi Collet
+# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -28,7 +28,7 @@
%endif
%bcond_without pgsql
-%global upstream_version 4.9.1
+%global upstream_version 4.10.0
#global upstream_prever RC2
@@ -322,6 +322,9 @@ cd ../ZTS
%changelog
+* Tue Jan 25 2022 Remi Collet <remi@remirepo.net> - 4.10.0-1
+- update to 4.10.0
+
* Mon Dec 27 2021 Remi Collet <remi@remirepo.net> - 4.9.1-1
- update to 4.9.1
- drop patch merged upstream