summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-27 08:16:22 +0100
committerRemi Collet <remi@php.net>2021-12-27 08:16:22 +0100
commit965222743cd637bc0d5087cd530eb8cac141e920 (patch)
tree2fe9e2113970b50f30b8320471a4033942ca60bd
parent1fd143a60ceb86c9941a75ba2025cebf6fe9908b (diff)
update to 4.9.1
drop patch merged upstream
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION8
-rw-r--r--openswoole-oldcurl.patch59
-rw-r--r--php-pecl-openswoole.spec10
4 files changed, 12 insertions, 71 deletions
diff --git a/PHPINFO b/PHPINFO
index d105243..b00c6cf 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,9 +2,9 @@
openswoole
Open Swoole => enabled
-Author => Open Swoole Group & Contributors <hello@swoole.co.uk>
-Version => 4.9.0
-Built => Dec 20 2021 00:00:00
+Author => Open Swoole Group <hello@openswoole.com>
+Version => 4.9.1
+Built => Dec 27 2021 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
diff --git a/REFLECTION b/REFLECTION
index 610de62..f8ab67d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #88 openswoole version 4.9.0 ] {
+Extension [ <persistent> extension #119 openswoole version 4.9.1 ] {
- Dependencies {
Dependency [ swoole (Conflicts) ]
@@ -30,11 +30,11 @@ Extension [ <persistent> extension #88 openswoole version 4.9.0 ] {
}
- Constants [381] {
- Constant [ string SWOOLE_VERSION ] { 4.9.0 }
- Constant [ int SWOOLE_VERSION_ID ] { 40900 }
+ Constant [ string SWOOLE_VERSION ] { 4.9.1 }
+ Constant [ int SWOOLE_VERSION_ID ] { 40901 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
Constant [ int SWOOLE_MINOR_VERSION ] { 9 }
- Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
+ Constant [ int SWOOLE_RELEASE_VERSION ] { 1 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
Constant [ bool SWOOLE_HAVE_COMPRESSION ] { 1 }
diff --git a/openswoole-oldcurl.patch b/openswoole-oldcurl.patch
deleted file mode 100644
index ef592c0..0000000
--- a/openswoole-oldcurl.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-From b0afb66e8d74eeadf0bff02098a1fe154087377c Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 20 Dec 2021 08:38:43 +0100
-Subject: [PATCH] fix build with old libcurl
-
----
- thirdparty/php/curl/interface.cc | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/thirdparty/php/curl/interface.cc b/thirdparty/php/curl/interface.cc
-index 6af19e0dc..c1d7f748e 100644
---- a/thirdparty/php/curl/interface.cc
-+++ b/thirdparty/php/curl/interface.cc
-@@ -381,7 +381,9 @@ static zend_function *swoole_curl_get_constructor(zend_object *object) {
- static zend_object *swoole_curl_clone_obj(zend_object *object) {
- php_curl *ch;
- CURL *cp;
-+#if LIBCURL_VERSION_NUM >= 0x073800 /* 7.56.0 */
- zval *postfields;
-+#endif
- zend_object *clone_object;
- php_curl *clone_ch;
-
-@@ -399,6 +401,7 @@ static zend_object *swoole_curl_clone_obj(zend_object *object) {
- clone_ch->cp = cp;
- swoole_setup_easy_copy_handlers(clone_ch, ch);
-
-+#if LIBCURL_VERSION_NUM >= 0x073800 /* 7.56.0 */
- postfields = &clone_ch->postfields;
- if (Z_TYPE_P(postfields) != IS_UNDEF) {
- if (build_mime_structure_from_hash(clone_ch, postfields) != SUCCESS) {
-@@ -406,6 +409,7 @@ static zend_object *swoole_curl_clone_obj(zend_object *object) {
- return &clone_ch->std;
- }
- }
-+#endif
-
- return &clone_ch->std;
- }
-@@ -415,7 +419,9 @@ static HashTable *swoole_curl_get_gc(zend_object *object, zval **table, int *n)
-
- zend_get_gc_buffer *gc_buffer = zend_get_gc_buffer_create();
-
-+#if LIBCURL_VERSION_NUM >= 0x073800 /* 7.56.0 */
- zend_get_gc_buffer_add_zval(gc_buffer, &curl->postfields);
-+#endif
- if (curl_handlers(curl)) {
- if (curl_handlers(curl)->read) {
- zend_get_gc_buffer_add_zval(gc_buffer, &curl_handlers(curl)->read->func_name);
-@@ -2835,7 +2841,9 @@ static void _php_curl_free(php_curl *ch) {
- efree(ch->handlers);
- #endif
-
-+#if LIBCURL_VERSION_NUM >= 0x073800 /* 7.56.0 */
- zval_ptr_dtor(&ch->postfields);
-+#endif
-
- #if PHP_VERSION_ID >= 80100
- zval_ptr_dtor(&ch->private_data);
diff --git a/php-pecl-openswoole.spec b/php-pecl-openswoole.spec
index d5af860..8433321 100644
--- a/php-pecl-openswoole.spec
+++ b/php-pecl-openswoole.spec
@@ -28,7 +28,7 @@
%endif
%bcond_without pgsql
-%global upstream_version 4.9.0
+%global upstream_version 4.9.1
#global upstream_prever RC2
@@ -42,8 +42,6 @@ License: ASL 2.0 and BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: openswoole-oldcurl.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
@@ -152,8 +150,6 @@ sed \
cd NTS
-%patch0 -p1
-
cp -p thirdparty/hiredis/COPYING hiredis-COPYING
cp -p thirdparty/nghttp2/COPYING nghttp2-COPYING
@@ -326,6 +322,10 @@ cd ../ZTS
%changelog
+* Mon Dec 27 2021 Remi Collet <remi@remirepo.net> - 4.9.1-1
+- update to 4.9.1
+- drop patch merged upstream
+
* Mon Dec 20 2021 Remi Collet <remi@remirepo.net> - 4.9.0-1
- update to 4.9.0
- add patch for libcurl < 7.56 (EL-7) from