summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-24 16:28:07 +0100
committerRemi Collet <remi@php.net>2022-03-24 16:28:07 +0100
commitab200fac8bb9fa0d5cab16ebaa42072da87d12d0 (patch)
treee0ab0e523e236a803a2c5b3d4f1be94d48d07810
parentdf14bc9fb8b8f3f91a7bc67b018d720b85447d2c (diff)
update to 4.11.0
raise dependency on PHP 7.4
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION54
-rw-r--r--php-pecl-openswoole.spec15
3 files changed, 52 insertions, 23 deletions
diff --git a/PHPINFO b/PHPINFO
index 732805f..858871f 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,8 +3,8 @@ openswoole
Open Swoole => enabled
Author => Open Swoole Group <hello@openswoole.com>
-Version => 4.10.0
-Built => Jan 25 2022 00:00:00
+Version => 4.11.0
+Built => Mar 24 2022 00:00:00
coroutine => enabled with boost asm context
trace_log => enabled
epoll => enabled
@@ -14,7 +14,7 @@ cpu_affinity => enabled
spinlock => enabled
rwlock => enabled
sockets => enabled
-openssl => OpenSSL 1.1.1l FIPS 24 Aug 2021
+openssl => OpenSSL 1.1.1n FIPS 15 Mar 2022
dtls => enabled
http2 => enabled
json => enabled
diff --git a/REFLECTION b/REFLECTION
index f4b9f5d..e06676a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
+Extension [ <persistent> extension #120 openswoole version 4.11.0 ] {
- Dependencies {
Dependency [ swoole (Conflicts) ]
@@ -29,11 +29,11 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
}
}
- - Constants [381] {
- Constant [ string SWOOLE_VERSION ] { 4.10.0 }
- Constant [ int SWOOLE_VERSION_ID ] { 41000 }
+ - Constants [395] {
+ Constant [ string SWOOLE_VERSION ] { 4.11.0 }
+ Constant [ int SWOOLE_VERSION_ID ] { 41100 }
Constant [ int SWOOLE_MAJOR_VERSION ] { 4 }
- Constant [ int SWOOLE_MINOR_VERSION ] { 10 }
+ Constant [ int SWOOLE_MINOR_VERSION ] { 11 }
Constant [ int SWOOLE_RELEASE_VERSION ] { 0 }
Constant [ string SWOOLE_EXTRA_VERSION ] { }
Constant [ bool SWOOLE_DEBUG ] { }
@@ -43,11 +43,6 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
Constant [ bool SWOOLE_USE_HTTP2 ] { 1 }
Constant [ bool SWOOLE_USE_POSTGRES ] { 1 }
Constant [ bool SWOOLE_USE_SHORTNAME ] { 1 }
- Constant [ int SWOOLE_BASE ] { 1 }
- Constant [ int SWOOLE_PROCESS ] { 2 }
- Constant [ int SWOOLE_IPC_UNSOCK ] { 1 }
- Constant [ int SWOOLE_IPC_MSGQUEUE ] { 2 }
- Constant [ int SWOOLE_IPC_PREEMPTIVE ] { 3 }
Constant [ int SWOOLE_SOCK_TCP ] { 1 }
Constant [ int SWOOLE_SOCK_TCP6 ] { 3 }
Constant [ int SWOOLE_SOCK_UDP ] { 2 }
@@ -343,6 +338,11 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
Constant [ int SWOOLE_HTTP2_ERROR_CONNECT_ERROR ] { 10 }
Constant [ int SWOOLE_HTTP2_ERROR_ENHANCE_YOUR_CALM ] { 11 }
Constant [ int SWOOLE_HTTP2_ERROR_INADEQUATE_SECURITY ] { 12 }
+ Constant [ int SWOOLE_BASE ] { 1 }
+ Constant [ int SWOOLE_PROCESS ] { 2 }
+ Constant [ int SWOOLE_IPC_UNSOCK ] { 1 }
+ Constant [ int SWOOLE_IPC_MSGQUEUE ] { 2 }
+ Constant [ int SWOOLE_IPC_PREEMPTIVE ] { 3 }
Constant [ int SWOOLE_DISPATCH_RESULT_DISCARD_PACKET ] { -1 }
Constant [ int SWOOLE_DISPATCH_RESULT_CLOSE_CONNECTION ] { -2 }
Constant [ int SWOOLE_DISPATCH_RESULT_USERFUNC_FALLBACK ] { -3 }
@@ -411,6 +411,20 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
Constant [ int OPENSWOOLE_PGSQL_ASSOC ] { 1 }
Constant [ int OPENSWOOLE_PGSQL_NUM ] { 2 }
Constant [ int OPENSWOOLE_PGSQL_BOTH ] { 3 }
+ Constant [ int OPENSWOOLE_PGRES_EMPTY_QUERY ] { 0 }
+ Constant [ int OPENSWOOLE_PGRES_COMMAND_OK ] { 1 }
+ Constant [ int OPENSWOOLE_PGRES_TUPLES_OK ] { 2 }
+ Constant [ int OPENSWOOLE_PGRES_BAD_RESPONSE ] { 5 }
+ Constant [ int OPENSWOOLE_PGRES_NONFATAL_ERROR ] { 6 }
+ Constant [ int OPENSWOOLE_PGRES_FATAL_ERROR ] { 7 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_OK ] { 0 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_BAD ] { 1 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_STARTED ] { 2 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_AWAITING_RESPONSE ] { 4 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_AUTH_OK ] { 5 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_SETENV ] { 6 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_SSL_STARTUP ] { 7 }
+ Constant [ int OPENSWOOLE_PG_CONNECTION_NEEDED ] { 8 }
}
- Functions {
@@ -8906,7 +8920,7 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
}
- Static methods [1] {
- Method [ <internal:openswoole> static public method format ] {
+ Method [ <internal, deprecated:openswoole> static public method format ] {
- Parameters [2] {
Parameter #0 [ <required> int $type ]
@@ -8933,7 +8947,7 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
}
- Methods [49] {
- Method [ <internal:openswoole> public method setHandler ] {
+ Method [ <internal, deprecated:openswoole> public method setHandler ] {
- Parameters [2] {
Parameter #0 [ <required> string $command ]
@@ -8942,7 +8956,7 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
- Return [ void ]
}
- Method [ <internal:openswoole> public method getHandler ] {
+ Method [ <internal, deprecated:openswoole> public method getHandler ] {
- Parameters [1] {
Parameter #0 [ <required> string $command ]
@@ -9372,7 +9386,7 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
Property [ public $notices = NULL ]
}
- - Methods [18] {
+ - Methods [20] {
Method [ <internal:openswoole, ctor> public method __construct ] {
- Parameters [0] {
@@ -9503,6 +9517,18 @@ Extension [ <persistent> extension #120 openswoole version 4.10.0 ] {
}
}
+ Method [ <internal:openswoole> public method status ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:openswoole> public method reset ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:openswoole> public method __destruct ] {
- Parameters [0] {
diff --git a/php-pecl-openswoole.spec b/php-pecl-openswoole.spec
index a7c9269..f0855e0 100644
--- a/php-pecl-openswoole.spec
+++ b/php-pecl-openswoole.spec
@@ -1,4 +1,4 @@
-# remirepo spec file for php-pecl-swoole4
+# remirepo spec file for php-pecl-openswoole
#
# Copyright (c) 2013-2022 Remi Collet
# License: CC-BY-SA
@@ -28,7 +28,7 @@
%endif
%bcond_without pgsql
-%global upstream_version 4.10.0
+%global upstream_version 4.11.0
#global upstream_prever RC2
@@ -45,7 +45,7 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upst
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?dtsprefix}gcc-c++
-BuildRequires: %{?scl_prefix}php-devel >= 7.2
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-curl
BuildRequires: %{?scl_prefix}php-json
@@ -88,9 +88,7 @@ Conflicts: %{?scl_prefix}php-pecl-swoole2
Conflicts: %{?scl_prefix}php-pecl-swoole4
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "8.0"
Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
@@ -186,7 +184,7 @@ EOF
peclbuild() {
%configure \
- --enable-swoole \
+ --enable-openswoole \
--enable-sockets \
--enable-trace-log \
--enable-openssl \
@@ -314,6 +312,7 @@ cd ../ZTS
%doc %{pecl_docdir}/%{pecl_name}/gdbinit
%doc %{pecl_docdir}/%{pecl_name}/thirdparty
%doc %{pecl_docdir}/%{pecl_name}/travis
+%doc %{pecl_docdir}/%{pecl_name}/CHANGELOG
%{php_incldir}/ext/%{pecl_name}
%if %{with_zts}
@@ -322,6 +321,10 @@ cd ../ZTS
%changelog
+* Thu Mar 24 2022 Remi Collet <remi@remirepo.net> - 4.11.0-1
+- update to 4.11.0
+- raise dependency on PHP 7.4
+
* Tue Jan 25 2022 Remi Collet <remi@remirepo.net> - 4.10.0-1
- update to 4.10.0