summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-08-26 09:40:13 +0200
committerRemi Collet <remi@php.net>2024-08-26 09:40:13 +0200
commitbd3bedbac4202061b6a600642041ee6bb837c324 (patch)
tree016fb336ffb5d51884e03abb3b11c5bc3e0f2caa
parent267a6fb9662c28b14073173b5ff30909d1016788 (diff)
update to 3.0.0RC1
drop patch merged upstream add APCu support
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION11
-rw-r--r--php-pecl-msgpack.spec22
3 files changed, 24 insertions, 13 deletions
diff --git a/PHPINFO b/PHPINFO
index 49b3fe8..40076fa 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -3,11 +3,13 @@ msgpack
MessagePack Support => enabled
Session Support => enabled
-extension Version => 2.2.0
+MessagePack APCu Serializer ABI => 0
+extension Version => 3.0.0RC1
header Version => 3.2.0
Directive => Local Value => Master Value
msgpack.error_display => On => On
msgpack.php_only => On => On
+msgpack.assoc => On => On
msgpack.illegal_key_insert => Off => Off
msgpack.use_str8_serialization => On => On
diff --git a/REFLECTION b/REFLECTION
index 6298c67..adf666c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #85 msgpack version 2.2.0 ] {
+Extension [ <persistent> extension #84 msgpack version 3.0.0RC1 ] {
- INI {
Entry [ msgpack.error_display <ALL> ]
@@ -7,6 +7,9 @@ Extension [ <persistent> extension #85 msgpack version 2.2.0 ] {
Entry [ msgpack.php_only <ALL> ]
Current = '1'
}
+ Entry [ msgpack.assoc <ALL> ]
+ Current = '1'
+ }
Entry [ msgpack.illegal_key_insert <ALL> ]
Current = '0'
}
@@ -15,8 +18,9 @@ Extension [ <persistent> extension #85 msgpack version 2.2.0 ] {
}
}
- - Constants [1] {
+ - Constants [2] {
Constant [ int MESSAGEPACK_OPT_PHPONLY ] { -1001 }
+ Constant [ int MESSAGEPACK_OPT_ASSOC ] { -1002 }
}
- Functions {
@@ -51,8 +55,9 @@ Extension [ <persistent> extension #85 msgpack version 2.2.0 ] {
- Classes [2] {
Class [ <internal:msgpack> class MessagePack ] {
- - Constants [1] {
+ - Constants [2] {
Constant [ public int OPT_PHPONLY ] { -1001 }
+ Constant [ public int OPT_ASSOC ] { -1002 }
}
- Static properties [0] {
diff --git a/php-pecl-msgpack.spec b/php-pecl-msgpack.spec
index 5635d83..1efb9cf 100644
--- a/php-pecl-msgpack.spec
+++ b/php-pecl-msgpack.spec
@@ -19,8 +19,8 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 2.2.0
-#global upstream_prever RC2
+%global upstream_version 3.0.0
+%global upstream_prever RC1
#global upstream_lower RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -39,12 +39,11 @@ URL: https://pecl.php.net/package/msgpack
Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: 174.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
%if %{with msgpack}
BuildRequires: msgpack-devel
%else
@@ -95,8 +94,6 @@ These are the files needed to compile programs using MessagePack serializer.
sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
-%patch -P0 -p1
-
%if %{with msgpack}
# use system library
rm -rf msgpack
@@ -123,8 +120,10 @@ extension = %{pecl_name}.so
; Configuration options
;msgpack.error_display = On
-;msgpack.illegal_key_insert = Off
;msgpack.php_only = On
+;msgpack.assoc = On
+;msgpack.illegal_key_insert = Off
+;msgpack.use_str8_serialization = On
EOF
@@ -195,7 +194,7 @@ cd %{sources}
%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/../NTS/modules -d extension=%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=apcu.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php $OPT
%endif
@@ -209,7 +208,7 @@ REPORT_EXIT_STATUS=1 \
%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/../ZTS/modules -d extension=%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=apcu.so -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php $OPT
%endif
@@ -240,6 +239,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Aug 26 2024 Remi Collet <remi@remirepo.net> - 3.0.0~RC1-1
+- update to 3.0.0RC1
+- drop patch merged upstream
+- add APCu support
+
* Fri Jul 5 2024 Remi Collet <remi@remirepo.net> - 2.2.0-3
- fix test suite with 8.4 using patch from
https://github.com/msgpack/msgpack-php/pull/174