summaryrefslogtreecommitdiffstats
path: root/php-pecl-msgpack.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-msgpack.spec')
-rw-r--r--php-pecl-msgpack.spec22
1 files changed, 13 insertions, 9 deletions
diff --git a/php-pecl-msgpack.spec b/php-pecl-msgpack.spec
index 5635d83..1efb9cf 100644
--- a/php-pecl-msgpack.spec
+++ b/php-pecl-msgpack.spec
@@ -19,8 +19,8 @@
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 2.2.0
-#global upstream_prever RC2
+%global upstream_version 3.0.0
+%global upstream_prever RC1
#global upstream_lower RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
%global _configure ../%{sources}/configure
@@ -39,12 +39,11 @@ URL: https://pecl.php.net/package/msgpack
Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-Patch0: 174.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-pecl-apcu-devel
%if %{with msgpack}
BuildRequires: msgpack-devel
%else
@@ -95,8 +94,6 @@ These are the files needed to compile programs using MessagePack serializer.
sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
-%patch -P0 -p1
-
%if %{with msgpack}
# use system library
rm -rf msgpack
@@ -123,8 +120,10 @@ extension = %{pecl_name}.so
; Configuration options
;msgpack.error_display = On
-;msgpack.illegal_key_insert = Off
;msgpack.php_only = On
+;msgpack.assoc = On
+;msgpack.illegal_key_insert = Off
+;msgpack.use_str8_serialization = On
EOF
@@ -195,7 +194,7 @@ cd %{sources}
%if %{with tests}
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/../NTS/modules -d extension=%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=apcu.so -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php $OPT
%endif
@@ -209,7 +208,7 @@ REPORT_EXIT_STATUS=1 \
%if %{with tests}
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension_dir=$PWD/../ZTS/modules -d extension=%{pecl_name}.so" \
+TEST_PHP_ARGS="-n -d extension=apcu.so -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php $OPT
%endif
@@ -240,6 +239,11 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Aug 26 2024 Remi Collet <remi@remirepo.net> - 3.0.0~RC1-1
+- update to 3.0.0RC1
+- drop patch merged upstream
+- add APCu support
+
* Fri Jul 5 2024 Remi Collet <remi@remirepo.net> - 2.2.0-3
- fix test suite with 8.4 using patch from
https://github.com/msgpack/msgpack-php/pull/174