summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec58
1 files changed, 10 insertions, 48 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 9c3d515..79044ee 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -29,10 +29,10 @@
%endif
# Bundled versions
-%global bundled_libmongo 1.27.0
+%global bundled_libmongo 1.27.2
%global bundled_libcrypt 1.10.0
# Required versions
-%global minimal_libmongo 1.27.1
+%global minimal_libmongo 1.27.2
%global minimal_libcrypt 1.9.1
%if %{with syslib}
@@ -46,7 +46,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.19.1
+%global upstream_version 1.19.3
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -78,16 +78,11 @@ BuildRequires: openssl-devel
BuildRequires: pkgconfig(libsasl2)
BuildRequires: pkgconfig(libzstd)
BuildRequires: pkgconfig(zlib)
-%if 0%{?rhel} == 7
-BuildRequires: snappy-devel
-BuildRequires: utf8proc-devel
-%else
BuildRequires: pkgconfig(snappy)
%if 0%{?rhel} == 9 || 0%{?fedora}
# EL-8 will use bundled as only in subversion module
BuildRequires: pkgconfig(libutf8proc)
%endif
-%endif
Provides: bundled(libbson) = %{bundled_libmongo}
Provides: bundled(mongo-c-driver) = %{bundled_libmongo}
Provides: bundled(libmongocrypt) = %{bundled_libcrypt}
@@ -104,26 +99,6 @@ Requires: %{?scl_prefix}php-json%{?_isa}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
-# Other third party repo stuff
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-
%description
The purpose of this driver is to provide exceptionally thin glue between
MongoDB and PHP, implementing only fundemental and performance-critical
@@ -246,26 +221,6 @@ do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
-%if 0%{?fedora} < 24 && 0%{?rhel} < 8
-# when pear installed alone, after us
-%triggerin -- %{?scl_prefix}php-pear
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-# posttrans as pear can be installed after us
-%posttrans
-if [ -x %{__pecl} ] ; then
- %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
-fi
-
-%postun
-if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
-fi
-%endif
-
-
%check
OPT="-n"
[ -f %{php_extdir}/json.so ] && OPT="$OPT -d extension=json.so"
@@ -347,6 +302,13 @@ exit $ret
%changelog
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 1.19.3-1
+- update to 1.19.3
+
+* Thu Jun 6 2024 Remi Collet <remi@remirepo.net> - 1.19.2-1
+- update to 1.19.2 (no change)
+- EL-7 use bundled libbson and libmongc 1.27.2
+
* Wed May 29 2024 Remi Collet <remi@remirepo.net> - 1.19.1-1
- update to 1.19.1