summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO10
-rw-r--r--REFLECTION34
-rw-r--r--php-pecl-mongodb.spec10
3 files changed, 29 insertions, 25 deletions
diff --git a/PHPINFO b/PHPINFO
index a9da22d..19f2914 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.19.1
+MongoDB extension version => 1.19.2
MongoDB extension stability => stable
-libbson headers version => 1.27.1
-libbson library version => 1.27.1
-libmongoc headers version => 1.27.1
-libmongoc library version => 1.27.1
+libbson headers version => 1.27.2
+libbson library version => 1.27.2
+libmongoc headers version => 1.27.2
+libmongoc library version => 1.27.2
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
diff --git a/REFLECTION b/REFLECTION
index f7b39ed..df6424a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
+Extension [ <persistent> extension #103 mongodb version 1.19.2 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.19.1 }
+ Constant [ string MONGODB_VERSION ] { 1.19.2 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -184,7 +184,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Tentative return [ int ]
}
- Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -208,7 +208,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
}
- Methods [1] {
- Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -246,7 +246,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Tentative return [ ?object ]
}
- Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -313,7 +313,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Tentative return [ int ]
}
- Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -351,7 +351,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Tentative return [ string ]
}
- Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -389,7 +389,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Tentative return [ int ]
}
- Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -420,7 +420,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Tentative return [ DateTime ]
}
- Method [ <internal:mongodb, prototype Stringable> abstract public method __toString ] {
+ Method [ <internal:mongodb> abstract public method __toString ] {
- Parameters [0] {
}
@@ -849,7 +849,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Return [ int ]
}
- Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\BinaryInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -998,7 +998,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
}
}
- Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\Decimal128Interface> final public method __toString ] {
- Parameters [0] {
}
@@ -1163,7 +1163,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Return [ ?object ]
}
- Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\JavascriptInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -1367,7 +1367,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Return [ int ]
}
- Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\ObjectIdInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -1428,7 +1428,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
}
- Methods [2] {
- Method [ <internal:mongodb, prototype MongoDB\BSON\Serializable> abstract public method bsonSerialize ] {
+ Method [ <internal:mongodb> abstract public method bsonSerialize ] {
- Parameters [0] {
}
@@ -1489,7 +1489,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Return [ string ]
}
- Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\RegexInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -1653,7 +1653,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Return [ int ]
}
- Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\TimestampInterface> final public method __toString ] {
- Parameters [0] {
}
@@ -1809,7 +1809,7 @@ Extension [ <persistent> extension #100 mongodb version 1.19.1 ] {
- Return [ DateTime ]
}
- Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+ Method [ <internal:mongodb, prototype MongoDB\BSON\UTCDateTimeInterface> final public method __toString ] {
- Parameters [0] {
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 9c3d515..ceb85c1 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -29,10 +29,10 @@
%endif
# Bundled versions
-%global bundled_libmongo 1.27.0
+%global bundled_libmongo 1.27.2
%global bundled_libcrypt 1.10.0
# Required versions
-%global minimal_libmongo 1.27.1
+%global minimal_libmongo 1.27.2
%global minimal_libcrypt 1.9.1
%if %{with syslib}
@@ -46,7 +46,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.19.1
+%global upstream_version 1.19.2
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -347,6 +347,10 @@ exit $ret
%changelog
+* Thu Jun 6 2024 Remi Collet <remi@remirepo.net> - 1.19.2-1
+- update to 1.19.2 (no change)
+- EL-7 use bundled libbson and libmongc 1.27.2
+
* Wed May 29 2024 Remi Collet <remi@remirepo.net> - 1.19.1-1
- update to 1.19.1