summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-08 11:25:01 +0200
committerRemi Collet <remi@php.net>2022-06-08 11:25:01 +0200
commitcf820b8d6afc44baf0b22dc3be6299d11ba1c70e (patch)
treef4654436e2b2c423bd5061e8b6b884b066607944 /php-pecl-mongodb.spec
parent8449199e5772072f7dafc6b7d2832e5a761ba1e2 (diff)
update to 1.14.0beta1
use bundled libmongocrypt 1.5.0-rc1 use bundled libbson and libmongc 1.22.0-beta0
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec24
1 files changed, 14 insertions, 10 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index caf3540..81d3223 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -26,7 +26,7 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 99 || 0%{?rhel} >= 99
%bcond_without syslib
%else
%bcond_with syslib
@@ -34,22 +34,22 @@
%if %{with syslib}
# Build dependency
-%global libmongo 1.21
-%global libcrypt 1.3
+%global libmongo 1.22
+%global libcrypt 1.5
# Runtime dependency
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
# Bundled versions
-%global libmongo 1.21.1
-%global libcrypt 1.3.2
+%global libmongo 1.22.0~beta0
+%global libcrypt 1.5.0~rc1
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.13.0
-#global upstream_prever alpha1
-#global upstream_lower ~alpha1
+%global upstream_version 1.14.0
+%global upstream_prever beta1
+%global upstream_lower ~beta1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -146,7 +146,7 @@ sed -e 's/1.21.1/%{libmongo}/;s/1.3.2/%{libcrypt}/' -i config.m4
%endif
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' src/phongo_version.h)
+extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' phongo_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
@@ -165,7 +165,6 @@ extension=%{pecl_name}.so
; Configuration
;mongodb.debug=''
-;mongodb.mock_service_id = 0
EOF
@@ -329,6 +328,11 @@ exit $ret
%changelog
+* Wed Jun 8 2022 Remi Collet <remi@remirepo.net> - 1.14.0~beta1-1
+- update to 1.14.0beta1
+- use bundled libmongocrypt 1.5.0-rc1
+- use bundled libbson and libmongc 1.22.0-beta0
+
* Thu Mar 24 2022 Remi Collet <remi@remirepo.net> - 1.13.0-1
- update to 1.13.0
- with libbson and libmongoc 1.21.1 and libmongocrypt 1.3.2