summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION59
-rw-r--r--php-pecl-mongodb.spec24
3 files changed, 61 insertions, 36 deletions
diff --git a/PHPINFO b/PHPINFO
index 62508ff..b180ca5 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,10 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.13.0
-MongoDB extension stability => stable
-libbson headers version => 1.21.1
-libbson library version => 1.21.1
-libmongoc headers version => 1.21.1
-libmongoc library version => 1.21.1
+MongoDB extension version => 1.14.0beta1
+MongoDB extension stability => beta
+libbson bundled version => 1.22.0-beta0
+libmongoc bundled version => 1.22.0-beta0
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,11 +17,9 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.3.2
-libmongocrypt library version => 1.3.2
+libmongocrypt bundled version => 1.5.0-rc1
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
Directive => Local Value => Master Value
mongodb.debug => no value => no value
-mongodb.mock_service_id => Off => Off
diff --git a/REFLECTION b/REFLECTION
index 49c5e95..8f3ce5b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
+Extension [ <persistent> extension #114 mongodb version 1.14.0beta1 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -11,14 +11,11 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
Entry [ mongodb.debug <ALL> ]
Current = ''
}
- Entry [ mongodb.mock_service_id <ALL> ]
- Current = '0'
- }
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.13.0 }
- Constant [ string MONGODB_STABILITY ] { stable }
+ Constant [ string MONGODB_VERSION ] { 1.14.0beta1 }
+ Constant [ string MONGODB_STABILITY ] { beta }
}
- Functions {
@@ -1457,9 +1454,12 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\ClientEncryption ] {
- - Constants [2] {
+ - Constants [5] {
Constant [ public string AEAD_AES_256_CBC_HMAC_SHA_512_DETERMINISTIC ] { AEAD_AES_256_CBC_HMAC_SHA_512-Deterministic }
Constant [ public string AEAD_AES_256_CBC_HMAC_SHA_512_RANDOM ] { AEAD_AES_256_CBC_HMAC_SHA_512-Random }
+ Constant [ public string ALGORITHM_INDEXED ] { Indexed }
+ Constant [ public string ALGORITHM_UNINDEXED ] { Unindexed }
+ Constant [ public int QUERY_TYPE_EQUALITY ] { 0 }
}
- Static properties [0] {
@@ -1472,6 +1472,13 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
}
- Methods [5] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> ?array $options = <default> ]
+ }
+ }
+
Method [ <internal:mongodb> final public method createDataKey ] {
- Parameters [2] {
@@ -1495,12 +1502,6 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
}
}
- Method [ <internal:mongodb, ctor> final private method __construct ] {
-
- - Parameters [0] {
- }
- }
-
Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
@@ -1706,7 +1707,7 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [18] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [3] {
@@ -1784,6 +1785,12 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
}
}
+ Method [ <internal:mongodb> final public method getEncryptedFieldsMap ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method getReadConcern ] {
- Parameters [0] {
@@ -4330,7 +4337,7 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
- Properties [0] {
}
- - Methods [10] {
+ - Methods [11] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -4385,6 +4392,12 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
}
}
+ Method [ <internal:mongodb> final public method getServerConnectionId ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
@@ -4407,7 +4420,7 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -4456,6 +4469,12 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
}
}
+ Method [ <internal:mongodb> final public method getServerConnectionId ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
@@ -4478,7 +4497,7 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -4527,6 +4546,12 @@ Extension [ <persistent> extension #114 mongodb version 1.13.0 ] {
}
}
+ Method [ <internal:mongodb> final public method getServerConnectionId ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index caf3540..81d3223 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -26,7 +26,7 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 33 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 99 || 0%{?rhel} >= 99
%bcond_without syslib
%else
%bcond_with syslib
@@ -34,22 +34,22 @@
%if %{with syslib}
# Build dependency
-%global libmongo 1.21
-%global libcrypt 1.3
+%global libmongo 1.22
+%global libcrypt 1.5
# Runtime dependency
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
# Bundled versions
-%global libmongo 1.21.1
-%global libcrypt 1.3.2
+%global libmongo 1.22.0~beta0
+%global libcrypt 1.5.0~rc1
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.13.0
-#global upstream_prever alpha1
-#global upstream_lower ~alpha1
+%global upstream_version 1.14.0
+%global upstream_prever beta1
+%global upstream_lower ~beta1
Version: %{upstream_version}%{?upstream_lower}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
@@ -146,7 +146,7 @@ sed -e 's/1.21.1/%{libmongo}/;s/1.3.2/%{libcrypt}/' -i config.m4
%endif
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' src/phongo_version.h)
+extver=$(sed -n '/#define PHP_MONGODB_VERSION /{s/.* "//;s/".*$//;p}' phongo_version.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
: Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
exit 1
@@ -165,7 +165,6 @@ extension=%{pecl_name}.so
; Configuration
;mongodb.debug=''
-;mongodb.mock_service_id = 0
EOF
@@ -329,6 +328,11 @@ exit $ret
%changelog
+* Wed Jun 8 2022 Remi Collet <remi@remirepo.net> - 1.14.0~beta1-1
+- update to 1.14.0beta1
+- use bundled libmongocrypt 1.5.0-rc1
+- use bundled libbson and libmongc 1.22.0-beta0
+
* Thu Mar 24 2022 Remi Collet <remi@remirepo.net> - 1.13.0-1
- update to 1.13.0
- with libbson and libmongoc 1.21.1 and libmongocrypt 1.3.2