summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-30 09:22:46 +0200
committerRemi Collet <remi@php.net>2021-10-30 09:22:46 +0200
commit70d5f0533dbd0330146b119afb45f7d34dd2326f (patch)
treee8b50858362d8acfa665f545a96e1b7706a18570 /php-pecl-mongodb.spec
parent1e232b28054bcb33b60a49c557d8d6343634db56 (diff)
update to 1.11.0
with libbson and libmongoc 1.19.1
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec23
1 files changed, 12 insertions, 11 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 7513917..ea29d81 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -33,23 +33,23 @@
%endif
%if %{with syslib}
-%global libmongo 1.19.0
+%global libmongo 1.19.1
#global libmongover #{libmongo}
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
%global libcrypt 1.2.1
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
-%global libmongo 1.19.0
+%global libmongo 1.19.1
%global libcrypt 1.2.1
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.11.0
-%global upstream_prever alpha1
-%global upstream_lower ~alpha1
+#global upstream_prever alpha1
+#global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -171,6 +171,7 @@ extension=%{pecl_name}.so
; Configuration
;mongodb.debug=''
+;mongodb.mock_service_id = 0
EOF
@@ -296,20 +297,16 @@ if [ -s server.pid ] ; then
echo '{"STANDALONE": "mongodb://127.0.0.1:27017"}' | tee /tmp/PHONGO-SERVERS.json
pushd NTS
- TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
- NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
- php -n run-tests.php --show-diff || ret=1
+ %{__php} -n run-tests.php -q -P --show-diff || ret=1
popd
%if %{with_zts}
pushd ZTS
- TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
- NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
- php -n run-tests.php --show-diff || ret=1
+ %{__ztsphp} -n run-tests.php -q -P --show-diff || ret=1
popd
%endif
@@ -338,6 +335,10 @@ exit $ret
%changelog
+* Sat Oct 30 2021 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+- with libbson and libmongoc 1.19.1
+
* Wed Sep 29 2021 Remi Collet <remi@remirepo.net> - 1.11.0~alpha1-2
- rebuild using ICU 69