summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-30 09:22:46 +0200
committerRemi Collet <remi@php.net>2021-10-30 09:22:46 +0200
commit70d5f0533dbd0330146b119afb45f7d34dd2326f (patch)
treee8b50858362d8acfa665f545a96e1b7706a18570
parent1e232b28054bcb33b60a49c557d8d6343634db56 (diff)
update to 1.11.0
with libbson and libmongoc 1.19.1
-rw-r--r--PHPINFO13
-rw-r--r--REFLECTION38
-rw-r--r--mongodb-php81.patch32
-rw-r--r--php-pecl-mongodb.spec23
4 files changed, 49 insertions, 57 deletions
diff --git a/PHPINFO b/PHPINFO
index 57dad3a..ecec1a4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.11.0alpha1
-MongoDB extension stability => alpha
-libbson headers version => 1.19.0
-libbson library version => 1.19.0
-libmongoc headers version => 1.19.0
-libmongoc library version => 1.19.0
+MongoDB extension version => 1.11.0
+MongoDB extension stability => stable
+libbson headers version => 1.19.1
+libbson library version => 1.19.1
+libmongoc headers version => 1.19.1
+libmongoc library version => 1.19.1
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -26,3 +26,4 @@ libmongocrypt crypto library => libcrypto
Directive => Local Value => Master Value
mongodb.debug => no value => no value
+mongodb.mock_service_id => Off => Off
diff --git a/REFLECTION b/REFLECTION
index 424e54c..afeac79 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
+Extension [ <persistent> extension #123 mongodb version 1.11.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -11,11 +11,14 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
Entry [ mongodb.debug <ALL> ]
Current = ''
}
+ Entry [ mongodb.mock_service_id <ALL> ]
+ Current = '0'
+ }
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.11.0alpha1 }
- Constant [ string MONGODB_STABILITY ] { alpha }
+ Constant [ string MONGODB_VERSION ] { 1.11.0 }
+ Constant [ string MONGODB_STABILITY ] { stable }
}
- Functions {
@@ -1795,7 +1798,7 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
Method [ <internal:mongodb> final public method selectServer ] {
- Parameters [1] {
- Parameter #0 [ <required> MongoDB\Driver\ReadPreference $readPreference ]
+ Parameter #0 [ <optional> MongoDB\Driver\ReadPreference or NULL $readPreference ]
}
}
@@ -2032,7 +2035,7 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\Server ] {
- - Constants [9] {
+ - Constants [10] {
Constant [ public int TYPE_UNKNOWN ] { 0 }
Constant [ public int TYPE_STANDALONE ] { 1 }
Constant [ public int TYPE_MONGOS ] { 2 }
@@ -2042,6 +2045,7 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
Constant [ public int TYPE_RS_ARBITER ] { 6 }
Constant [ public int TYPE_RS_OTHER ] { 7 }
Constant [ public int TYPE_RS_GHOST ] { 8 }
+ Constant [ public int TYPE_LOAD_BALANCER ] { 9 }
}
- Static properties [0] {
@@ -3664,7 +3668,7 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
- Properties [0] {
}
- - Methods [9] {
+ - Methods [10] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3713,6 +3717,12 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
}
}
+ Method [ <internal:mongodb> final public method getServiceId ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
@@ -3735,7 +3745,7 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3778,6 +3788,12 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
}
}
+ Method [ <internal:mongodb> final public method getServiceId ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
@@ -3800,7 +3816,7 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
- Properties [0] {
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3843,6 +3859,12 @@ Extension [ <persistent> extension #119 mongodb version 1.11.0alpha1 ] {
}
}
+ Method [ <internal:mongodb> final public method getServiceId ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:mongodb> final public method __wakeup ] {
- Parameters [0] {
diff --git a/mongodb-php81.patch b/mongodb-php81.patch
deleted file mode 100644
index d30767a..0000000
--- a/mongodb-php81.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 6b4109bb3657d6611f116e06a91699952b8a2fc5 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 23 Jul 2021 12:21:44 +0200
-Subject: [PATCH] Fix API change in 8.1.0beta1
-
----
- php_phongo.h | 7 +++++++
- 1 file changed, 7 insertions(+)
-
-diff --git a/php_phongo.h b/php_phongo.h
-index bf6bf094..7b0c1a3b 100644
---- a/php_phongo.h
-+++ b/php_phongo.h
-@@ -169,11 +169,18 @@ bool php_phongo_manager_unregister(php_phongo_manager_t* manager);
- ce->ce_flags |= ZEND_ACC_FINAL; \
- } while (0);
-
-+#if PHP_VERSION_ID < 80100
- #define PHONGO_CE_DISABLE_SERIALIZATION(ce) \
- do { \
- ce->serialize = zend_class_serialize_deny; \
- ce->unserialize = zend_class_unserialize_deny; \
- } while (0);
-+#else
-+#define PHONGO_CE_DISABLE_SERIALIZATION(ce) \
-+ do { \
-+ ce->ce_flags |= ZEND_ACC_NOT_SERIALIZABLE; \
-+ } while (0);
-+#endif
-
- #define PHONGO_GET_PROPERTY_HASH_INIT_PROPS(is_debug, intern, props, size) \
- do { \
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 7513917..ea29d81 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -33,23 +33,23 @@
%endif
%if %{with syslib}
-%global libmongo 1.19.0
+%global libmongo 1.19.1
#global libmongover #{libmongo}
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
%global libcrypt 1.2.1
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
-%global libmongo 1.19.0
+%global libmongo 1.19.1
%global libcrypt 1.2.1
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
%global upstream_version 1.11.0
-%global upstream_prever alpha1
-%global upstream_lower ~alpha1
+#global upstream_prever alpha1
+#global upstream_lower ~alpha1
Version: %{upstream_version}%{?upstream_lower}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
@@ -171,6 +171,7 @@ extension=%{pecl_name}.so
; Configuration
;mongodb.debug=''
+;mongodb.mock_service_id = 0
EOF
@@ -296,20 +297,16 @@ if [ -s server.pid ] ; then
echo '{"STANDALONE": "mongodb://127.0.0.1:27017"}' | tee /tmp/PHONGO-SERVERS.json
pushd NTS
- TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
- NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
- php -n run-tests.php --show-diff || ret=1
+ %{__php} -n run-tests.php -q -P --show-diff || ret=1
popd
%if %{with_zts}
pushd ZTS
- TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="$OPT -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
- NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
- php -n run-tests.php --show-diff || ret=1
+ %{__ztsphp} -n run-tests.php -q -P --show-diff || ret=1
popd
%endif
@@ -338,6 +335,10 @@ exit $ret
%changelog
+* Sat Oct 30 2021 Remi Collet <remi@remirepo.net> - 1.11.0-1
+- update to 1.11.0
+- with libbson and libmongoc 1.19.1
+
* Wed Sep 29 2021 Remi Collet <remi@remirepo.net> - 1.11.0~alpha1-2
- rebuild using ICU 69