summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-22 12:16:13 +0200
committerRemi Collet <remi@php.net>2023-06-22 12:16:13 +0200
commit69aebbf9bd19a4cc3259d55fe35380f8fa22855c (patch)
treee1dc6955d7717e14d760c6e8f51b79702eb2f047
parent567d069d9d262662e7834d82f76d33ad0577be2f (diff)
update to 1.16.0
EL use bundled libbson and libmongc 1.24.1 EL use bundled libmongocrypt 1.8.1
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION414
-rw-r--r--php-pecl-mongodb.spec23
3 files changed, 402 insertions, 49 deletions
diff --git a/PHPINFO b/PHPINFO
index 05821f3..c0d8021 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.15.3
+MongoDB extension version => 1.16.0
MongoDB extension stability => stable
-libbson headers version => 1.23.4
-libbson library version => 1.23.4
-libmongoc headers version => 1.23.4
-libmongoc library version => 1.23.4
+libbson headers version => 1.24.1
+libbson library version => 1.24.1
+libmongoc headers version => 1.24.1
+libmongoc library version => 1.24.1
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,8 +19,8 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.8.0
-libmongocrypt library version => 1.8.0
+libmongocrypt headers version => 1.8.1
+libmongocrypt library version => 1.8.1
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
crypt_shared library version => unknown
diff --git a/REFLECTION b/REFLECTION
index 21dc3c6..c3f9b13 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
+Extension [ <persistent> extension #116 mongodb version 1.16.0 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.15.3 }
+ Constant [ string MONGODB_VERSION ] { 1.16.0 }
Constant [ string MONGODB_STABILITY ] { stable }
}
@@ -78,7 +78,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
}
}
- - Classes [75] {
+ - Classes [78] {
Interface [ <internal:mongodb> interface MongoDB\BSON\Type ] {
- Constants [0] {
@@ -420,6 +420,313 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
}
}
+ Class [ <internal:mongodb> <iterateable> final class MongoDB\BSON\Iterator implements Iterator, Traversable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [7] {
+ Method [ <internal:mongodb, ctor> final private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> final public method current ] {
+
+ - Parameters [0] {
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> final public method key ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|int ]
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> final public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> final public method rewind ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:mongodb, prototype Iterator> final public method valid ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:mongodb> final public method __wakeup ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> <iterateable> final class MongoDB\BSON\PackedArray implements Stringable, IteratorAggregate, Traversable, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:mongodb> final static public method fromPHP ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $value ]
+ }
+ - Return [ MongoDB\BSON\PackedArray ]
+ }
+
+ Method [ <internal:mongodb> final static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ - Return [ MongoDB\BSON\PackedArray ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [10] {
+ Method [ <internal:mongodb, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $index ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:mongodb, prototype IteratorAggregate> final public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ MongoDB\BSON\Iterator ]
+ }
+
+ Method [ <internal:mongodb> final public method has ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> int $index ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:mongodb> final public method toPHP ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> ?array $typeMap = null ]
+ }
+ - Return [ object|array ]
+ }
+
+ Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:mongodb> final public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:mongodb> final public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
+ Class [ <internal:mongodb> <iterateable> final class MongoDB\BSON\Document implements Stringable, IteratorAggregate, Traversable, Serializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [4] {
+ Method [ <internal:mongodb> final static public method fromBSON ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $bson ]
+ }
+ - Return [ MongoDB\BSON\Document ]
+ }
+
+ Method [ <internal:mongodb> final static public method fromJSON ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $json ]
+ }
+ - Return [ MongoDB\BSON\Document ]
+ }
+
+ Method [ <internal:mongodb> final static public method fromPHP ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> object|array $value ]
+ }
+ - Return [ MongoDB\BSON\Document ]
+ }
+
+ Method [ <internal:mongodb> final static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ - Return [ MongoDB\BSON\Document ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [12] {
+ Method [ <internal:mongodb, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:mongodb> final public method get ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $key ]
+ }
+ - Return [ mixed ]
+ }
+
+ Method [ <internal:mongodb, prototype IteratorAggregate> final public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Return [ MongoDB\BSON\Iterator ]
+ }
+
+ Method [ <internal:mongodb> final public method has ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $key ]
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:mongodb> final public method toPHP ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> ?array $typeMap = null ]
+ }
+ - Return [ object|array ]
+ }
+
+ Method [ <internal:mongodb> final public method toCanonicalExtendedJSON ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:mongodb> final public method toRelaxedExtendedJSON ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:mongodb, prototype Stringable> final public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:mongodb> final public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:mongodb> final public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+ }
+ }
+
Class [ <internal:mongodb> final class MongoDB\BSON\Binary implements Stringable, MongoDB\BSON\BinaryInterface, JsonSerializable, MongoDB\BSON\Type, Serializable ] {
- Constants [9] {
@@ -490,7 +797,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -527,7 +834,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> final static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ - Return [ MongoDB\BSON\DBPointer ]
+ }
}
- Properties [0] {
@@ -557,7 +871,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -632,7 +946,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -669,16 +983,24 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> final static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ - Return [ MongoDB\BSON\Int64 ]
+ }
}
- Properties [0] {
}
- Methods [7] {
- Method [ <internal:mongodb, ctor> final private method __construct ] {
+ Method [ <internal:mongodb, ctor> final public method __construct ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> string|int $value ]
}
}
@@ -699,7 +1021,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -789,7 +1111,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -850,7 +1172,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -911,7 +1233,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -993,7 +1315,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -1115,7 +1437,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -1152,7 +1474,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> final static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ - Return [ MongoDB\BSON\Symbol ]
+ }
}
- Properties [0] {
@@ -1182,7 +1511,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -1272,7 +1601,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -1309,7 +1638,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Static properties [0] {
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:mongodb> final static public method __set_state ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $properties ]
+ }
+ - Return [ MongoDB\BSON\Undefined ]
+ }
}
- Properties [0] {
@@ -1339,7 +1675,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -1421,7 +1757,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -1570,12 +1906,14 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Class [ <internal:mongodb> final class MongoDB\Driver\ClientEncryption ] {
- - Constants [5] {
+ - Constants [7] {
Constant [ public string AEAD_AES_256_CBC_HMAC_SHA_512_DETERMINISTIC ] { AEAD_AES_256_CBC_HMAC_SHA_512-Deterministic }
Constant [ public string AEAD_AES_256_CBC_HMAC_SHA_512_RANDOM ] { AEAD_AES_256_CBC_HMAC_SHA_512-Random }
Constant [ public string ALGORITHM_INDEXED ] { Indexed }
Constant [ public string ALGORITHM_UNINDEXED ] { Unindexed }
+ Constant [ public string ALGORITHM_RANGE_PREVIEW ] { RangePreview }
Constant [ public string QUERY_TYPE_EQUALITY ] { equality }
+ Constant [ public string QUERY_TYPE_RANGE_PREVIEW ] { rangePreview }
}
- Static properties [0] {
@@ -1587,7 +1925,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [13] {
Method [ <internal:mongodb, ctor> final public method __construct ] {
- Parameters [1] {
@@ -1638,6 +1976,15 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Return [ MongoDB\BSON\Binary ]
}
+ Method [ <internal:mongodb> final public method encryptExpression ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> object|array $expr ]
+ Parameter #1 [ <optional> ?array $options = null ]
+ }
+ - Return [ object ]
+ }
+
Method [ <internal:mongodb> final public method getKey ] {
- Parameters [1] {
@@ -1866,7 +2213,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -2153,7 +2500,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -2270,7 +2617,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -2525,7 +2872,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -2907,7 +3254,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
Method [ <internal:mongodb, prototype Serializable> final public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
- Return [ void ]
}
@@ -3052,7 +3399,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Properties [0] {
}
- - Methods [12] {
+ - Methods [13] {
Method [ <internal:mongodb, ctor> final private method __construct ] {
- Parameters [0] {
@@ -3122,6 +3469,13 @@ Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Return [ array ]
}
+ Method [ <internal:mongodb> final public method getErrorReplies ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
Method [ <internal:mongodb> final public method isAcknowledged ] {
- Parameters [0] {
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index dc09069..64b36ed 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -16,12 +16,6 @@
%global _root_prefix %{_prefix}
%endif
-# Defined in Fedora >= 37 and RHEL >= 10, in PHP >= 7.4 for remirepo
-%{!?__phpize: %global __phpize %{_bindir}/phpize}
-%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
-%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
-%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
-
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mongodb
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
@@ -31,20 +25,20 @@
%bcond_with tests
# temp for EL until available in EPEL
-%if 0%{?fedora} >= 34 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 10
%bcond_without syslib
%else
%bcond_with syslib
%endif
# Bundled versions
-%global bundled_libmongo 1.23.4
-%global bundled_libcrypt 1.5.2
+%global bundled_libmongo 1.24.1
+%global bundled_libcrypt 1.8.1
%if %{with syslib}
# Build dependencies
-%global system_libmongo 1.23.3
-%global system_libcrypt 1.5.2
+%global system_libmongo 1.24.1
+%global system_libcrypt 1.8.1
# Runtime dependencies
%global runtime_libmongo %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{system_libmongo})
%global runtime_libcrypt %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{system_libcrypt})
@@ -52,7 +46,7 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.15.3
+%global upstream_version 1.16.0
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
@@ -337,6 +331,11 @@ exit $ret
%changelog
+* Thu Jun 22 2023 Remi Collet <remi@remirepo.net> - 1.16.0-1
+- update to 1.16.0
+- EL use bundled libbson and libmongc 1.24.1
+- EL use bundled libmongocrypt 1.8.1
+
* Sat May 13 2023 Remi Collet <remi@remirepo.net> - 1.15.3-1
- update to 1.15.3
- EL-7 use bundled libbson and libmongc 1.23.4