summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-13 08:38:57 +0200
committerRemi Collet <remi@php.net>2023-05-13 08:38:57 +0200
commit567d069d9d262662e7834d82f76d33ad0577be2f (patch)
tree71fa2e4ffffb8a0864090bd5dc8c84375dcea364
parentbf5adfad4762220436266b0d74c7da8401c3dfbe (diff)
update to 1.15.3
EL-7 use bundled libbson and libmongc 1.23.4
-rw-r--r--PHPINFO14
-rw-r--r--REFLECTION4
-rw-r--r--php-pecl-mongodb.spec28
3 files changed, 28 insertions, 18 deletions
diff --git a/PHPINFO b/PHPINFO
index f6faa43..05821f3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,12 +2,12 @@
mongodb
MongoDB support => enabled
-MongoDB extension version => 1.15.2
+MongoDB extension version => 1.15.3
MongoDB extension stability => stable
-libbson headers version => 1.23.3
-libbson library version => 1.23.3
-libmongoc headers version => 1.23.3
-libmongoc library version => 1.23.3
+libbson headers version => 1.23.4
+libbson library version => 1.23.4
+libmongoc headers version => 1.23.4
+libmongoc library version => 1.23.4
libmongoc SSL => enabled
libmongoc SSL library => OpenSSL
libmongoc crypto => enabled
@@ -19,8 +19,8 @@ libmongoc compression => enabled
libmongoc compression snappy => enabled
libmongoc compression zlib => enabled
libmongoc compression zstd => enabled
-libmongocrypt headers version => 1.7.4
-libmongocrypt library version => 1.7.4
+libmongocrypt headers version => 1.8.0
+libmongocrypt library version => 1.8.0
libmongocrypt crypto => enabled
libmongocrypt crypto library => libcrypto
crypt_shared library version => unknown
diff --git a/REFLECTION b/REFLECTION
index 0522224..21dc3c6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 mongodb version 1.15.2 ] {
+Extension [ <persistent> extension #115 mongodb version 1.15.3 ] {
- Dependencies {
Dependency [ date (Required) ]
@@ -14,7 +14,7 @@ Extension [ <persistent> extension #115 mongodb version 1.15.2 ] {
}
- Constants [2] {
- Constant [ string MONGODB_VERSION ] { 1.15.2 }
+ Constant [ string MONGODB_VERSION ] { 1.15.3 }
Constant [ string MONGODB_STABILITY ] { stable }
}
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index ffdc75d..dc09069 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -16,6 +16,12 @@
%global _root_prefix %{_prefix}
%endif
+# Defined in Fedora >= 37 and RHEL >= 10, in PHP >= 7.4 for remirepo
+%{!?__phpize: %global __phpize %{_bindir}/phpize}
+%{!?__ztsphpize: %global __ztsphpize %{_bindir}/zts-phpize}
+%{!?__phpconfig: %global __phpconfig %{_bindir}/php-config}
+%{!?__ztsphpconfig:%global __ztsphpconfig %{_bindir}/zts-php-config}
+
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global pecl_name mongodb
# After 40-smbclient.ini, see https://jira.mongodb.org/browse/PHPC-658
@@ -32,7 +38,7 @@
%endif
# Bundled versions
-%global bundled_libmongo 1.23.3
+%global bundled_libmongo 1.23.4
%global bundled_libcrypt 1.5.2
%if %{with syslib}
@@ -46,12 +52,12 @@
Summary: MongoDB driver for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.15.2
+%global upstream_version 1.15.3
#global upstream_prever beta1
#global upstream_lower ~beta1
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
Version: %{upstream_version}%{?upstream_lower}
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with syslib}
License: Apache-2.0
%else
@@ -78,8 +84,8 @@ BuildRequires: openssl-devel
BuildRequires: libzstd-devel
BuildRequires: snappy-devel
BuildRequires: zlib-devel
-# We require 69 to ensure we use the same version than PHP
-BuildRequires: pkgconfig(icu-uc) >= 69
+# We require 72 to ensure we use the same version than PHP
+BuildRequires: pkgconfig(icu-uc) >= 72
Provides: bundled(libbson) = %{bundled_libmongo}
Provides: bundled(mongo-c-driver) = %{bundled_libmongo}
Provides: bundled(libmongocrypt) = %{bundled_libcrypt}
@@ -183,7 +189,7 @@ peclbuild() {
--with-mongodb-icu=yes \
--with-mongodb-ssl=openssl \
%endif
- --with-php-config=%{_bindir}/${1}-config \
+ --with-php-config=${1} \
--with-mongodb-client-side-encryption \
--enable-mongodb
@@ -191,7 +197,7 @@ peclbuild() {
}
cd %{sources}
-phpize
+%{__phpize}
%if %{with syslib}
# Ensure we use system library
# Need to be removed only after phpize because of m4_include
@@ -199,11 +205,11 @@ phpize
%endif
cd ../NTS
-peclbuild php
+peclbuild %{__phpconfig}
%if %{with_zts}
cd ../ZTS
-peclbuild zts-php
+peclbuild %{__ztsphpconfig}
%endif
@@ -331,6 +337,10 @@ exit $ret
%changelog
+* Sat May 13 2023 Remi Collet <remi@remirepo.net> - 1.15.3-1
+- update to 1.15.3
+- EL-7 use bundled libbson and libmongc 1.23.4
+
* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 1.15.2-2
- build out of sources tree