summaryrefslogtreecommitdiffstats
path: root/php-pecl-mongodb.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-mongodb.spec')
-rw-r--r--php-pecl-mongodb.spec35
1 files changed, 14 insertions, 21 deletions
diff --git a/php-pecl-mongodb.spec b/php-pecl-mongodb.spec
index 73adbbb..75106c2 100644
--- a/php-pecl-mongodb.spec
+++ b/php-pecl-mongodb.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-mongodb
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -26,22 +26,22 @@
%bcond_with tests
# temp for EL-8 until available in EPEL
-%if 0%{?fedora} >= 31 || 0%{?rhel} >= 8
+%if 0%{?fedora} >= 32 || 0%{?rhel} >= 8
%global with_syslib 1
-%global libmongo 1.17
+%global libmongo 1.17.4
#global libmongover #{libmongo}
%global libmongover %(pkg-config --silence-errors --modversion libmongoc-1.0 2>/dev/null || echo %{libmongo})
-%global libcrypt 1.0.1
+%global libcrypt 1.2.0
%global libcryptver %(pkg-config --silence-errors --modversion libmongocrypt 2>/dev/null || echo %{libcrypt})
%else
%global with_syslib 0
-%global libmongo 1.17.2
+%global libmongo 1.17.4
%global libcrypt 1.0.4
%endif
Summary: MongoDB driver for PHP
Name: %{?sub_prefix}php-pecl-%{pecl_name}
-%global upstream_version 1.9.0
+%global upstream_version 1.9.1
#global upstream_prever RC1
#global upstream_lower ~rc1
Version: %{upstream_version}%{?upstream_lower}
@@ -50,13 +50,11 @@ License: ASL 2.0
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel > 7.0
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
-%if 0%{?rhel} == 6
-BuildRequires: autoconf268
-%endif
%if %{with_syslib}
BuildRequires: pkgconfig(libbson-1.0) >= %{libmongo}
BuildRequires: pkgconfig(libmongoc-1.0) >= %{libmongo}
@@ -69,8 +67,8 @@ BuildRequires: cyrus-sasl-devel
BuildRequires: openssl-devel
BuildRequires: snappy-devel
BuildRequires: zlib-devel
-# We require 50 to ensure use of libicu-last (same version than PHP)
-BuildRequires: libicu-devel >= 50
+# We require 65 to ensure use of libicu-last (same version than PHP)
+BuildRequires: libicu-devel >= 65
Provides: bundled(libbson) = %{libmongo}
Provides: bundled(mongo-c-driver) = %{libmongo}
Provides: bundled(libmongocrypt) = %{libcrypt}
@@ -122,12 +120,6 @@ Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
%endif
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
-
%description
The purpose of this driver is to provide exceptionally thin glue between
@@ -176,9 +168,6 @@ EOF
%build
-%if 0%{?rhel} == 6
-export PHP_AUTOCONF=autoconf268;export PHP_AUTOHEADER=autoheader268
-%endif
%{?dtsenable}
peclbuild() {
@@ -346,6 +335,10 @@ exit $ret
%changelog
+* Wed Apr 7 2021 Remi Collet <remi@remirepo.net> - 1.9.1-1
+- update to 1.9.1
+- with libbson and libmongoc 1.17.4
+
* Wed Nov 25 2020 Remi Collet <remi@remirepo.net> - 1.9.0-1
- update to 1.9.0 (stable)