summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-08 14:20:38 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-08 14:20:38 +0100
commit4341837ecd5bf6e33ca758ae22f7ef8994382fb0 (patch)
tree85524ee10e62a5ecc249059add2cdd53590a8560
parentef3b44a8150867fe38bdf9b0f92fb84682a9b778 (diff)
php-pecl-mogilefs: F24
-rw-r--r--php-pecl-mogilefs.spec19
1 files changed, 12 insertions, 7 deletions
diff --git a/php-pecl-mogilefs.spec b/php-pecl-mogilefs.spec
index b88e1f9..db4968f 100644
--- a/php-pecl-mogilefs.spec
+++ b/php-pecl-mogilefs.spec
@@ -15,9 +15,6 @@
%endif
%{?scl: %scl_package php-pecl-mogilefs}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
# Broken for now
%global with_zts 0
@@ -50,10 +47,12 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
# Other third party repo stuff
@@ -197,6 +196,7 @@ REPORT_EXIT_STATUS=1 \
%endif
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -213,6 +213,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%clean
@@ -235,9 +236,13 @@ rm -rf %{buildroot}
%changelog
+* Tue Mar 8 2016 Remi Collet <remi@fedoraproject.org> - 0.9.2-2
+- adapt for F24
+
* Thu Sep 3 2015 Remi Collet <remi@fedoraproject.org> - 0.9.2-1
- initial package, version 0.9.2 (beta)
- missing license file
open https://github.com/lstrojny/pecl-mogilefs/issues/15
- ZTS build is broken
- open https://github.com/lstrojny/pecl-mogilefs/pull/16 \ No newline at end of file
+ open https://github.com/lstrojny/pecl-mogilefs/pull/16
+