summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-05 18:00:58 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-05 18:00:58 +0100
commitef3b44a8150867fe38bdf9b0f92fb84682a9b778 (patch)
tree1d08d882b034f627ff8ef93a44dccfa1dc603071
parent904f581bcb1dc954fc60c403275c57c189a43c10 (diff)
php-pecl-mogilefs: F24
-rw-r--r--php-pecl-mogilefs-php7.spec23
1 files changed, 13 insertions, 10 deletions
diff --git a/php-pecl-mogilefs-php7.spec b/php-pecl-mogilefs-php7.spec
index 8a7c07c..d020376 100644
--- a/php-pecl-mogilefs-php7.spec
+++ b/php-pecl-mogilefs-php7.spec
@@ -11,9 +11,6 @@
%endif
%{?scl: %scl_package php-pecl-mogilefs}
-%{!?php_inidir: %global php_inidir %{_sysconfdir}/php.d}
-%{!?__pecl: %global __pecl %{_bindir}/pecl}
-%{!?__php: %global __php %{_bindir}/php}
# Broken for now
%global with_zts 0
@@ -25,7 +22,7 @@
Summary: PHP client library to communicate with the MogileFS storage
Name: %{?sub_prefix}php-pecl-%{pecl_name}
Version: 0.9.3.1
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
# https://github.com/lstrojny/pecl-mogilefs/issues/15
License: BSD
Group: Development/Languages
@@ -42,11 +39,11 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
@@ -185,6 +182,7 @@ REPORT_EXIT_STATUS=1 \
%endif
+%if 0%{?fedora} < 24
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -201,6 +199,7 @@ fi
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
%{pecl_uninstall} %{pecl_name} >/dev/null || :
fi
+%endif
%clean
@@ -223,6 +222,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 5 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-2
+- adapt for F24
+
* Wed Jan 20 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3.1-1
- Update to 0.9.3.1 (php 7, beta, no change)
@@ -234,4 +236,5 @@ rm -rf %{buildroot}
- missing license file
open https://github.com/lstrojny/pecl-mogilefs/issues/15
- ZTS build is broken
- open https://github.com/lstrojny/pecl-mogilefs/pull/16 \ No newline at end of file
+ open https://github.com/lstrojny/pecl-mogilefs/pull/16
+