summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-17 18:30:28 +0200
committerRemi Collet <remi@remirepo.net>2017-07-17 18:30:28 +0200
commitbad70ad950bb84eef04fa190b0610541a4adc146 (patch)
tree430083cbe15ea9a123bad5395b876442a069fca3
parentd6f20501ff07620391291bb05ed1ac7760b9fee7 (diff)
v2.0.2 - New package
-rw-r--r--REFLECTION438
-rw-r--r--php-pecl-libsodium2.spec73
2 files changed, 335 insertions, 176 deletions
diff --git a/REFLECTION b/REFLECTION
index a237d8c..be92075 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,73 +1,86 @@
-Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
-
- - Constants [58] {
- Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_KEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_NSECBYTES ] { 0 }
- Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_NPUBBYTES ] { 12 }
- Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_ABYTES ] { 16 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES ] { 0 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES ] { 8 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_ABYTES ] { 16 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES ] { 0 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES ] { 12 }
- Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES ] { 16 }
- Constant [ integer Sodium\CRYPTO_AUTH_BYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_AUTH_KEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_BOX_SEALBYTES ] { 48 }
- Constant [ integer Sodium\CRYPTO_BOX_SECRETKEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_BOX_PUBLICKEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_BOX_KEYPAIRBYTES ] { 64 }
- Constant [ integer Sodium\CRYPTO_BOX_MACBYTES ] { 16 }
- Constant [ integer Sodium\CRYPTO_BOX_NONCEBYTES ] { 24 }
- Constant [ integer Sodium\CRYPTO_BOX_SEEDBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_KX_BYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_KX_PUBLICKEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_KX_SECRETKEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_GENERICHASH_BYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_GENERICHASH_BYTES_MIN ] { 16 }
- Constant [ integer Sodium\CRYPTO_GENERICHASH_BYTES_MAX ] { 64 }
- Constant [ integer Sodium\CRYPTO_GENERICHASH_KEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_GENERICHASH_KEYBYTES_MIN ] { 16 }
- Constant [ integer Sodium\CRYPTO_GENERICHASH_KEYBYTES_MAX ] { 64 }
- Constant [ integer Sodium\CRYPTO_PWHASH_SALTBYTES ] { 16 }
- Constant [ string Sodium\CRYPTO_PWHASH_STRPREFIX ] { $argon2i$ }
- Constant [ integer Sodium\CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE ] { 4 }
- Constant [ integer Sodium\CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE ] { 33554432 }
- Constant [ integer Sodium\CRYPTO_PWHASH_OPSLIMIT_MODERATE ] { 6 }
- Constant [ integer Sodium\CRYPTO_PWHASH_MEMLIMIT_MODERATE ] { 134217728 }
- Constant [ integer Sodium\CRYPTO_PWHASH_OPSLIMIT_SENSITIVE ] { 8 }
- Constant [ integer Sodium\CRYPTO_PWHASH_MEMLIMIT_SENSITIVE ] { 536870912 }
- Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES ] { 32 }
- Constant [ string Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX ] { $7$ }
- Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE ] { 524288 }
- Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE ] { 16777216 }
- Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE ] { 33554432 }
- Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE ] { 1073741824 }
- Constant [ integer Sodium\CRYPTO_SCALARMULT_BYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_SCALARMULT_SCALARBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_SHORTHASH_BYTES ] { 8 }
- Constant [ integer Sodium\CRYPTO_SHORTHASH_KEYBYTES ] { 16 }
- Constant [ integer Sodium\CRYPTO_SECRETBOX_KEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_SECRETBOX_MACBYTES ] { 16 }
- Constant [ integer Sodium\CRYPTO_SECRETBOX_NONCEBYTES ] { 24 }
- Constant [ integer Sodium\CRYPTO_SIGN_BYTES ] { 64 }
- Constant [ integer Sodium\CRYPTO_SIGN_SEEDBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_SIGN_PUBLICKEYBYTES ] { 32 }
- Constant [ integer Sodium\CRYPTO_SIGN_SECRETKEYBYTES ] { 64 }
- Constant [ integer Sodium\CRYPTO_SIGN_KEYPAIRBYTES ] { 96 }
- Constant [ integer Sodium\CRYPTO_STREAM_NONCEBYTES ] { 24 }
- Constant [ integer Sodium\CRYPTO_STREAM_KEYBYTES ] { 32 }
+Extension [ <persistent> extension #126 sodium version 2.0.2 ] {
+
+ - Constants [71] {
+ Constant [ string SODIUM_LIBRARY_VERSION ] { 1.0.12 }
+ Constant [ integer SODIUM_LIBRARY_MAJOR_VERSION ] { 9 }
+ Constant [ integer SODIUM_LIBRARY_MINOR_VERSION ] { 4 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_AES256GCM_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_AES256GCM_NSECBYTES ] { 0 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_AES256GCM_NPUBBYTES ] { 12 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_AES256GCM_ABYTES ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES ] { 0 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES ] { 8 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_ABYTES ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES ] { 0 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES ] { 12 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NSECBYTES ] { 0 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_NPUBBYTES ] { 24 }
+ Constant [ integer SODIUM_CRYPTO_AEAD_XCHACHA20POLY1305_IETF_ABYTES ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_AUTH_BYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_AUTH_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_BOX_SEALBYTES ] { 48 }
+ Constant [ integer SODIUM_CRYPTO_BOX_SECRETKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_BOX_PUBLICKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_BOX_KEYPAIRBYTES ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_BOX_MACBYTES ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_BOX_NONCEBYTES ] { 24 }
+ Constant [ integer SODIUM_CRYPTO_BOX_SEEDBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_KDF_BYTES_MIN ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_KDF_BYTES_MAX ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_KDF_CONTEXTBYTES ] { 8 }
+ Constant [ integer SODIUM_CRYPTO_KDF_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_KX_SEEDBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_KX_SESSIONKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_KX_PUBLICKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_KX_SECRETKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_KX_KEYPAIRBYTES ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES_MIN ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_GENERICHASH_BYTES_MAX ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_GENERICHASH_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MIN ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_GENERICHASH_KEYBYTES_MAX ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SALTBYTES ] { 16 }
+ Constant [ string SODIUM_CRYPTO_PWHASH_STRPREFIX ] { $argon2i$ }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE ] { 4 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE ] { 33554432 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_OPSLIMIT_MODERATE ] { 6 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_MEMLIMIT_MODERATE ] { 134217728 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_OPSLIMIT_SENSITIVE ] { 8 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_MEMLIMIT_SENSITIVE ] { 536870912 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES ] { 32 }
+ Constant [ string SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX ] { $7$ }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE ] { 524288 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE ] { 16777216 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE ] { 33554432 }
+ Constant [ integer SODIUM_CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE ] { 1073741824 }
+ Constant [ integer SODIUM_CRYPTO_SCALARMULT_BYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_SCALARMULT_SCALARBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_SHORTHASH_BYTES ] { 8 }
+ Constant [ integer SODIUM_CRYPTO_SHORTHASH_KEYBYTES ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_SECRETBOX_KEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_SECRETBOX_MACBYTES ] { 16 }
+ Constant [ integer SODIUM_CRYPTO_SECRETBOX_NONCEBYTES ] { 24 }
+ Constant [ integer SODIUM_CRYPTO_SIGN_BYTES ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_SIGN_SEEDBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_SIGN_PUBLICKEYBYTES ] { 32 }
+ Constant [ integer SODIUM_CRYPTO_SIGN_SECRETKEYBYTES ] { 64 }
+ Constant [ integer SODIUM_CRYPTO_SIGN_KEYPAIRBYTES ] { 96 }
+ Constant [ integer SODIUM_CRYPTO_STREAM_NONCEBYTES ] { 24 }
+ Constant [ integer SODIUM_CRYPTO_STREAM_KEYBYTES ] { 32 }
}
- Functions {
- Function [ <internal:libsodium> function Sodium\crypto_aead_aes256gcm_is_available ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_aes256gcm_is_available ] {
- Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\crypto_aead_aes256gcm_decrypt ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_aes256gcm_decrypt ] {
- Parameters [4] {
Parameter #0 [ <required> $string ]
@@ -76,7 +89,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #3 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_aead_aes256gcm_encrypt ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_aes256gcm_encrypt ] {
- Parameters [4] {
Parameter #0 [ <required> $string ]
@@ -85,7 +98,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #3 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_decrypt ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_decrypt ] {
- Parameters [4] {
Parameter #0 [ <required> $string ]
@@ -94,7 +107,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #3 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_encrypt ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_encrypt ] {
- Parameters [4] {
Parameter #0 [ <required> $string ]
@@ -103,7 +116,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #3 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_ietf_decrypt ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_ietf_decrypt ] {
- Parameters [4] {
Parameter #0 [ <required> $string ]
@@ -112,7 +125,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #3 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_ietf_encrypt ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_ietf_encrypt ] {
- Parameters [4] {
Parameter #0 [ <required> $string ]
@@ -121,14 +134,32 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #3 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_auth ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_xchacha20poly1305_ietf_decrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_aead_xchacha20poly1305_ietf_encrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_auth ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
Parameter #1 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_auth_verify ] {
+ Function [ <internal:sodium> function sodium_crypto_auth_verify ] {
- Parameters [3] {
Parameter #0 [ <required> $signature ]
@@ -136,7 +167,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box ] {
+ Function [ <internal:sodium> function sodium_crypto_box ] {
- Parameters [3] {
Parameter #0 [ <required> $string ]
@@ -144,25 +175,25 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_keypair ] {
+ Function [ <internal:sodium> function sodium_crypto_box_keypair ] {
- Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_seed_keypair ] {
+ Function [ <internal:sodium> function sodium_crypto_box_seed_keypair ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_keypair_from_secretkey_and_publickey ] {
+ Function [ <internal:sodium> function sodium_crypto_box_keypair_from_secretkey_and_publickey ] {
- Parameters [2] {
Parameter #0 [ <required> $secret_key ]
Parameter #1 [ <required> $public_key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_open ] {
+ Function [ <internal:sodium> function sodium_crypto_box_open ] {
- Parameters [3] {
Parameter #0 [ <required> $string ]
@@ -170,48 +201,76 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_publickey ] {
+ Function [ <internal:sodium> function sodium_crypto_box_publickey ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_publickey_from_secretkey ] {
+ Function [ <internal:sodium> function sodium_crypto_box_publickey_from_secretkey ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_seal ] {
+ Function [ <internal:sodium> function sodium_crypto_box_seal ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
Parameter #1 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_seal_open ] {
+ Function [ <internal:sodium> function sodium_crypto_box_seal_open ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
Parameter #1 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_box_secretkey ] {
+ Function [ <internal:sodium> function sodium_crypto_box_secretkey ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_kx ] {
+ Function [ <internal:sodium> function sodium_crypto_kx_keypair ] {
- - Parameters [4] {
- Parameter #0 [ <required> $string_1 ]
- Parameter #1 [ <required> $string_2 ]
- Parameter #2 [ <required> $string_3 ]
- Parameter #3 [ <optional> $string_4 ]
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_kx_publickey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_kx_secretkey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_generichash ] {
+ Function [ <internal:sodium> function sodium_crypto_kx_seed_keypair ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $string ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_kx_client_session_keys ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $client_keypair ]
+ Parameter #1 [ <required> $server_key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_kx_server_session_keys ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $server_keypair ]
+ Parameter #1 [ <required> $client_key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_generichash ] {
- Parameters [3] {
Parameter #0 [ <required> $string ]
@@ -219,28 +278,37 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <optional> $length ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_generichash_init ] {
+ Function [ <internal:sodium> function sodium_crypto_generichash_init ] {
- Parameters [2] {
Parameter #0 [ <optional> $key ]
Parameter #1 [ <optional> $length ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_generichash_update ] {
+ Function [ <internal:sodium> function sodium_crypto_generichash_update ] {
- Parameters [2] {
Parameter #0 [ <required> &$state ]
Parameter #1 [ <required> $string ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_generichash_final ] {
+ Function [ <internal:sodium> function sodium_crypto_generichash_final ] {
- Parameters [2] {
Parameter #0 [ <required> &$state ]
Parameter #1 [ <optional> $length ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_pwhash ] {
+ Function [ <internal:sodium> function sodium_crypto_kdf_derive_from_key ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $subkey_len ]
+ Parameter #1 [ <required> $subkey_id ]
+ Parameter #2 [ <required> $context ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_pwhash ] {
- Parameters [5] {
Parameter #0 [ <required> $length ]
@@ -250,7 +318,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #4 [ <required> $memlimit ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_pwhash_str ] {
+ Function [ <internal:sodium> function sodium_crypto_pwhash_str ] {
- Parameters [3] {
Parameter #0 [ <required> $password ]
@@ -258,14 +326,14 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $memlimit ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_pwhash_str_verify ] {
+ Function [ <internal:sodium> function sodium_crypto_pwhash_str_verify ] {
- Parameters [2] {
Parameter #0 [ <required> $hash ]
Parameter #1 [ <required> $password ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_pwhash_scryptsalsa208sha256 ] {
+ Function [ <internal:sodium> function sodium_crypto_pwhash_scryptsalsa208sha256 ] {
- Parameters [5] {
Parameter #0 [ <required> $length ]
@@ -275,7 +343,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #4 [ <required> $memlimit ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_pwhash_scryptsalsa208sha256_str ] {
+ Function [ <internal:sodium> function sodium_crypto_pwhash_scryptsalsa208sha256_str ] {
- Parameters [3] {
Parameter #0 [ <required> $password ]
@@ -283,21 +351,21 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $memlimit ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_pwhash_scryptsalsa208sha256_str_verify ] {
+ Function [ <internal:sodium> function sodium_crypto_pwhash_scryptsalsa208sha256_str_verify ] {
- Parameters [2] {
Parameter #0 [ <required> $hash ]
Parameter #1 [ <required> $password ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_scalarmult ] {
+ Function [ <internal:sodium> function sodium_crypto_scalarmult ] {
- Parameters [2] {
Parameter #0 [ <required> $string_1 ]
Parameter #1 [ <required> $string_2 ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_secretbox ] {
+ Function [ <internal:sodium> function sodium_crypto_secretbox ] {
- Parameters [3] {
Parameter #0 [ <required> $string ]
@@ -305,7 +373,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_secretbox_open ] {
+ Function [ <internal:sodium> function sodium_crypto_secretbox_open ] {
- Parameters [3] {
Parameter #0 [ <required> $string ]
@@ -313,83 +381,83 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_shorthash ] {
+ Function [ <internal:sodium> function sodium_crypto_shorthash ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
Parameter #1 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign ] {
+ Function [ <internal:sodium> function sodium_crypto_sign ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
Parameter #1 [ <required> $keypair ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_detached ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_detached ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
Parameter #1 [ <required> $keypair ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_ed25519_pk_to_curve25519 ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_ed25519_pk_to_curve25519 ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_ed25519_sk_to_curve25519 ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_ed25519_sk_to_curve25519 ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_keypair ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_keypair ] {
- Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_keypair_from_secretkey_and_publickey ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_keypair_from_secretkey_and_publickey ] {
- Parameters [2] {
Parameter #0 [ <required> $secret_key ]
Parameter #1 [ <required> $public_key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_open ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_open ] {
- Parameters [2] {
Parameter #0 [ <required> $string ]
Parameter #1 [ <required> $keypair ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_publickey ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_publickey ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_secretkey ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_secretkey ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_publickey_from_secretkey ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_publickey_from_secretkey ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_seed_keypair ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_seed_keypair ] {
- Parameters [1] {
Parameter #0 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_sign_verify_detached ] {
+ Function [ <internal:sodium> function sodium_crypto_sign_verify_detached ] {
- Parameters [3] {
Parameter #0 [ <required> $signature ]
@@ -397,7 +465,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_stream ] {
+ Function [ <internal:sodium> function sodium_crypto_stream ] {
- Parameters [3] {
Parameter #0 [ <required> $length ]
@@ -405,7 +473,7 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\crypto_stream_xor ] {
+ Function [ <internal:sodium> function sodium_crypto_stream_xor ] {
- Parameters [3] {
Parameter #0 [ <required> $string ]
@@ -413,85 +481,104 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
Parameter #2 [ <required> $key ]
}
}
- Function [ <internal:libsodium> function Sodium\randombytes_buf ] {
+ Function [ <internal:sodium> function sodium_bin2hex ] {
- Parameters [1] {
- Parameter #0 [ <required> $length ]
+ Parameter #0 [ <required> $string ]
}
}
- Function [ <internal:libsodium> function Sodium\randombytes_random16 ] {
+ Function [ <internal:sodium> function sodium_compare ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
}
}
- Function [ <internal:libsodium> function Sodium\randombytes_uniform ] {
+ Function [ <internal:sodium> function sodium_hex2bin ] {
- - Parameters [1] {
- Parameter #0 [ <required> $integer ]
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
}
}
- Function [ <internal:libsodium> function Sodium\bin2hex ] {
+ Function [ <internal:sodium> function sodium_increment ] {
- Parameters [1] {
- Parameter #0 [ <required> $string ]
+ Parameter #0 [ <required> &$string ]
}
}
- Function [ <internal:libsodium> function Sodium\compare ] {
+ Function [ <internal:sodium> function sodium_add ] {
- - Parameters [1] {
- Parameter #0 [ <required> $string ]
+ - Parameters [2] {
+ Parameter #0 [ <required> &$string_1 ]
+ Parameter #1 [ <required> $string_2 ]
}
}
- Function [ <internal:libsodium> function Sodium\hex2bin ] {
+ Function [ <internal:sodium> function sodium_memcmp ] {
- Parameters [2] {
Parameter #0 [ <required> $string_1 ]
Parameter #1 [ <required> $string_2 ]
}
}
- Function [ <internal:libsodium> function Sodium\increment ] {
+ Function [ <internal:sodium> function sodium_memzero ] {
- - Parameters [1] {
- Parameter #0 [ <required> $string ]
+ - Parameters [2] {
+ Parameter #0 [ <required> &$reference ]
+ Parameter #1 [ <required> $length ]
}
}
- Function [ <internal:libsodium> function Sodium\add ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_aes256gcm_keygen ] {
- - Parameters [2] {
- Parameter #0 [ <required> $string_1 ]
- Parameter #1 [ <required> $string_2 ]
+ - Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\library_version_major ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_keygen ] {
- Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\library_version_minor ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_chacha20poly1305_ietf_keygen ] {
- Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\memcmp ] {
+ Function [ <internal:sodium> function sodium_crypto_aead_xchacha20poly1305_ietf_keygen ] {
- - Parameters [2] {
- Parameter #0 [ <required> $string_1 ]
- Parameter #1 [ <required> $string_2 ]
+ - Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\memzero ] {
+ Function [ <internal:sodium> function sodium_crypto_auth_keygen ] {
- - Parameters [2] {
- Parameter #0 [ <required> &$reference ]
- Parameter #1 [ <required> $length ]
+ - Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\version_string ] {
+ Function [ <internal:sodium> function sodium_crypto_generichash_keygen ] {
- Parameters [0] {
}
}
- Function [ <internal:libsodium> function Sodium\crypto_scalarmult_base ] {
+ Function [ <internal:sodium> function sodium_crypto_kdf_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_secretbox_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_shorthash_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_stream_keygen ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:sodium> function sodium_crypto_scalarmult_base ] {
- Parameters [2] {
Parameter #0 [ <required> $string_1 ]
@@ -499,5 +586,64 @@ Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
}
}
}
+
+ - Classes [1] {
+ Class [ <internal:sodium> class SodiumException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+ }
}
diff --git a/php-pecl-libsodium2.spec b/php-pecl-libsodium2.spec
index dd33410..b65263e 100644
--- a/php-pecl-libsodium2.spec
+++ b/php-pecl-libsodium2.spec
@@ -12,7 +12,8 @@
%endif
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name libsodium
+%global proj_name libsodium
+%global pecl_name sodium
%global with_tests 0%{!?_without_tests:1}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -22,23 +23,23 @@
%global buildver %(pkg-config --silence-errors --modversion libsodium 2>/dev/null || echo 65536)
Summary: Wrapper for the Sodium cryptographic library
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.0.6
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Name: %{?sub_prefix}php-pecl-%{proj_name}2
+Version: 2.0.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
Group: Development/Languages
-URL: http://pecl.php.net/package/%{pecl_name}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+URL: http://pecl.php.net/package/%{proj_name}
+Source0: http://pecl.php.net/get/%{proj_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%if "%{?vendor}" == "Remi Collet"
# Ensure libsodium-last is used
-BuildRequires: libsodium-devel >= 1.0.7
+BuildRequires: pkgconfig(libsodium) >= 1.0.12
%else
# Per upstream documentation
BuildRequires: libsodium-devel >= 0.6.0
%endif
-BuildRequires: %{?scl_prefix}php-devel > 5.4
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-json
BuildRequires: pkgconfig
@@ -50,34 +51,40 @@ Requires: libsodium%{?_isa} >= %{buildver}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
-Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{proj_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{proj_name})%{?_isa} = %{version}
%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}2 = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}2%{?_isa} = %{version}-%{release}
%endif
+# Only one version
+Conflicts: %{?scl_prefix}php-pecl-%{proj_name} < 2
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php53-pecl-%{pecl_name} <= %{version}
-Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54-pecl-%{pecl_name} <= %{version}
-Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php53u-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php54-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php54w-pecl-%{proj_name}2 <= %{version}
%if "%{php_version}" > "5.5"
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55u-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php55w-pecl-%{proj_name}2 <= %{version}
%endif
%if "%{php_version}" > "5.6"
-Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56u-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php56w-pecl-%{proj_name}2 <= %{version}
%endif
%if "%{php_version}" > "7.0"
-Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70u-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php70w-pecl-%{proj_name}2 <= %{version}
%endif
%if "%{php_version}" > "7.1"
-Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71u-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php71w-pecl-%{proj_name}2 <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-pecl-%{proj_name}2 <= %{version}
+Obsoletes: php72w-pecl-%{proj_name}2 <= %{version}
%endif
%endif
@@ -96,7 +103,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c
-mv %{pecl_name}-%{version} NTS
+mv %{proj_name}-%{version} NTS
# Don't install tests
sed -e 's/role="test"/role="src"/' \
@@ -105,8 +112,10 @@ sed -e 's/role="test"/role="src"/' \
cd NTS
+sed -e '/PHP_SODIUM_VERSION/s/2.0.1/2.0.2/' -i php_libsodium.h
+
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_LIBSODIUM_VERSION/{s/.* "//;s/".*$//;p}' php_libsodium.h)
+extver=$(sed -n '/#define PHP_SODIUM_VERSION/{s/.* "//;s/".*$//;p}' php_libsodium.h)
if test "x${extver}" != "x%{version}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}.
exit 1
@@ -120,7 +129,7 @@ cp -pr NTS ZTS
# Create configuration file
cat > %{ini_name} << 'EOF'
-; Enable %{pecl_name} extension module
+; Enable %{proj_name} extension module
extension=%{pecl_name}.so
EOF
@@ -160,7 +169,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{proj_name}/$i
done
@@ -179,7 +188,7 @@ fi
%postun
if [ $1 -eq 0 -a -x %{__pecl} ] ; then
- %{pecl_uninstall} %{pecl_name} >/dev/null || :
+ %{pecl_uninstall} %{proj_name} >/dev/null || :
fi
%endif
@@ -224,7 +233,7 @@ rm -rf %{buildroot}
%files
%defattr(-,root,root,-)
-%doc %{pecl_docdir}/%{pecl_name}
+%doc %{pecl_docdir}/%{proj_name}
%{?_licensedir:%license NTS/LICENSE}
%{pecl_xmldir}/%{name}.xml
@@ -238,6 +247,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Jul 17 2017 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- renamed to php-pecl-libsodium2 (new API)
+- update to 2.0.2
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.0.6-3
- rebuild with PHP 7.1.0 GA