summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-07-17 18:01:53 +0200
committerRemi Collet <remi@remirepo.net>2017-07-17 18:01:53 +0200
commitd6f20501ff07620391291bb05ed1ac7760b9fee7 (patch)
tree66ad0a29947eab8f09b05a5c9b7b437f57708d5a
copy php-pecl-libsodium
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--REFLECTION503
-rw-r--r--php-pecl-libsodium2.spec324
4 files changed, 838 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..a237d8c
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,503 @@
+Extension [ <persistent> extension #121 libsodium version 1.0.6 ] {
+
+ - Constants [58] {
+ Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_NSECBYTES ] { 0 }
+ Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_NPUBBYTES ] { 12 }
+ Constant [ integer Sodium\CRYPTO_AEAD_AES256GCM_ABYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NSECBYTES ] { 0 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_NPUBBYTES ] { 8 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_ABYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NSECBYTES ] { 0 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_NPUBBYTES ] { 12 }
+ Constant [ integer Sodium\CRYPTO_AEAD_CHACHA20POLY1305_IETF_ABYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_AUTH_BYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_AUTH_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_BOX_SEALBYTES ] { 48 }
+ Constant [ integer Sodium\CRYPTO_BOX_SECRETKEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_BOX_PUBLICKEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_BOX_KEYPAIRBYTES ] { 64 }
+ Constant [ integer Sodium\CRYPTO_BOX_MACBYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_BOX_NONCEBYTES ] { 24 }
+ Constant [ integer Sodium\CRYPTO_BOX_SEEDBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_KX_BYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_KX_PUBLICKEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_KX_SECRETKEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_GENERICHASH_BYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_GENERICHASH_BYTES_MIN ] { 16 }
+ Constant [ integer Sodium\CRYPTO_GENERICHASH_BYTES_MAX ] { 64 }
+ Constant [ integer Sodium\CRYPTO_GENERICHASH_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_GENERICHASH_KEYBYTES_MIN ] { 16 }
+ Constant [ integer Sodium\CRYPTO_GENERICHASH_KEYBYTES_MAX ] { 64 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_SALTBYTES ] { 16 }
+ Constant [ string Sodium\CRYPTO_PWHASH_STRPREFIX ] { $argon2i$ }
+ Constant [ integer Sodium\CRYPTO_PWHASH_OPSLIMIT_INTERACTIVE ] { 4 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_MEMLIMIT_INTERACTIVE ] { 33554432 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_OPSLIMIT_MODERATE ] { 6 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_MEMLIMIT_MODERATE ] { 134217728 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_OPSLIMIT_SENSITIVE ] { 8 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_MEMLIMIT_SENSITIVE ] { 536870912 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_SALTBYTES ] { 32 }
+ Constant [ string Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_STRPREFIX ] { $7$ }
+ Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_INTERACTIVE ] { 524288 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_INTERACTIVE ] { 16777216 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_OPSLIMIT_SENSITIVE ] { 33554432 }
+ Constant [ integer Sodium\CRYPTO_PWHASH_SCRYPTSALSA208SHA256_MEMLIMIT_SENSITIVE ] { 1073741824 }
+ Constant [ integer Sodium\CRYPTO_SCALARMULT_BYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_SCALARMULT_SCALARBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_SHORTHASH_BYTES ] { 8 }
+ Constant [ integer Sodium\CRYPTO_SHORTHASH_KEYBYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_SECRETBOX_KEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_SECRETBOX_MACBYTES ] { 16 }
+ Constant [ integer Sodium\CRYPTO_SECRETBOX_NONCEBYTES ] { 24 }
+ Constant [ integer Sodium\CRYPTO_SIGN_BYTES ] { 64 }
+ Constant [ integer Sodium\CRYPTO_SIGN_SEEDBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_SIGN_PUBLICKEYBYTES ] { 32 }
+ Constant [ integer Sodium\CRYPTO_SIGN_SECRETKEYBYTES ] { 64 }
+ Constant [ integer Sodium\CRYPTO_SIGN_KEYPAIRBYTES ] { 96 }
+ Constant [ integer Sodium\CRYPTO_STREAM_NONCEBYTES ] { 24 }
+ Constant [ integer Sodium\CRYPTO_STREAM_KEYBYTES ] { 32 }
+ }
+
+ - Functions {
+ Function [ <internal:libsodium> function Sodium\crypto_aead_aes256gcm_is_available ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_aead_aes256gcm_decrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_aead_aes256gcm_encrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_decrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_encrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_ietf_decrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_aead_chacha20poly1305_ietf_encrypt ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $ad ]
+ Parameter #2 [ <required> $nonce ]
+ Parameter #3 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_auth ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_auth_verify ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $signature ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $nonce ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_keypair ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_seed_keypair ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_keypair_from_secretkey_and_publickey ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $secret_key ]
+ Parameter #1 [ <required> $public_key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_open ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $nonce ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_publickey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_publickey_from_secretkey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_seal ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_seal_open ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_box_secretkey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_kx ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
+ Parameter #2 [ <required> $string_3 ]
+ Parameter #3 [ <optional> $string_4 ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_generichash ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <optional> $key ]
+ Parameter #2 [ <optional> $length ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_generichash_init ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> $key ]
+ Parameter #1 [ <optional> $length ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_generichash_update ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$state ]
+ Parameter #1 [ <required> $string ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_generichash_final ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$state ]
+ Parameter #1 [ <optional> $length ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_pwhash ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $length ]
+ Parameter #1 [ <required> $password ]
+ Parameter #2 [ <required> $salt ]
+ Parameter #3 [ <required> $opslimit ]
+ Parameter #4 [ <required> $memlimit ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_pwhash_str ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $password ]
+ Parameter #1 [ <required> $opslimit ]
+ Parameter #2 [ <required> $memlimit ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_pwhash_str_verify ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $hash ]
+ Parameter #1 [ <required> $password ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_pwhash_scryptsalsa208sha256 ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $length ]
+ Parameter #1 [ <required> $password ]
+ Parameter #2 [ <required> $salt ]
+ Parameter #3 [ <required> $opslimit ]
+ Parameter #4 [ <required> $memlimit ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_pwhash_scryptsalsa208sha256_str ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $password ]
+ Parameter #1 [ <required> $opslimit ]
+ Parameter #2 [ <required> $memlimit ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_pwhash_scryptsalsa208sha256_str_verify ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $hash ]
+ Parameter #1 [ <required> $password ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_scalarmult ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_secretbox ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $nonce ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_secretbox_open ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $nonce ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_shorthash ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $keypair ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_detached ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $keypair ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_ed25519_pk_to_curve25519 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_ed25519_sk_to_curve25519 ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_keypair ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_keypair_from_secretkey_and_publickey ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $secret_key ]
+ Parameter #1 [ <required> $public_key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_open ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $keypair ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_publickey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_secretkey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_publickey_from_secretkey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_seed_keypair ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_sign_verify_detached ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $signature ]
+ Parameter #1 [ <required> $string ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_stream ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $length ]
+ Parameter #1 [ <required> $nonce ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_stream_xor ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $string ]
+ Parameter #1 [ <required> $nonce ]
+ Parameter #2 [ <required> $key ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\randombytes_buf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $length ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\randombytes_random16 ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\randombytes_uniform ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $integer ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\bin2hex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $string ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\compare ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $string ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\hex2bin ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\increment ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $string ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\add ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\library_version_major ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\library_version_minor ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\memcmp ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\memzero ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> &$reference ]
+ Parameter #1 [ <required> $length ]
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\version_string ] {
+
+ - Parameters [0] {
+ }
+ }
+ Function [ <internal:libsodium> function Sodium\crypto_scalarmult_base ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $string_1 ]
+ Parameter #1 [ <required> $string_2 ]
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-libsodium2.spec b/php-pecl-libsodium2.spec
new file mode 100644
index 0000000..dd33410
--- /dev/null
+++ b/php-pecl-libsodium2.spec
@@ -0,0 +1,324 @@
+# remirepo spec file for php-pecl-libsodium
+#
+# Copyright (c) 2014-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-pecl-libsodium
+%endif
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name libsodium
+%global with_tests 0%{!?_without_tests:1}
+%if "%{php_version}" < "5.6"
+%global ini_name %{pecl_name}.ini
+%else
+%global ini_name 40-%{pecl_name}.ini
+%endif
+%global buildver %(pkg-config --silence-errors --modversion libsodium 2>/dev/null || echo 65536)
+
+Summary: Wrapper for the Sodium cryptographic library
+Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Version: 1.0.6
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+License: BSD
+Group: Development/Languages
+URL: http://pecl.php.net/package/%{pecl_name}
+Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+%if "%{?vendor}" == "Remi Collet"
+# Ensure libsodium-last is used
+BuildRequires: libsodium-devel >= 1.0.7
+%else
+# Per upstream documentation
+BuildRequires: libsodium-devel >= 0.6.0
+%endif
+BuildRequires: %{?scl_prefix}php-devel > 5.4
+BuildRequires: %{?scl_prefix}php-pear
+BuildRequires: %{?scl_prefix}php-json
+BuildRequires: pkgconfig
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: libsodium%{?_isa} >= %{buildver}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+%if "%{?scl_prefix}" != "%{?sub_prefix}"
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+%endif
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+# Other third party repo stuff
+Obsoletes: php53-pecl-%{pecl_name} <= %{version}
+Obsoletes: php53u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54-pecl-%{pecl_name} <= %{version}
+Obsoletes: php54w-pecl-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php56w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php70w-pecl-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-pecl-%{pecl_name} <= %{version}
+Obsoletes: php71w-pecl-%{pecl_name} <= %{version}
+%endif
+%endif
+
+# Filter shared private - always as libsodium.so is a bad name
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+
+
+%description
+A simple, low-level PHP extension for libsodium.
+
+Documentation: https://paragonie.com/book/pecl-libsodium
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{scl_vendor})}.
+
+
+%prep
+%setup -q -c
+mv %{pecl_name}-%{version} NTS
+
+# Don't install tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_LIBSODIUM_VERSION/{s/.* "//;s/".*$//;p}' php_libsodium.h)
+if test "x${extver}" != "x%{version}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# Duplicate source tree for NTS / ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Create configuration file
+cat > %{ini_name} << 'EOF'
+; Enable %{pecl_name} extension module
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+
+make -C NTS install INSTALL_ROOT=%{buildroot}
+
+# install config file
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
+do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%if 0%{?fedora} < 24
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff
+%endif
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+%if %{with_tests}
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_ARGS="-n -d extension=json.so -d extension=$PWD/modules/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{_bindir}/zts-php -n run-tests.php --show-diff
+%endif
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%doc %{pecl_docdir}/%{pecl_name}
+%{?_licensedir:%license NTS/LICENSE}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 1.0.6-3
+- rebuild with PHP 7.1.0 GA
+
+* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 1.0.6-2
+- rebuild for PHP 7.1 new API version
+
+* Thu May 05 2016 Remi Collet <remi@fedoraproject.org> - 1.0.6-1
+- Update to 1.0.6
+
+* Fri Apr 08 2016 Remi Collet <remi@fedoraproject.org> - 1.0.5-1
+- Update to 1.0.5
+
+* Tue Apr 05 2016 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
+- Update to 1.0.4 (no change since 1.0.3)
+
+* Tue Apr 5 2016 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- Update to 1.0.3
+- raise minimal PHP version to 5.4
+- drop patch merged upstream
+
+* Sun Mar 6 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-4
+- adapt for F24
+
+* Wed Dec 9 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-3
+- rebuild against libsodium 1.0.7
+- add upstream patch for test suite from
+ https://github.com/jedisct1/libsodium-php/pull/70
+
+* Wed Nov 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-2
+- rebuild against libsodium 1.0.6
+
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- Update to 1.0.2
+- drop all patches, merged upstream
+
+* Tue Oct 27 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- Update to 1.0.1
+- fix for old libsodium
+ https://github.com/jedisct1/libsodium-php/pull/63
+- don't zero interned string
+ https://github.com/jedisct1/libsodium-php/pull/62
+- add dependency on libsodium version used at build time
+
+* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-3
+- rebuild for PHP 7.0.0RC5 new API version
+
+* Fri Sep 18 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-2
+- F23 rebuild with rh_layout
+
+* Thu Sep 03 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Update to 1.0.0 (stable)
+
+* Mon Jul 27 2015 Remi Collet <remi@fedoraproject.org> - 0.2.1-1
+- Update to 0.2.1 (beta)
+
+* Sun Jul 26 2015 Remi Collet <remi@fedoraproject.org> - 0.2.0-1
+- Update to 0.2.0 (beta)
+
+* Wed Jul 22 2015 Remi Collet <remi@fedoraproject.org> - 0.1.3-4
+- rebuild against php 7.0.0beta2
+
+* Wed Jul 8 2015 Remi Collet <remi@fedoraproject.org> - 0.1.3-3
+- rebuild against php 7.0.0beta1
+
+* Wed Jun 24 2015 Remi Collet <remi@fedoraproject.org> - 0.1.3-2
+- allow build against rh-php56 (as more-php56)
+- rebuild for "rh_layout" (php70)
+
+* Wed Apr 15 2015 Remi Collet <remi@fedoraproject.org> - 0.1.3-1
+- Update to 0.1.3 (beta)
+
+* Thu Apr 02 2015 Remi Collet <remi@fedoraproject.org> - 0.1.2-1
+- Update to 0.1.2 (beta)
+- drop runtime dependency on pear, new scriptlets
+- open https://github.com/jedisct1/libsodium-php/pull/22 - build
+- open https://github.com/jedisct1/libsodium-php/pull/23 - php 7
+
+* Wed Dec 24 2014 Remi Collet <remi@fedoraproject.org> - 0.1.1-1.1
+- Fedora 21 SCL mass rebuild
+
+* Sun Sep 28 2014 Remi Collet <rcollet@redhat.com> - 0.1.1-1
+- initial package, version 0.1.1 (beta)
+- open https://github.com/jedisct1/libsodium-php/pull/14
+