summaryrefslogtreecommitdiffstats
path: root/php-pecl-imagick.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-imagick.spec')
-rw-r--r--php-pecl-imagick.spec51
1 files changed, 18 insertions, 33 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 6de4afb..372067d 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-imagick
#
-# SPDX-FileCopyrightText: Copyright 2008-2024 Remi Collet
+# SPDX-FileCopyrightText: Copyright 2008-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
@@ -20,12 +20,9 @@
# NOTICE: 2 builds needed to get the full set
# All distro
# default (im7)
-# On Fedora <= 39 and EL <= 9
+# On EL 8 and 9
# --with im6
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
%if 0%{?scl:1}
%scl_package php-pecl-imagick
%else
@@ -36,17 +33,12 @@
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner imagick
%global gh_project imagick
-#global gh_date 20151204
%global pecl_name imagick
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.7.0
-#global upstream_prever RC1
-%if 0%{?gh_date:1}
-%global sources %{gh_project}-%{gh_commit}
-%else
+%global upstream_version 3.8.0
+%global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
-%endif
%global _configure ../%{sources}/configure
%if %{with im6}
@@ -57,19 +49,11 @@ Summary: Extension to create and modify images using ImageMagick 7
Name: %{?scl_prefix}php-pecl-imagick-im7
%endif
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-%if 0%{?gh_date}
-Release: 0.11.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Release: 13%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-%endif
License: PHP-3.01
URL: https://pecl.php.net/package/imagick
-Patch0: %{pecl_name}-tests.patch
-Patch1: %{pecl_name}-pr690.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -158,11 +142,6 @@ These are the files needed to compile programs using %{pecl_name} extension.
%prep
%setup -q -c
-%if 0%{?gh_date}
-mv NTS/package.xml .
-sed -e 's/@PACKAGE_VERSION@/%{version}dev/' -i NTS/php_imagick.h
-sed -e 's/3.3.0RC2/%{version}dev/' -i package.xml
-%endif
# don't install any font (and test using it)
# don't install empty file (d41d8cd98f00b204e9800998ecf8427e)
@@ -178,9 +157,6 @@ then : "Font files detected!"
fi
cd %{sources}
-%patch -P0 -p1
-%patch -P1 -p1
-
: Avoid arginfo to be regenerated
rm *.stub.php
@@ -310,10 +286,14 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%endif
if [ -f %{php_extdir}/%{pecl_name}.so ]; then
-: upstream test suite for extension built with previous version
-%{__php} --ri imagick
-TEST_PHP_ARGS="-n -d extension=%{pecl_name}" \
-%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+ # Only if same version
+ if %{__php} -n -d extension=%{pecl_name} -r 'exit(phpversion("%{pecl_name}")==="%{upstream_version}%{?upstream_prever}" ? 0 : 1);'
+ then
+ : upstream test suite for extension built with previous version
+ %{__php} --ri imagick
+ TEST_PHP_ARGS="-n -d extension=%{pecl_name}" \
+ %{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+ fi
fi
%endif
@@ -351,6 +331,11 @@ fi
%changelog
+* Fri Mar 14 2025 Remi Collet <remi@remirepo.net> - 3.8.0~RC2-1
+- update to 3.8.0RC2
+- open https://github.com/Imagick/imagick/issues/723 test failure with PHP 5.x
+- open https://github.com/Imagick/imagick/issues/724 erratic segfault in subImageMatch
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 3.7.0-13
- re-license spec file to CECILL-2.1
- im7 by default, change using --with im6 build option