summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile2
-rw-r--r--PHPINFO-im78
-rw-r--r--REFLECTION-im784
-rw-r--r--imagick-pr690.patch40
-rw-r--r--imagick-tests.patch94
-rw-r--r--php-pecl-imagick.spec51
6 files changed, 70 insertions, 209 deletions
diff --git a/Makefile b/Makefile
index 984c849..460477d 100644
--- a/Makefile
+++ b/Makefile
@@ -5,6 +5,4 @@ include ../../../common/Makefile
refl: $(NAME).spec
php --re imagick >REFLECTION-im7
php --ri imagick >PHPINFO-im7
- php82 --re imagick >REFLECTION-im6
- php82 --ri imagick >PHPINFO-im6
diff --git a/PHPINFO-im7 b/PHPINFO-im7
index ee5a245..7e8b6dd 100644
--- a/PHPINFO-im7
+++ b/PHPINFO-im7
@@ -2,12 +2,12 @@
imagick
imagick module => enabled
-imagick module version => 3.7.0
+imagick module version => 3.8.0RC2
imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
-Imagick compiled with ImageMagick version => ImageMagick 7.1.1-43 Q16-HDRI x86_64 22550 https://imagemagick.org
-Imagick using ImageMagick library version => ImageMagick 7.1.1-43 Q16-HDRI x86_64 22550 https://imagemagick.org
+Imagick compiled with ImageMagick version => ImageMagick 7.1.1-45 Q16-HDRI x86_64 22722 https://imagemagick.org
+Imagick using ImageMagick library version => ImageMagick 7.1.1-45 Q16-HDRI x86_64 22722 https://imagemagick.org
ImageMagick copyright => (C) 1999 ImageMagick Studio LLC
-ImageMagick release date => 2024-12-22
+ImageMagick release date => 2025-03-09
ImageMagick number of supported formats: => 273
ImageMagick supported formats => 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, ASHLAR, AVCI, AVI, AVIF, AVS, BAYER, BAYERA, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUBE, CUR, CUT, DATA, DCM, DCR, DCRAW, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FARBFELD, FAX, FF, FFF, FILE, FITS, FL32, FLV, FRACTAL, FTP, FTS, FTXT, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, HALD, HDR, HEIC, HEIF, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, JXL, K25, KDC, KERNEL, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MDC, MEF, MIFF, MKV, MNG, MONO, MOS, MOV, MP4, MPC, MPEG, MPG, MPO, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORA, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PHM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, QOI, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGB565, RGBA, RGBO, RGF, RLA, RLE, RMF, RSVG, RW2, RWL, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, SRW, STEGANO, STI, STRIMG, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TM2, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YAML, YCBCR, YCBCRA, YUV
diff --git a/REFLECTION-im7 b/REFLECTION-im7
index 6da5139..f55014e 100644
--- a/REFLECTION-im7
+++ b/REFLECTION-im7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
+Extension [ <persistent> extension #84 imagick version 3.8.0RC2 ] {
- Dependencies {
Dependency [ gmagick (Conflicts) ]
@@ -490,7 +490,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Class [ <internal:imagick> <iterateable> class Imagick implements Stringable, Iterator, Traversable, Countable ] {
- - Constants [629] {
+ - Constants [628] {
Constant [ public int COLOR_BLACK ] { 11 }
Constant [ public int COLOR_BLUE ] { 12 }
Constant [ public int COLOR_CYAN ] { 13 }
@@ -500,8 +500,8 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Constant [ public int COLOR_MAGENTA ] { 17 }
Constant [ public int COLOR_ALPHA ] { 18 }
Constant [ public int COLOR_FUZZ ] { 19 }
- Constant [ public int IMAGICK_EXTNUM ] { 30700 }
- Constant [ public string IMAGICK_EXTVER ] { 3.7.0 }
+ Constant [ public int IMAGICK_EXTNUM ] { 30800 }
+ Constant [ public string IMAGICK_EXTVER ] { 3.8.0RC2 }
Constant [ public int QUANTUM_RANGE ] { 65535 }
Constant [ public int USE_ZEND_MM ] { 0 }
Constant [ public int COMPOSITE_DEFAULT ] { 54 }
@@ -676,7 +676,6 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Constant [ public int COMPRESSION_WEBP ] { 23 }
Constant [ public int COMPRESSION_DWAA ] { 24 }
Constant [ public int COMPRESSION_DWAB ] { 25 }
- Constant [ public int COMPRESSION_BC7 ] { 26 }
Constant [ public int PAINT_POINT ] { 1 }
Constant [ public int PAINT_REPLACE ] { 2 }
Constant [ public int PAINT_FLOODFILL ] { 3 }
@@ -1238,7 +1237,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [1] {
Parameter #0 [ <required> int $type ]
}
- - Return [ int ]
+ - Return [ float ]
}
Method [ <internal:imagick> static public method getVersion ] {
@@ -1271,7 +1270,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [1] {
Parameter #0 [ <required> string $key ]
}
- - Return [ string ]
+ - Return [ string|false ]
}
Method [ <internal:imagick> static public method listRegistry ] {
@@ -1293,12 +1292,12 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Properties [0] {
}
- - Methods [376] {
+ - Methods [377] {
Method [ <internal:imagick> public method optimizeImageLayers ] {
- Parameters [0] {
}
- - Return [ bool ]
+ - Return [ Imagick ]
}
Method [ <internal:imagick> public method compareImageLayers ] {
@@ -1647,6 +1646,15 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Return [ bool ]
}
+ Method [ <internal:imagick> public method clutImageWithInterpolate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Imagick $lookup_table ]
+ Parameter #1 [ <required> int $pixel_interpolate_method ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:imagick> public method getImageProperties ] {
- Parameters [2] {
@@ -2258,7 +2266,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ ?string ]
}
Method [ <internal:imagick> public method getImagesBlob ] {
@@ -3070,7 +3078,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Method [ <internal:imagick> public method convolveImage ] {
- Parameters [2] {
- Parameter #0 [ <required> array $kernel ]
+ Parameter #0 [ <required> ImagickKernel $kernel ]
Parameter #1 [ <optional> int $channel = Imagick::CHANNEL_DEFAULT ]
}
- Return [ bool ]
@@ -3144,7 +3152,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [1] {
Parameter #0 [ <required> int $evaluate ]
}
- - Return [ bool ]
+ - Return [ Imagick ]
}
Method [ <internal:imagick> public method flattenImages ] {
@@ -3633,9 +3641,10 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Method [ <internal:imagick> public method setImageBluePrimary ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> float $x ]
Parameter #1 [ <required> float $y ]
+ Parameter #2 [ <required> float $z ]
}
- Return [ bool ]
}
@@ -3693,9 +3702,10 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Method [ <internal:imagick> public method setImageGreenPrimary ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> float $x ]
Parameter #1 [ <required> float $y ]
+ Parameter #2 [ <required> float $z ]
}
- Return [ bool ]
}
@@ -3719,9 +3729,10 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Method [ <internal:imagick> public method setImageRedPrimary ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> float $x ]
Parameter #1 [ <required> float $y ]
+ Parameter #2 [ <required> float $z ]
}
- Return [ bool ]
}
@@ -3744,9 +3755,10 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Method [ <internal:imagick> public method setImageWhitePoint ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> float $x ]
Parameter #1 [ <required> float $y ]
+ Parameter #2 [ <required> float $z ]
}
- Return [ bool ]
}
@@ -3829,7 +3841,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Parameter #0 [ <required> int $columns ]
Parameter #1 [ <required> int $rows ]
Parameter #2 [ <required> ImagickPixel|string $background_color ]
- Parameter #3 [ <optional> string $format = null ]
+ Parameter #3 [ <optional> ?string $format = null ]
}
- Return [ bool ]
}
@@ -4021,14 +4033,14 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [0] {
}
- - Tentative return [ void ]
+ - Return [ void ]
}
Method [ <internal:imagick, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
- - Tentative return [ void ]
+ - Return [ void ]
}
Method [ <internal:imagick, prototype Iterator> public method valid ] {
@@ -4098,8 +4110,8 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [5] {
Parameter #0 [ <required> Imagick $image ]
- Parameter #1 [ <optional> ?array &$offset = null ]
- Parameter #2 [ <optional> ?float &$similarity = null ]
+ Parameter #1 [ <optional> &$offset = null ]
+ Parameter #2 [ <optional> &$similarity = null ]
Parameter #3 [ <optional> float $threshold = 0.0 ]
Parameter #4 [ <optional> int $metric = 0 ]
}
@@ -4110,8 +4122,8 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [5] {
Parameter #0 [ <required> Imagick $image ]
- Parameter #1 [ <optional> ?array &$offset = null ]
- Parameter #2 [ <optional> ?float &$similarity = null ]
+ Parameter #1 [ <optional> &$offset = null ]
+ Parameter #2 [ <optional> &$similarity = null ]
Parameter #3 [ <optional> float $threshold = 0.0 ]
Parameter #4 [ <optional> int $metric = 0 ]
}
@@ -4197,7 +4209,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Parameter #0 [ <required> float $radius ]
Parameter #1 [ <required> float $strength ]
}
- - Return [ void ]
+ - Return [ bool ]
}
Method [ <internal:imagick> public method identifyImageType ] {
@@ -4869,7 +4881,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ string|false ]
}
Method [ <internal:imagick> public method getFontStretch ] {
@@ -4988,7 +5000,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ string|false ]
}
Method [ <internal:imagick> public method getClipRule ] {
@@ -5538,7 +5550,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Method [ <internal:imagick> public method setStrokeDashArray ] {
- Parameters [1] {
- Parameter #0 [ <required> array $dashes ]
+ Parameter #0 [ <required> ?array $dashes ]
}
- Return [ bool ]
}
@@ -5680,7 +5692,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [0] {
}
- - Return [ array ]
+ - Return [ ?array ]
}
Method [ <internal:imagick> public method getIteratorRow ] {
@@ -5694,7 +5706,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [0] {
}
- - Return [ array ]
+ - Return [ ?array ]
}
Method [ <internal:imagick> public method getPreviousIteratorRow ] {
@@ -5715,21 +5727,21 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [0] {
}
- - Tentative return [ void ]
+ - Return [ void ]
}
Method [ <internal:imagick, prototype Iterator> public method rewind ] {
- Parameters [0] {
}
- - Tentative return [ void ]
+ - Return [ void ]
}
Method [ <internal:imagick, prototype Iterator> public method current ] {
- Parameters [0] {
}
- - Return [ array ]
+ - Return [ ?array ]
}
Method [ <internal:imagick> public method newPixelIterator ] {
@@ -5898,7 +5910,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Parameter #0 [ <required> ImagickPixel|string $color ]
Parameter #1 [ <required> float $fuzz ]
}
- - Return [ bool ]
+ - Return [ ?bool ]
}
Method [ <internal:imagick> public method isPixelSimilarQuantum ] {
@@ -5907,7 +5919,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Parameter #0 [ <required> ImagickPixel|string $color ]
Parameter #1 [ <required> float $fuzz_quantum_range_scaled_by_square_root_of_three ]
}
- - Return [ bool ]
+ - Return [ ?bool ]
}
Method [ <internal:imagick> public method isSimilar ] {
@@ -5916,7 +5928,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
Parameter #0 [ <required> ImagickPixel|string $color ]
Parameter #1 [ <required> float $fuzz_quantum_range_scaled_by_square_root_of_three ]
}
- - Return [ bool ]
+ - Return [ ?bool ]
}
Method [ <internal:imagick> public method setColor ] {
@@ -6003,7 +6015,7 @@ Extension [ <persistent> extension #82 imagick version 3.7.0 ] {
- Parameters [2] {
Parameter #0 [ <required> array $matrix ]
- Parameter #1 [ <required> ?array $origin ]
+ Parameter #1 [ <optional> ?array $origin = null ]
}
- Return [ ImagickKernel ]
}
diff --git a/imagick-pr690.patch b/imagick-pr690.patch
deleted file mode 100644
index 189e745..0000000
--- a/imagick-pr690.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 65e27f2bc02e7e8f1bf64e26e359e42a1331fca1 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Michael=20Vo=C5=99=C3=AD=C5=A1ek?= <mvorisek@mvorisek.cz>
-Date: Wed, 25 Sep 2024 10:56:28 +0200
-Subject: [PATCH] Fix removed "php_strtolower" for PHP 8.4
-
----
- imagick.c | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/imagick.c b/imagick.c
-index 1b765389..ebab7ae7 100644
---- a/imagick.c
-+++ b/imagick.c
-@@ -610,7 +610,7 @@ static zval *php_imagick_read_property(zend_object *object, zend_string *member,
- if (format) {
- retval = rv;
- ZVAL_STRING(retval, format);
-- php_strtolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
-+ zend_str_tolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
- IMAGICK_FREE_MAGICK_MEMORY(format);
- } else {
- retval = rv;
-@@ -683,7 +683,7 @@ static zval *php_imagick_read_property(zval *object, zval *member, int type, voi
- if (format) {
- retval = rv;
- ZVAL_STRING(retval, format);
-- php_strtolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
-+ zend_str_tolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
- IMAGICK_FREE_MAGICK_MEMORY(format);
- } else {
- retval = rv;
-@@ -766,7 +766,7 @@ static zval *php_imagick_read_property(zval *object, zval *member, int type, con
-
- if (format) {
- ZVAL_STRING(retval, format, 1);
-- php_strtolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
-+ zend_str_tolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
- IMAGICK_FREE_MAGICK_MEMORY(format);
- } else {
- ZVAL_STRING(retval, "", 1);
diff --git a/imagick-tests.patch b/imagick-tests.patch
deleted file mode 100644
index 7f6990b..0000000
--- a/imagick-tests.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 944b67fce68bcb5835999a149f917670555b6fcb Mon Sep 17 00:00:00 2001
-From: Danack <Danack@basereality.com>
-Date: Fri, 9 Feb 2024 13:59:39 +0000
-Subject: [PATCH] Improve test so that is passes.
-
-The underlying maths for some statistics changed: https://github.com/ImageMagick/ImageMagick/issues/6924 so the tests need to pass on both before and after maths.
----
- bisect/bisect_analyze.sh | 61 +++++++++++++++++++++++++
- tests/316_Imagick_getImageKurtosis.phpt | 12 ++++-
- tests/functions.inc | 40 +++++++++++++++-
- 3 files changed, 110 insertions(+), 3 deletions(-)
- create mode 100644 bisect/bisect_analyze.sh
-
-diff --git a/tests/316_Imagick_getImageKurtosis.phpt b/tests/316_Imagick_getImageKurtosis.phpt
-index 2618924a..61370b57 100644
---- a/tests/316_Imagick_getImageKurtosis.phpt
-+++ b/tests/316_Imagick_getImageKurtosis.phpt
-@@ -14,8 +14,16 @@ function getImageKurtosis() {
- $imagick = new \Imagick(__DIR__ . '/Biter_500.jpg');
- $values = $imagick->getImageKurtosis();
-
-- check_value($values, "kurtosis", -0.9379261035010518);
-- check_value($values, "skewness", 0.4562517200972045);
-+ check_value_posibilities(
-+ $values,
-+ "kurtosis",
-+ [-0.9379261035010518, -0.70925995674921]
-+ );
-+ check_value_posibilities(
-+ $values,
-+ "skewness",
-+ [0.4562517200972045, 0.56839010636614]
-+ );
- }
-
- getImageKurtosis() ;
-diff --git a/tests/functions.inc b/tests/functions.inc
-index bbd60ac0..11012864 100644
---- a/tests/functions.inc
-+++ b/tests/functions.inc
-@@ -111,7 +111,10 @@ function setFontForImagickDraw(\ImagickDraw $imagickDraw)
- $imagickDraw->setFont($font);
- }
-
--
-+/**
-+ * Checks that a named value exists in an array and it matches
-+ * an expected value.
-+ */
- function check_value(array $values, $name, $expected_value)
- {
- if (array_key_exists($name, $values) !== true) {
-@@ -136,6 +139,41 @@ function check_value(array $values, $name, $expected_value)
- }
-
-
-+/**
-+ * Checks that a named value exists in an array and it matches
-+ * one of a number of expected values.
-+ * This function exists because the expected values for Kurtosis can
-+ * change when the underlying maths changes: https://github.com/ImageMagick/ImageMagick/issues/6924
-+ */
-+function check_value_posibilities(array $values, $name, array $expected_values)
-+{
-+ if (array_key_exists($name, $values) !== true) {
-+
-+ $message = "Expected key '$name' not set. Array contains:\n";
-+ $message .= var_export($values, true);
-+
-+ throw new \Exception($message);
-+ }
-+
-+
-+ $value = $values[$name];
-+
-+ $epsilon = 0.01;
-+
-+ foreach ($expected_values as $expected_value) {
-+ if (($value > $expected_value - $epsilon) && ($value < $expected_value + $epsilon)) {
-+ echo "Value for '$name' is $value which is close enough to expected $expected_value\n";
-+ return;
-+ }
-+ }
-+
-+ $expected_string = implode(", ", $expected_values);
-+
-+ $message = "Value for $name doesn't match expected possibilities. Expected one of: $expected_string, actual: $value";
-+ throw new \Exception($message);
-+}
-+
-+
- function check_value_with_epsilon(array $values, $name, $expected_value, $epsilon)
- {
- if (array_key_exists($name, $values) !== true) {
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 6de4afb..372067d 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-imagick
#
-# SPDX-FileCopyrightText: Copyright 2008-2024 Remi Collet
+# SPDX-FileCopyrightText: Copyright 2008-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
@@ -20,12 +20,9 @@
# NOTICE: 2 builds needed to get the full set
# All distro
# default (im7)
-# On Fedora <= 39 and EL <= 9
+# On EL 8 and 9
# --with im6
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
%if 0%{?scl:1}
%scl_package php-pecl-imagick
%else
@@ -36,17 +33,12 @@
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner imagick
%global gh_project imagick
-#global gh_date 20151204
%global pecl_name imagick
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global ini_name 40-%{pecl_name}.ini
-%global upstream_version 3.7.0
-#global upstream_prever RC1
-%if 0%{?gh_date:1}
-%global sources %{gh_project}-%{gh_commit}
-%else
+%global upstream_version 3.8.0
+%global upstream_prever RC2
%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
-%endif
%global _configure ../%{sources}/configure
%if %{with im6}
@@ -57,19 +49,11 @@ Summary: Extension to create and modify images using ImageMagick 7
Name: %{?scl_prefix}php-pecl-imagick-im7
%endif
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-%if 0%{?gh_date}
-Release: 0.11.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-%else
-Release: 13%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
-%endif
License: PHP-3.01
URL: https://pecl.php.net/package/imagick
-Patch0: %{pecl_name}-tests.patch
-Patch1: %{pecl_name}-pr690.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -158,11 +142,6 @@ These are the files needed to compile programs using %{pecl_name} extension.
%prep
%setup -q -c
-%if 0%{?gh_date}
-mv NTS/package.xml .
-sed -e 's/@PACKAGE_VERSION@/%{version}dev/' -i NTS/php_imagick.h
-sed -e 's/3.3.0RC2/%{version}dev/' -i package.xml
-%endif
# don't install any font (and test using it)
# don't install empty file (d41d8cd98f00b204e9800998ecf8427e)
@@ -178,9 +157,6 @@ then : "Font files detected!"
fi
cd %{sources}
-%patch -P0 -p1
-%patch -P1 -p1
-
: Avoid arginfo to be regenerated
rm *.stub.php
@@ -310,10 +286,14 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
%endif
if [ -f %{php_extdir}/%{pecl_name}.so ]; then
-: upstream test suite for extension built with previous version
-%{__php} --ri imagick
-TEST_PHP_ARGS="-n -d extension=%{pecl_name}" \
-%{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+ # Only if same version
+ if %{__php} -n -d extension=%{pecl_name} -r 'exit(phpversion("%{pecl_name}")==="%{upstream_version}%{?upstream_prever}" ? 0 : 1);'
+ then
+ : upstream test suite for extension built with previous version
+ %{__php} --ri imagick
+ TEST_PHP_ARGS="-n -d extension=%{pecl_name}" \
+ %{__php} -n run-tests.php -q --show-diff %{?_smp_mflags}
+ fi
fi
%endif
@@ -351,6 +331,11 @@ fi
%changelog
+* Fri Mar 14 2025 Remi Collet <remi@remirepo.net> - 3.8.0~RC2-1
+- update to 3.8.0RC2
+- open https://github.com/Imagick/imagick/issues/723 test failure with PHP 5.x
+- open https://github.com/Imagick/imagick/issues/724 erratic segfault in subImageMatch
+
* Mon Dec 23 2024 Remi Collet <remi@remirepo.net> - 3.7.0-13
- re-license spec file to CECILL-2.1
- im7 by default, change using --with im6 build option