summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-23 06:58:31 +0200
committerRemi Collet <remi@remirepo.net>2021-07-23 06:58:31 +0200
commitc988947a5d0198996e48e915214867b8977d63f6 (patch)
treefefa0331fe568b7beb1a9a941d897998ede6b8a9
parent3ee19f120e6abdc27198e25718c65a16b5c2879e (diff)
update to 3.5.1
drop patch merged upstream
-rw-r--r--Makefile6
-rw-r--r--PHPINFO-im620
-rw-r--r--PHPINFO-im7 (renamed from PHPINFO)2
-rw-r--r--REFLECTION-im68
-rw-r--r--REFLECTION-im78
-rw-r--r--imagick-php81.patch143
-rw-r--r--php-pecl-imagick.spec10
7 files changed, 40 insertions, 157 deletions
diff --git a/Makefile b/Makefile
index 13af741..80f13aa 100644
--- a/Makefile
+++ b/Makefile
@@ -2,3 +2,9 @@ SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
include ../../../common/Makefile
+refl: $(NAME).spec
+ php --re imagick >REFLECTION-im7
+ php --ri imagick >PHPINFO-im7
+ php74 --re imagick >REFLECTION-im6
+ php74 --ri imagick >PHPINFO-im6
+
diff --git a/PHPINFO-im6 b/PHPINFO-im6
new file mode 100644
index 0000000..150cb0c
--- /dev/null
+++ b/PHPINFO-im6
@@ -0,0 +1,20 @@
+
+imagick
+
+imagick module => enabled
+imagick module version => 3.5.1
+imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
+Imagick compiled with ImageMagick version => ImageMagick 6.9.12-19 Q16 x86_64 2021-07-18 https://imagemagick.org
+Imagick using ImageMagick library version => ImageMagick 6.9.12-19 Q16 x86_64 2021-07-18 https://imagemagick.org
+ImageMagick copyright => (C) 1999-2021 ImageMagick Studio LLC
+ImageMagick release date => 2021-07-18
+ImageMagick number of supported formats: => 247
+ImageMagick supported formats => 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
+
+Directive => Local Value => Master Value
+imagick.locale_fix => 0 => 0
+imagick.skip_version_check => 1 => 1
+imagick.progress_monitor => 0 => 0
+imagick.set_single_thread => 1 => 1
+imagick.shutdown_sleep_count => 10 => 10
+imagick.allow_zero_dimension_images => 0 => 0
diff --git a/PHPINFO b/PHPINFO-im7
index 3e646d6..09c6700 100644
--- a/PHPINFO
+++ b/PHPINFO-im7
@@ -2,7 +2,7 @@
imagick
imagick module => enabled
-imagick module version => 3.5.1RC1
+imagick module version => 3.5.1
imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
Imagick compiled with ImageMagick version => ImageMagick 7.1.0-4 Q16 x86_64 2021-07-18 https://imagemagick.org
Imagick using ImageMagick library version => ImageMagick 7.1.0-4 Q16 x86_64 2021-07-18 https://imagemagick.org
diff --git a/REFLECTION-im6 b/REFLECTION-im6
index db65ffa..07971e0 100644
--- a/REFLECTION-im6
+++ b/REFLECTION-im6
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #15 imagick version 3.5.0 ] {
+Extension [ <persistent> extension #96 imagick version 3.5.1 ] {
- Dependencies {
Dependency [ gmagick (Conflicts) ]
@@ -11,7 +11,7 @@ Extension [ <persistent> extension #15 imagick version 3.5.0 ] {
Current = '0'
}
Entry [ imagick.skip_version_check <ALL> ]
- Current = '0'
+ Current = '1'
}
Entry [ imagick.progress_monitor <SYSTEM> ]
Current = '0'
@@ -326,8 +326,8 @@ Extension [ <persistent> extension #15 imagick version 3.5.0 ] {
Constant [ public int COLOR_OPACITY ] { 18 }
Constant [ public int COLOR_ALPHA ] { 19 }
Constant [ public int COLOR_FUZZ ] { 20 }
- Constant [ public int IMAGICK_EXTNUM ] { 30500 }
- Constant [ public string IMAGICK_EXTVER ] { 3.5.0 }
+ Constant [ public int IMAGICK_EXTNUM ] { 30501 }
+ Constant [ public string IMAGICK_EXTVER ] { 3.5.1 }
Constant [ public int QUANTUM_RANGE ] { 65535 }
Constant [ public int USE_ZEND_MM ] { 0 }
Constant [ public int COMPOSITE_DEFAULT ] { 40 }
diff --git a/REFLECTION-im7 b/REFLECTION-im7
index 4eb7035..7e1da79 100644
--- a/REFLECTION-im7
+++ b/REFLECTION-im7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #15 imagick version 3.5.0 ] {
+Extension [ <persistent> extension #76 imagick version 3.5.1 ] {
- Dependencies {
Dependency [ gmagick (Conflicts) ]
@@ -11,7 +11,7 @@ Extension [ <persistent> extension #15 imagick version 3.5.0 ] {
Current = '0'
}
Entry [ imagick.skip_version_check <ALL> ]
- Current = '0'
+ Current = '1'
}
Entry [ imagick.progress_monitor <SYSTEM> ]
Current = '0'
@@ -325,8 +325,8 @@ Extension [ <persistent> extension #15 imagick version 3.5.0 ] {
Constant [ public int COLOR_MAGENTA ] { 17 }
Constant [ public int COLOR_ALPHA ] { 18 }
Constant [ public int COLOR_FUZZ ] { 19 }
- Constant [ public int IMAGICK_EXTNUM ] { 30500 }
- Constant [ public string IMAGICK_EXTVER ] { 3.5.0 }
+ Constant [ public int IMAGICK_EXTNUM ] { 30501 }
+ Constant [ public string IMAGICK_EXTVER ] { 3.5.1 }
Constant [ public int QUANTUM_RANGE ] { 65535 }
Constant [ public int USE_ZEND_MM ] { 0 }
Constant [ public int COMPOSITE_DEFAULT ] { 54 }
diff --git a/imagick-php81.patch b/imagick-php81.patch
deleted file mode 100644
index 86c71ae..0000000
--- a/imagick-php81.patch
+++ /dev/null
@@ -1,143 +0,0 @@
-From 28508a8b376a866a653ae4fba5d920d8277c83a3 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 21 Jul 2021 10:53:38 +0200
-Subject: [PATCH] fix for PHP 8.1.0beta1
-
----
- Imagick.stub.php | 12 ++++++++----
- ImagickPixelIterator.stub.php | 14 +++++++++-----
- ImagickPixelIterator_arginfo.h | 5 +++--
- Imagick_arginfo.h | 5 +++--
- regen_arginfo.sh | 4 ++--
- shim_php7_to_php8.h | 7 ++++++-
- 6 files changed, 31 insertions(+), 16 deletions(-)
-
-diff --git a/Imagick.stub.php b/Imagick.stub.php
-index b1189b64..7fe3ed82 100644
---- a/Imagick.stub.php
-+++ b/Imagick.stub.php
-@@ -1223,11 +1223,15 @@ public function key(): int {}
- //# endif
- //#endif
-
-- /** @alias Imagick::nextImage */
-- public function next(): bool {}
-+ /** @alias Imagick::nextImage
-+ * @tentative-return-type
-+ */
-+ public function next(): void {}
-
-- /** @alias Imagick::setFirstIterator */
-- public function rewind(): bool {}
-+ /** @alias Imagick::setFirstIterator
-+ * @tentative-return-type
-+ */
-+ public function rewind(): void {}
-
- public function valid(): bool {}
-
-diff --git a/ImagickPixelIterator.stub.php b/ImagickPixelIterator.stub.php
-index 8a5b7cde..96072333 100644
---- a/ImagickPixelIterator.stub.php
-+++ b/ImagickPixelIterator.stub.php
-@@ -30,11 +30,15 @@ public function getPreviousIteratorRow(): array {}
- /** @alias ImagickPixelIterator::getIteratorRow */
- public function key(): int {}
-
-- /** @alias ImagickPixelIterator::getNextIteratorRow */
-- public function next(): array {}
-+ /** @alias ImagickPixelIterator::getNextIteratorRow
-+ * @tentative-return-type
-+ */
-+ public function next(): void {}
-
-- /** @alias ImagickPixelIterator::resetIterator */
-- public function rewind(): bool {}
-+ /** @alias ImagickPixelIterator::resetIterator
-+ * @tentative-return-type
-+ */
-+ public function rewind(): void {}
-
- /** @alias ImagickPixelIterator::getCurrentIteratorRow */
- public function current(): array {}
-@@ -59,4 +63,4 @@ public function setIteratorRow(int $row): bool {}
- public function syncIterator(): bool {}
-
- public function valid(): bool {}
--}
-\ No newline at end of file
-+}
-diff --git a/ImagickPixelIterator_arginfo.h b/ImagickPixelIterator_arginfo.h
-index ef20a02e..26237941 100644
---- a/ImagickPixelIterator_arginfo.h
-+++ b/ImagickPixelIterator_arginfo.h
-@@ -85,9 +85,10 @@ ZEND_END_ARG_INFO()
-
- #define arginfo_class_ImagickPixelIterator_key arginfo_class_ImagickPixelIterator_getIteratorRow
-
--#define arginfo_class_ImagickPixelIterator_next arginfo_class_ImagickPixelIterator_getCurrentIteratorRow
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_class_ImagickPixelIterator_next, 0, 0, IS_VOID, 0)
-+ZEND_END_ARG_INFO()
-
--#define arginfo_class_ImagickPixelIterator_rewind arginfo_class_ImagickPixelIterator_clear
-+#define arginfo_class_ImagickPixelIterator_rewind arginfo_class_ImagickPixelIterator_next
-
- #define arginfo_class_ImagickPixelIterator_current arginfo_class_ImagickPixelIterator_getCurrentIteratorRow
-
-diff --git a/Imagick_arginfo.h b/Imagick_arginfo.h
-index db2b2ee5..2df4076c 100644
---- a/Imagick_arginfo.h
-+++ b/Imagick_arginfo.h
-@@ -4786,11 +4786,12 @@ ZEND_END_ARG_INFO()
- #endif
-
- #if MagickLibVersion > 0x628
--#define arginfo_class_Imagick_next arginfo_class_Imagick_optimizeImageLayers
-+ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(arginfo_class_Imagick_next, 0, 0, IS_VOID, 0)
-+ZEND_END_ARG_INFO()
- #endif
-
- #if MagickLibVersion > 0x628
--#define arginfo_class_Imagick_rewind arginfo_class_Imagick_optimizeImageLayers
-+#define arginfo_class_Imagick_rewind arginfo_class_Imagick_next
- #endif
-
- #if MagickLibVersion > 0x628
-diff --git a/regen_arginfo.sh b/regen_arginfo.sh
-index 96c24cea..1df4ade5 100755
---- a/regen_arginfo.sh
-+++ b/regen_arginfo.sh
-@@ -2,9 +2,9 @@
-
- VER=0$(php-config --vernum 2>/dev/null)
-
--if [ $VER -lt 70100 ]; then
-+if [ $VER -lt 80100 ]; then
-
-- echo "You need php >= 7.1 to run this script"
-+ echo "You need php >= 8.1 to run this script"
-
- elif [ ! -f build/gen_stub.php ]; then
-
-diff --git a/shim_php7_to_php8.h b/shim_php7_to_php8.h
-index 5f8d89b4..7c4e92c7 100644
---- a/shim_php7_to_php8.h
-+++ b/shim_php7_to_php8.h
-@@ -1,5 +1,10 @@
-
-
-+#if PHP_VERSION_ID < 80100
-+#define ZEND_BEGIN_ARG_WITH_TENTATIVE_RETURN_TYPE_INFO_EX(name, return_reference, required_num_args, type, allow_null) \
-+ ZEND_BEGIN_ARG_INFO_EX(name, return_reference, required_num_args, allow_null)
-+#endif
-+
- #if PHP_VERSION_ID < 80000
- // Allow the generated stubs to work on previous versions of PHP
-
-@@ -11,4 +16,4 @@
-
- #define MAY_BE_STRING ""
-
--#endif
-\ No newline at end of file
-+#endif
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 5bbdc7b..6277fa1 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -35,7 +35,7 @@
%global ini_name 40-%{pecl_name}.ini
%endif
%global upstream_version 3.5.1
-%global upstream_prever RC1
+#global upstream_prever RC1
%if %{with im7}
Summary: Extension to create and modify images using ImageMagick 7
@@ -55,8 +55,6 @@ Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstr
License: PHP
URL: https://pecl.php.net/package/imagick
-Patch0: %{pecl_name}-php81.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -196,8 +194,6 @@ then : "Font files detected!"
fi
cd NTS
-%patch0 -p1 -b .pr450
-
: Fix permission for archive generated on Windows
find . -type f -exec chmod -x {} \;
@@ -365,6 +361,10 @@ cd ../ZTS
%changelog
+* Fri Jul 23 2021 Remi Collet <remi@remirepo.net> - 3.5.1-1
+- update to 3.5.1
+- drop patch merged upstream
+
* Wed Jul 21 2021 Remi Collet <remi@remirepo.net> - 3.5.1~RC1-1
- update to 3.5.1RC1
- add patch for PHP 8.1.0beta1 from