summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-10 15:24:38 +0100
committerRemi Collet <remi@php.net>2021-11-10 15:24:38 +0100
commit9eacf9cf8bb617b2bd3385fcc63099f78565cbc0 (patch)
treeaa3ba208a2f961b903bc25d842ce16e85f38b289
parent258fa728d64bd82631fa68fb8695540af20ab9b8 (diff)
update to 3.6.0RC1
drop patch merged upstream
-rw-r--r--458.patch37
-rw-r--r--PHPINFO-im68
-rw-r--r--PHPINFO-im78
-rw-r--r--REFLECTION-im622
-rw-r--r--REFLECTION-im7250
-rw-r--r--php-pecl-imagick.spec39
6 files changed, 284 insertions, 80 deletions
diff --git a/458.patch b/458.patch
deleted file mode 100644
index 45a2ae7..0000000
--- a/458.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 46fd58be9c1291eb563fd13315de5eeae9107c75 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Mon, 20 Sep 2021 13:44:02 +0200
-Subject: [PATCH] Fix #457 ensure format is always lowercase
-
----
- imagick.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/imagick.c b/imagick.c
-index ac889118..ee725669 100644
---- a/imagick.c
-+++ b/imagick.c
-@@ -3388,6 +3388,7 @@ static zval *php_imagick_read_property(zend_object *object, zend_string *member,
- if (format) {
- retval = rv;
- ZVAL_STRING(retval, format);
-+ php_strtolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
- IMAGICK_FREE_MAGICK_MEMORY(format);
- } else {
- retval = rv;
-@@ -3460,6 +3461,7 @@ static zval *php_imagick_read_property(zval *object, zval *member, int type, voi
- if (format) {
- retval = rv;
- ZVAL_STRING(retval, format);
-+ php_strtolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
- IMAGICK_FREE_MAGICK_MEMORY(format);
- } else {
- retval = rv;
-@@ -3542,6 +3544,7 @@ static zval *php_imagick_read_property(zval *object, zval *member, int type, con
-
- if (format) {
- ZVAL_STRING(retval, format, 1);
-+ php_strtolower(Z_STRVAL_P(retval), Z_STRLEN_P(retval));
- IMAGICK_FREE_MAGICK_MEMORY(format);
- } else {
- ZVAL_STRING(retval, "", 1);
diff --git a/PHPINFO-im6 b/PHPINFO-im6
index 2497251..480d0d6 100644
--- a/PHPINFO-im6
+++ b/PHPINFO-im6
@@ -2,12 +2,12 @@
imagick
imagick module => enabled
-imagick module version => 3.5.1
+imagick module version => 3.6.0RC1
imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
-Imagick compiled with ImageMagick version => ImageMagick 6.9.12-23 Q16 x86_64 2021-09-18 https://imagemagick.org
-Imagick using ImageMagick library version => ImageMagick 6.9.12-23 Q16 x86_64 2021-09-18 https://imagemagick.org
+Imagick compiled with ImageMagick version => ImageMagick 6.9.12-28 Q16 x86_64 2021-10-29 https://imagemagick.org
+Imagick using ImageMagick library version => ImageMagick 6.9.12-28 Q16 x86_64 2021-10-29 https://imagemagick.org
ImageMagick copyright => (C) 1999-2021 ImageMagick Studio LLC
-ImageMagick release date => 2021-09-18
+ImageMagick release date => 2021-10-29
ImageMagick number of supported formats: => 247
ImageMagick supported formats => 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
diff --git a/PHPINFO-im7 b/PHPINFO-im7
index 98dfb2d..6a4c47a 100644
--- a/PHPINFO-im7
+++ b/PHPINFO-im7
@@ -2,12 +2,12 @@
imagick
imagick module => enabled
-imagick module version => 3.5.1
+imagick module version => 3.6.0RC1
imagick classes => Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel
-Imagick compiled with ImageMagick version => ImageMagick 7.1.0-8 Q16-HDRI x86_64 2021-09-18 https://imagemagick.org
-Imagick using ImageMagick library version => ImageMagick 7.1.0-8 Q16-HDRI x86_64 2021-09-18 https://imagemagick.org
+Imagick compiled with ImageMagick version => ImageMagick 7.1.0-13 Q16-HDRI x86_64 2021-10-29 https://imagemagick.org
+Imagick using ImageMagick library version => ImageMagick 7.1.0-13 Q16-HDRI x86_64 2021-10-29 https://imagemagick.org
ImageMagick copyright => (C) 1999-2021 ImageMagick Studio LLC
-ImageMagick release date => 2021-09-18
+ImageMagick release date => 2021-10-29
ImageMagick number of supported formats: => 259
ImageMagick supported formats => 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, ASHLAR, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUBE, CUR, CUT, DATA, DCM, DCR, DCRAW, DCX, DDS, DFONT, DJVU, DNG, DOT, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, EXR, FARBFELD, FAX, FF, FILE, FITS, FL32, FLV, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, GV, HALD, HDR, HEIC, HEIF, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, KERNEL, LABEL, M2V, M4V, MAC, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPEG, MPG, MRW, MSL, MSVG, MTV, MVG, NEF, NRW, NULL, ORA, ORF, OTB, OTF, PAL, PALM, PAM, PANGO, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PHM, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGB565, RGBA, RGBO, RGF, RLA, RLE, RMF, RSVG, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, SVG, SVGZ, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TM2, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMF, WMV, WMZ, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YAML, YCbCr, YCbCrA, YUV
diff --git a/REFLECTION-im6 b/REFLECTION-im6
index 5960878..ad9f800 100644
--- a/REFLECTION-im6
+++ b/REFLECTION-im6
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
+Extension [ <persistent> extension #97 imagick version 3.6.0RC1 ] {
- Dependencies {
Dependency [ gmagick (Conflicts) ]
@@ -326,8 +326,8 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
Constant [ public int COLOR_OPACITY ] { 18 }
Constant [ public int COLOR_ALPHA ] { 19 }
Constant [ public int COLOR_FUZZ ] { 20 }
- Constant [ public int IMAGICK_EXTNUM ] { 30501 }
- Constant [ public string IMAGICK_EXTVER ] { 3.5.1 }
+ Constant [ public int IMAGICK_EXTNUM ] { 30600 }
+ Constant [ public string IMAGICK_EXTVER ] { 3.6.0RC1 }
Constant [ public int QUANTUM_RANGE ] { 65535 }
Constant [ public int USE_ZEND_MM ] { 0 }
Constant [ public int COMPOSITE_DEFAULT ] { 40 }
@@ -1208,7 +1208,7 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
}
}
- Method [ <internal, deprecated:imagick> public method roundCornersImage ] {
+ Method [ <internal:imagick> public method roundCornersImage ] {
- Parameters [5] {
Parameter #0 [ <required> $x_rounding ]
@@ -1916,7 +1916,7 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
}
}
- Method [ <internal, deprecated:imagick> public method getImageSize ] {
+ Method [ <internal:imagick> public method getImageSize ] {
- Parameters [0] {
}
@@ -1976,14 +1976,14 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
}
}
- Method [ <internal, deprecated:imagick> public method setImageIndex ] {
+ Method [ <internal:imagick> public method setImageIndex ] {
- Parameters [1] {
Parameter #0 [ <required> $index ]
}
}
- Method [ <internal, deprecated:imagick> public method getImageIndex ] {
+ Method [ <internal:imagick> public method getImageIndex ] {
- Parameters [0] {
}
@@ -2307,7 +2307,7 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
}
}
- Method [ <internal, deprecated:imagick> public method setImageMatteColor ] {
+ Method [ <internal:imagick> public method setImageMatteColor ] {
- Parameters [1] {
Parameter #0 [ <required> $matte_color ]
@@ -2520,7 +2520,7 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
}
}
- Method [ <internal, deprecated:imagick> public method averageImages ] {
+ Method [ <internal:imagick> public method averageImages ] {
- Parameters [0] {
}
@@ -2694,7 +2694,7 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
}
}
- Method [ <internal, deprecated:imagick> public method flattenImages ] {
+ Method [ <internal:imagick> public method flattenImages ] {
- Parameters [0] {
}
@@ -3600,7 +3600,7 @@ Extension [ <persistent> extension #97 imagick version 3.5.1 ] {
}
}
- Method [ <internal:imagick> public method similarityimage ] {
+ Method [ <internal:imagick> public method similarityImage ] {
- Parameters [5] {
Parameter #0 [ <required> Imagick $image ]
diff --git a/REFLECTION-im7 b/REFLECTION-im7
index f8b0252..25fb376 100644
--- a/REFLECTION-im7
+++ b/REFLECTION-im7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
+Extension [ <persistent> extension #78 imagick version 3.6.0RC1 ] {
- Dependencies {
Dependency [ gmagick (Conflicts) ]
@@ -315,7 +315,7 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
Class [ <internal:imagick> <iterateable> class Imagick implements Iterator, Traversable, Countable ] {
- - Constants [603] {
+ - Constants [615] {
Constant [ public int COLOR_BLACK ] { 11 }
Constant [ public int COLOR_BLUE ] { 12 }
Constant [ public int COLOR_CYAN ] { 13 }
@@ -325,8 +325,8 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
Constant [ public int COLOR_MAGENTA ] { 17 }
Constant [ public int COLOR_ALPHA ] { 18 }
Constant [ public int COLOR_FUZZ ] { 19 }
- Constant [ public int IMAGICK_EXTNUM ] { 30501 }
- Constant [ public string IMAGICK_EXTVER ] { 3.5.1 }
+ Constant [ public int IMAGICK_EXTNUM ] { 30600 }
+ Constant [ public string IMAGICK_EXTVER ] { 3.6.0RC1 }
Constant [ public int QUANTUM_RANGE ] { 65535 }
Constant [ public int USE_ZEND_MM ] { 0 }
Constant [ public int COMPOSITE_DEFAULT ] { 54 }
@@ -815,9 +815,11 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
Constant [ public int ALPHACHANNEL_SET ] { 13 }
Constant [ public int ALPHACHANNEL_UNDEFINED ] { 0 }
Constant [ public int ALPHACHANNEL_DISCRETE ] { 6 }
+ Constant [ public int ALPHACHANNEL_COPY ] { 4 }
Constant [ public int ALPHACHANNEL_DEACTIVATE ] { 5 }
Constant [ public int ALPHACHANNEL_EXTRACT ] { 8 }
Constant [ public int ALPHACHANNEL_OFF ] { 9 }
+ Constant [ public int ALPHACHANNEL_OPAQUE ] { 11 }
Constant [ public int ALPHACHANNEL_SHAPE ] { 14 }
Constant [ public int ALPHACHANNEL_TRANSPARENT ] { 15 }
Constant [ public int ALPHACHANNEL_ASSOCIATE ] { 2 }
@@ -919,12 +921,22 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
Constant [ public int PIXELMASK_READ ] { 1 }
Constant [ public int PIXELMASK_WRITE ] { 2 }
Constant [ public int PIXELMASK_COMPOSITE ] { 4 }
+ Constant [ public int AUTO_THRESHOLD_KAPUR ] { 1 }
+ Constant [ public int AUTO_THRESHOLD_OTSU ] { 2 }
+ Constant [ public int AUTO_THRESHOLD_TRIANGLE ] { 3 }
+ Constant [ public int COMPLEX_OPERATOR_ADD ] { 1 }
+ Constant [ public int COMPLEX_OPERATOR_CONJUGATE ] { 2 }
+ Constant [ public int COMPLEX_OPERATOR_DIVIDE ] { 3 }
+ Constant [ public int COMPLEX_OPERATOR_MAGNITUDEPHASE ] { 4 }
+ Constant [ public int COMPLEX_OPERATOR_MULTIPLY ] { 5 }
+ Constant [ public int COMPLEX_OPERATOR_REALIMAGINARY ] { 6 }
+ Constant [ public int COMPLEX_OPERATOR_SUBTRACT ] { 7 }
}
- Static properties [0] {
}
- - Static methods [20] {
+ - Static methods [21] {
Method [ <internal:imagick> static public method queryFormats ] {
- Parameters [1] {
@@ -1059,12 +1071,19 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:imagick> static public method setSeed ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $seed ]
+ }
+ }
}
- Properties [0] {
}
- - Methods [327] {
+ - Methods [353] {
Method [ <internal:imagick> public method optimizeImageLayers ] {
- Parameters [0] {
@@ -1222,6 +1241,28 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method roundCornersImage ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $x_rounding ]
+ Parameter #1 [ <required> $y_rounding ]
+ Parameter #2 [ <optional> $stroke_width ]
+ Parameter #3 [ <optional> $displace ]
+ Parameter #4 [ <optional> $size_correction ]
+ }
+ }
+
+ Method [ <internal, deprecated:imagick> public method roundCorners ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <required> $x_rounding ]
+ Parameter #1 [ <required> $y_rounding ]
+ Parameter #2 [ <optional> $stroke_width ]
+ Parameter #3 [ <optional> $displace ]
+ Parameter #4 [ <optional> $size_correction ]
+ }
+ }
+
Method [ <internal:imagick> public method setIteratorIndex ] {
- Parameters [1] {
@@ -1869,6 +1910,12 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method getImageSize ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:imagick> public method getImageBlob ] {
- Parameters [0] {
@@ -1923,6 +1970,19 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method setImageIndex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $index ]
+ }
+ }
+
+ Method [ <internal:imagick> public method getImageIndex ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:imagick> public method commentImage ] {
- Parameters [1] {
@@ -2232,6 +2292,13 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method setImageMatteColor ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $matte_color ]
+ }
+ }
+
Method [ <internal:imagick> public method setImagePage ] {
- Parameters [4] {
@@ -2432,6 +2499,12 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method averageImages ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:imagick> public method borderImage ] {
- Parameters [3] {
@@ -2441,6 +2514,16 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method borderImageWithComposite ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $border_color ]
+ Parameter #1 [ <required> $width ]
+ Parameter #2 [ <required> $height ]
+ Parameter #3 [ <required> $composite ]
+ }
+ }
+
Method [ <internal:imagick> public method chopImage ] {
- Parameters [4] {
@@ -2589,6 +2672,12 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method flattenImages ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:imagick> public method flipImage ] {
- Parameters [0] {
@@ -2619,6 +2708,18 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
+ Method [ <internal:imagick> public method frameImageWithComposite ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $matte_color ]
+ Parameter #1 [ <required> $width ]
+ Parameter #2 [ <required> $height ]
+ Parameter #3 [ <required> $inner_bevel ]
+ Parameter #4 [ <required> $outer_bevel ]
+ Parameter #5 [ <required> $composite ]
+ }
+ }
+
Method [ <internal:imagick> public method fxImage ] {
- Parameters [2] {
@@ -3406,7 +3507,7 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
}
}
- Method [ <internal:imagick> public method similarityimage ] {
+ Method [ <internal:imagick> public method similarityImage ] {
- Parameters [5] {
Parameter #0 [ <required> Imagick $image ]
@@ -3509,6 +3610,141 @@ Extension [ <persistent> extension #78 imagick version 3.5.1 ] {
Parameter #1 [ <required> $pixelmask ]
}
}
+
+ Method [ <internal:imagick> public method cannyEdgeImage ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $radius ]
+ Parameter #1 [ <required> $sigma ]
+ Parameter #2 [ <required> $lower_percent ]
+ Parameter #3 [ <required> $upper_percent ]
+ }
+ }
+
+ Method [ <internal:imagick> public method waveletDenoiseImage ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $threshold ]
+ Parameter #1 [ <required> $softness ]
+ }
+ }
+
+ Method [ <internal:imagick> public method meanShiftImage ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $width ]
+ Parameter #1 [ <required> $height ]
+ Parameter #2 [ <required> $color_distance ]
+ }
+ }
+
+ Method [ <internal:imagick> public method kmeansImage ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $number_colors ]
+ Parameter #1 [ <required> $max_iterations ]
+ Parameter #2 [ <required> $tolerance ]
+ }
+ }
+
+ Method [ <internal:imagick> public method rangeThresholdImage ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $low_black ]
+ Parameter #1 [ <required> $low_white ]
+ Parameter #2 [ <required> $high_white ]
+ Parameter #3 [ <required> $high_black ]
+ }
+ }
+
+ Method [ <internal:imagick> public method autoThresholdImage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $auto_threshold_method ]
+ }
+ }
+
+ Method [ <internal:imagick> public method bilateralBlurImage ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $radius ]
+ Parameter #1 [ <required> $sigma ]
+ Parameter #2 [ <required> $intensity_sigma ]
+ Parameter #3 [ <required> $spatial_sigma ]
+ }
+ }
+
+ Method [ <internal:imagick> public method claheImage ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $width ]
+ Parameter #1 [ <required> $height ]
+ Parameter #2 [ <required> $number_bins ]
+ Parameter #3 [ <required> $clip_limit ]
+ }
+ }
+
+ Method [ <internal:imagick> public method channelFxImage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $expression ]
+ }
+ }
+
+ Method [ <internal:imagick> public method colorThresholdImage ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $start_color ]
+ Parameter #1 [ <required> $stop_color ]
+ }
+ }
+
+ Method [ <internal:imagick> public method complexImages ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $complex_operator ]
+ }
+ }
+
+ Method [ <internal:imagick> public method interpolativeResizeImage ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $columns ]
+ Parameter #1 [ <required> $rows ]
+ Parameter #2 [ <required> $interpolate ]
+ }
+ }
+
+ Method [ <internal:imagick> public method levelImageColors ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $black_color ]
+ Parameter #1 [ <required> $white_color ]
+ Parameter #2 [ <required> $invert ]
+ }
+ }
+
+ Method [ <internal:imagick> public method levelizeImage ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $black_point ]
+ Parameter #1 [ <required> $gamma ]
+ Parameter #2 [ <required> $white_point ]
+ }
+ }
+
+ Method [ <internal:imagick> public method orderedDitherImage ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $dither_format ]
+ }
+ }
+
+ Method [ <internal:imagick> public method whiteBalanceImage ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 0b1d523..f654e13 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -7,12 +7,14 @@
# Please, preserve the changelog entries
#
-%bcond_without im7
+%bcond_with im6
+%bcond_with im7
%bcond_without tests
# 2 builds needed to get the full set
-# --with im7 (default)
-# --without im7 (so with im6)
+# no options for F36+ and EL9+
+# --with im6
+# --with im7
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
@@ -34,8 +36,8 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.5.1
-#global upstream_prever RC1
+%global upstream_version 3.6.0
+%global upstream_prever RC1
%if %{with im7}
Summary: Extension to create and modify images using ImageMagick 7
@@ -49,14 +51,12 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP
URL: https://pecl.php.net/package/imagick
-Patch0: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/458.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -65,11 +65,10 @@ BuildRequires: pcre-devel
%if %{with im7}
BuildRequires: ImageMagick7-devel
%else
-# Ensure we use the more recent version from remi repo
-%if 0%{?fedora} >= 99 || 0%{?rhel} >= 99
-BuildRequires: ImageMagick-devel
-%else
+%if %{with im6}
BuildRequires: ImageMagick6-devel
+%else
+BuildRequires: ImageMagick-devel > 1:6
%endif
%endif
@@ -88,10 +87,11 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
Conflicts: %{?scl_prefix}php-pecl-gmagick
%if %{with im7}
-Conflicts: %{?scl_prefix}php-pecl-imagick-im6
+Conflicts: %{?scl_prefix}php-pecl-imagick-im6 <= %{version}-%{release}
+Conflicts: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
%else
-Conflicts: %{?scl_prefix}php-pecl-imagick-im7
-Obsoletes: %{?scl_prefix}php-pecl-imagick < %{version}-%{release}
+Conflicts: %{?scl_prefix}php-pecl-imagick-im7 <= %{version}-%{release}
+Obsoletes: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
%endif
Provides: %{?scl_prefix}php-pecl-imagick = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-imagick%{?_isa} = %{version}-%{release}
@@ -196,8 +196,6 @@ then : "Font files detected!"
fi
cd NTS
-%patch0 -p1 -b .pr458
-
: Fix permission for archive generated on Windows
find . -type f -exec chmod -x {} \;
@@ -365,6 +363,13 @@ cd ../ZTS
%changelog
+* Wed Nov 10 2021 Remi Collet <remi@remirepo.net> - 3.6.0~RC1-1
+- update to 3.6.0RC1
+- drop patch merged upstream
+
+* Fri Nov 5 2021 Remi Collet <remi@remirepo.net> - 3.5.1-4
+- EL-9 build
+
* Mon Sep 20 2021 Remi Collet <remi@remirepo.net> - 3.5.1-3
- fix #457 failed test with ImageMagick 6.9.12-23 and 7.1.0-8
using patch from https://github.com/Imagick/imagick/pull/458