summaryrefslogtreecommitdiffstats
path: root/php-pecl-imagick.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-imagick.spec')
-rw-r--r--php-pecl-imagick.spec39
1 files changed, 22 insertions, 17 deletions
diff --git a/php-pecl-imagick.spec b/php-pecl-imagick.spec
index 0b1d523..f654e13 100644
--- a/php-pecl-imagick.spec
+++ b/php-pecl-imagick.spec
@@ -7,12 +7,14 @@
# Please, preserve the changelog entries
#
-%bcond_without im7
+%bcond_with im6
+%bcond_with im7
%bcond_without tests
# 2 builds needed to get the full set
-# --with im7 (default)
-# --without im7 (so with im6)
+# no options for F36+ and EL9+
+# --with im6
+# --with im7
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
@@ -34,8 +36,8 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
-%global upstream_version 3.5.1
-#global upstream_prever RC1
+%global upstream_version 3.6.0
+%global upstream_prever RC1
%if %{with im7}
Summary: Extension to create and modify images using ImageMagick 7
@@ -49,14 +51,12 @@ Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 0.10.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
%endif
License: PHP
URL: https://pecl.php.net/package/imagick
-Patch0: https://patch-diff.githubusercontent.com/raw/Imagick/imagick/pull/458.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -65,11 +65,10 @@ BuildRequires: pcre-devel
%if %{with im7}
BuildRequires: ImageMagick7-devel
%else
-# Ensure we use the more recent version from remi repo
-%if 0%{?fedora} >= 99 || 0%{?rhel} >= 99
-BuildRequires: ImageMagick-devel
-%else
+%if %{with im6}
BuildRequires: ImageMagick6-devel
+%else
+BuildRequires: ImageMagick-devel > 1:6
%endif
%endif
@@ -88,10 +87,11 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{relea
Conflicts: %{?scl_prefix}php-pecl-gmagick
%if %{with im7}
-Conflicts: %{?scl_prefix}php-pecl-imagick-im6
+Conflicts: %{?scl_prefix}php-pecl-imagick-im6 <= %{version}-%{release}
+Conflicts: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
%else
-Conflicts: %{?scl_prefix}php-pecl-imagick-im7
-Obsoletes: %{?scl_prefix}php-pecl-imagick < %{version}-%{release}
+Conflicts: %{?scl_prefix}php-pecl-imagick-im7 <= %{version}-%{release}
+Obsoletes: %{?scl_prefix}php-pecl-imagick <= %{version}-%{release}
%endif
Provides: %{?scl_prefix}php-pecl-imagick = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-imagick%{?_isa} = %{version}-%{release}
@@ -196,8 +196,6 @@ then : "Font files detected!"
fi
cd NTS
-%patch0 -p1 -b .pr458
-
: Fix permission for archive generated on Windows
find . -type f -exec chmod -x {} \;
@@ -365,6 +363,13 @@ cd ../ZTS
%changelog
+* Wed Nov 10 2021 Remi Collet <remi@remirepo.net> - 3.6.0~RC1-1
+- update to 3.6.0RC1
+- drop patch merged upstream
+
+* Fri Nov 5 2021 Remi Collet <remi@remirepo.net> - 3.5.1-4
+- EL-9 build
+
* Mon Sep 20 2021 Remi Collet <remi@remirepo.net> - 3.5.1-3
- fix #457 failed test with ImageMagick 6.9.12-23 and 7.1.0-8
using patch from https://github.com/Imagick/imagick/pull/458