summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-31 17:13:42 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-31 17:13:42 +0100
commit411e7331fe704ba717a20ed8c5e874fc2941f866 (patch)
tree8d18c4e675edb17255e8c697caa7798c3b85413f
parent39e73c040f65cf180eb26c7bb2855de3e5620e6d (diff)
php-pecl-imagick: 3.4.0RC6
-rw-r--r--REFLECTION-PHP713
-rw-r--r--php-pecl-imagick-php7.spec10
2 files changed, 18 insertions, 5 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 53e7f1a..7f1ad1d 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 imagick version 3.4.0RC5 ] {
+Extension [ <persistent> extension #108 imagick version 3.4.0RC6 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -316,7 +316,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.0RC5 ] {
Constant [ integer COLOR_ALPHA ] { 19 }
Constant [ integer COLOR_FUZZ ] { 20 }
Constant [ integer IMAGICK_EXTNUM ] { 30400 }
- Constant [ string IMAGICK_EXTVER ] { 3.4.0RC5 }
+ Constant [ string IMAGICK_EXTVER ] { 3.4.0RC6 }
Constant [ integer QUANTUM_RANGE ] { 65535 }
Constant [ integer USE_ZEND_MM ] { 0 }
Constant [ integer COMPOSITE_DEFAULT ] { 40 }
@@ -1017,7 +1017,7 @@ Extension [ <persistent> extension #108 imagick version 3.4.0RC5 ] {
- Properties [0] {
}
- - Methods [346] {
+ - Methods [347] {
Method [ <internal:imagick> public method optimizeimagelayers ] {
- Parameters [0] {
@@ -2654,6 +2654,13 @@ Extension [ <persistent> extension #108 imagick version 3.4.0RC5 ] {
}
}
+ Method [ <internal:imagick> public method evaluateimages ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $EVALUATE ]
+ }
+ }
+
Method [ <internal:imagick> public method flattenimages ] {
- Parameters [0] {
diff --git a/php-pecl-imagick-php7.spec b/php-pecl-imagick-php7.spec
index 1ff2249..81843e0 100644
--- a/php-pecl-imagick-php7.spec
+++ b/php-pecl-imagick-php7.spec
@@ -25,7 +25,7 @@
%global gh_project imagick
#global gh_date 20151204
%global pecl_name imagick
-%global prever RC5
+%global prever RC6
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -43,7 +43,7 @@ Version: 3.4.0
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 0.5.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.6.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: PHP
@@ -74,6 +74,8 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}%{?prever}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}%{?prever}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}%{?prever}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}%{?prever}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
Conflicts: %{?scl_prefix}php-pecl-gmagick
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
@@ -138,6 +140,7 @@ mv %{pecl_name}-%{version}%{?prever} NTS
sed -e '/anonymous_pro_minus.ttf/d' \
-e '/015-imagickdrawsetresolution.phpt/d' \
-e '/OFL.txt/d' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
-i package.xml
if grep '\.ttf' package.xml
@@ -304,6 +307,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Jan 30 2016 Remi Collet <remi@fedoraproject.org> - 3.4.0-0.6.RC6
+- update to 3.4.0RC6
+
* Tue Jan 12 2016 Remi Collet <remi@fedoraproject.org> - 3.4.0-0.5.RC5
- update to 3.4.0RC5