summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-01-12 08:12:57 +0100
committerRemi Collet <fedora@famillecollet.com>2016-01-12 08:12:57 +0100
commit39e73c040f65cf180eb26c7bb2855de3e5620e6d (patch)
treeb3506442eb005021c1218e9307baa24569772dd7
parenta9acd7801bc73e7629d111d325cf98f8da7eaccb (diff)
php-pecl-imagick: 3.4.0RC5
-rw-r--r--REFLECTION-PHP712
-rw-r--r--php-pecl-imagick-php7.spec9
2 files changed, 14 insertions, 7 deletions
diff --git a/REFLECTION-PHP7 b/REFLECTION-PHP7
index 36be10c..53e7f1a 100644
--- a/REFLECTION-PHP7
+++ b/REFLECTION-PHP7
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #106 imagick version 3.4.0RC4 ] {
+Extension [ <persistent> extension #108 imagick version 3.4.0RC5 ] {
- Dependencies {
Dependency [ spl (Required) ]
@@ -316,7 +316,7 @@ Extension [ <persistent> extension #106 imagick version 3.4.0RC4 ] {
Constant [ integer COLOR_ALPHA ] { 19 }
Constant [ integer COLOR_FUZZ ] { 20 }
Constant [ integer IMAGICK_EXTNUM ] { 30400 }
- Constant [ string IMAGICK_EXTVER ] { 3.4.0RC4 }
+ Constant [ string IMAGICK_EXTVER ] { 3.4.0RC5 }
Constant [ integer QUANTUM_RANGE ] { 65535 }
Constant [ integer USE_ZEND_MM ] { 0 }
Constant [ integer COMPOSITE_DEFAULT ] { 40 }
@@ -3548,19 +3548,23 @@ Extension [ <persistent> extension #106 imagick version 3.4.0RC4 ] {
Method [ <internal:imagick> public method subimagematch ] {
- - Parameters [3] {
+ - Parameters [5] {
Parameter #0 [ <required> Imagick $Imagick ]
Parameter #1 [ <optional> &$offset ]
Parameter #2 [ <optional> &$similarity ]
+ Parameter #3 [ <optional> &$similarity_threshold ]
+ Parameter #4 [ <optional> &$metric ]
}
}
Method [ <internal:imagick> public method similarityimage ] {
- - Parameters [3] {
+ - Parameters [5] {
Parameter #0 [ <required> Imagick $Imagick ]
Parameter #1 [ <optional> &$offset ]
Parameter #2 [ <optional> &$similarity ]
+ Parameter #3 [ <optional> &$similarity_threshold ]
+ Parameter #4 [ <optional> &$metric ]
}
}
diff --git a/php-pecl-imagick-php7.spec b/php-pecl-imagick-php7.spec
index 61115be..1ff2249 100644
--- a/php-pecl-imagick-php7.spec
+++ b/php-pecl-imagick-php7.spec
@@ -25,7 +25,7 @@
%global gh_project imagick
#global gh_date 20151204
%global pecl_name imagick
-%global prever RC4
+%global prever RC5
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
@@ -43,7 +43,7 @@ Version: 3.4.0
Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
-Release: 0.4.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 0.5.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
License: PHP
@@ -59,7 +59,7 @@ BuildRequires: pcre-devel
BuildRequires: ImageMagick-devel >= 6.8.8
Requires: ImageMagick-libs%{?_isa} >= %{imbuildver}
%else
-BuildRequires: ImageMagick-last-devel >= 6.9.2
+BuildRequires: ImageMagick-last-devel >= 6.9.3
Requires: ImageMagick-last-libs%{?_isa} >= %{imbuildver}
%endif
%else
@@ -304,6 +304,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 12 2016 Remi Collet <remi@fedoraproject.org> - 3.4.0-0.5.RC5
+- update to 3.4.0RC5
+
* Sat Dec 26 2015 Remi Collet <remi@fedoraproject.org> - 3.4.0-0.4.RC4
- update to 3.4.0RC4