summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec4
1 files changed, 3 insertions, 1 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 634caa7..0d60423 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -143,7 +143,7 @@ install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/z-%{pecl_name}.ini
%check
-# Minimal load test for NTS extension
+# Install needed extensions
modules=""
for mod in json hash iconv; do
if [ -f %{php_extdir}/${mod}.so ]; then
@@ -152,6 +152,8 @@ for mod in json hash iconv; do
modules="$modules --define extension=${mod}.so"
fi
done
+
+# Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension_dir=%{proj_name}-%{version}%{?prever}/modules \
$modules \