summaryrefslogtreecommitdiffstats
path: root/php-pecl-http.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-14 16:06:44 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-14 16:06:44 +0100
commit5a7cc06adf88d2caafe1a16a685e2ed8eb30d9a4 (patch)
treefad94d47a184661b686a0e70c7133e6710ab06f3 /php-pecl-http.spec
parent43904cb3031ba46c8e7847e53e4efd321d3bf10f (diff)
php-pecl-http: add patch + cleanups
Diffstat (limited to 'php-pecl-http.spec')
-rw-r--r--php-pecl-http.spec4
1 files changed, 3 insertions, 1 deletions
diff --git a/php-pecl-http.spec b/php-pecl-http.spec
index 634caa7..0d60423 100644
--- a/php-pecl-http.spec
+++ b/php-pecl-http.spec
@@ -143,7 +143,7 @@ install -Dpm644 %{pecl_name}.ini %{buildroot}%{php_ztsinidir}/z-%{pecl_name}.ini
%check
-# Minimal load test for NTS extension
+# Install needed extensions
modules=""
for mod in json hash iconv; do
if [ -f %{php_extdir}/${mod}.so ]; then
@@ -152,6 +152,8 @@ for mod in json hash iconv; do
modules="$modules --define extension=${mod}.so"
fi
done
+
+# Minimal load test for NTS extension
%{__php} --no-php-ini \
--define extension_dir=%{proj_name}-%{version}%{?prever}/modules \
$modules \