summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-26 13:53:59 +0100
committerRemi Collet <remi@php.net>2021-11-26 13:53:59 +0100
commitc6f5881d8b1b4b8572268c8c8806e66650410057 (patch)
tree3e8226c7fa0acded6ad7827fbf90e9dfc0222c34
parentbdeede603c8cc5b0c08842526eea11326c5d121f (diff)
cleanup
-rw-r--r--REFLECTION400
-rw-r--r--php-pecl-handlebars.spec16
2 files changed, 278 insertions, 138 deletions
diff --git a/REFLECTION b/REFLECTION
index 34e0890..6237c3e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
+Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
- Dependencies {
Dependency [ psr (Optional) ]
@@ -68,29 +68,29 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
}
}
@@ -116,45 +116,45 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
Method [ <internal:SPL, inherits ArrayObject, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $input ]
- Parameter #1 [ <optional> $flags ]
- Parameter #2 [ <optional> $iterator_class ]
+ Parameter #0 [ <optional> object|array $array = [] ]
+ Parameter #1 [ <optional> int $flags = 0 ]
+ Parameter #2 [ <optional> string $iteratorClass = ArrayIterator::class ]
}
}
Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $index ]
+ Parameter #0 [ <required> mixed $key ]
}
}
Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $index ]
+ Parameter #0 [ <required> mixed $key ]
}
}
Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $index ]
- Parameter #1 [ <required> $newval ]
+ Parameter #0 [ <required> mixed $key ]
+ Parameter #1 [ <required> mixed $value ]
}
}
Method [ <internal:SPL, inherits ArrayObject, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $index ]
+ Parameter #0 [ <required> mixed $key ]
}
}
Method [ <internal:SPL, inherits ArrayObject> public method append ] {
- Parameters [1] {
- Parameter #0 [ <required> $value ]
+ Parameter #0 [ <required> mixed $value ]
}
}
@@ -179,33 +179,35 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
Method [ <internal:SPL, inherits ArrayObject> public method setFlags ] {
- Parameters [1] {
- Parameter #0 [ <required> $flags ]
+ Parameter #0 [ <required> int $flags ]
}
}
Method [ <internal:SPL, inherits ArrayObject> public method asort ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
}
Method [ <internal:SPL, inherits ArrayObject> public method ksort ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <optional> int $flags = SORT_REGULAR ]
}
}
Method [ <internal:SPL, inherits ArrayObject> public method uasort ] {
- Parameters [1] {
- Parameter #0 [ <required> $cmp_function ]
+ Parameter #0 [ <required> callable $callback ]
}
}
Method [ <internal:SPL, inherits ArrayObject> public method uksort ] {
- Parameters [1] {
- Parameter #0 [ <required> $cmp_function ]
+ Parameter #0 [ <required> callable $callback ]
}
}
@@ -224,7 +226,7 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
Method [ <internal:SPL, inherits ArrayObject, prototype Serializable> public method unserialize ] {
- Parameters [1] {
- Parameter #0 [ <required> $serialized ]
+ Parameter #0 [ <required> string $data ]
}
}
@@ -234,22 +236,16 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
}
- Method [ <internal:SPL, inherits ArrayObject> public method __unserialize ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $serialized ]
- }
- }
-
Method [ <internal:SPL, inherits ArrayObject> public method __serialize ] {
- Parameters [0] {
}
}
- Method [ <internal:SPL, inherits ArrayObject> public method __debugInfo ] {
+ Method [ <internal:SPL, inherits ArrayObject> public method __unserialize ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> array $data ]
}
}
@@ -262,14 +258,14 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
Method [ <internal:SPL, inherits ArrayObject> public method exchangeArray ] {
- Parameters [1] {
- Parameter #0 [ <required> $input ]
+ Parameter #0 [ <required> object|array $array ]
}
}
Method [ <internal:SPL, inherits ArrayObject> public method setIteratorClass ] {
- Parameters [1] {
- Parameter #0 [ <required> $iteratorClass ]
+ Parameter #0 [ <required> string $iteratorClass ]
}
}
@@ -278,6 +274,12 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:SPL, inherits ArrayObject> public method __debugInfo ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
@@ -300,28 +302,28 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars> abstract public method getPartials ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars> abstract public method getDecorators ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars> abstract public method getLogger ] {
- Parameters [0] {
}
- - Return [ Psr\Logger\LoggerInterface or NULL ]
+ - Return [ ?Psr\Logger\LoggerInterface ]
}
Method [ <internal:handlebars> abstract public method setHelpers ] {
@@ -360,8 +362,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> $context ]
- Parameter #2 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> $context = <default> ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -370,8 +372,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> string $filename ]
- Parameter #1 [ <optional> $context ]
- Parameter #2 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> $context = <default> ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -390,10 +392,10 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $logger ]
- Property [ <default> protected $decorators ]
- Property [ <default> protected $helpers ]
- Property [ <default> protected $partials ]
+ Property [ protected ?Psr\Log\LoggerInterface $logger ]
+ Property [ protected ?Handlebars\Registry $decorators ]
+ Property [ protected ?Handlebars\Registry $helpers ]
+ Property [ protected ?Handlebars\Registry $partials ]
}
- Methods [10] {
@@ -401,28 +403,28 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars, prototype Handlebars\Impl> public method getPartials ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars, prototype Handlebars\Impl> public method getDecorators ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars, prototype Handlebars\Impl> public method getLogger ] {
- Parameters [0] {
}
- - Return [ Psr\Logger\LoggerInterface or NULL ]
+ - Return [ ?Psr\Logger\LoggerInterface ]
}
Method [ <internal:handlebars, prototype Handlebars\Impl> public method setHelpers ] {
@@ -461,8 +463,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> $context ]
- Parameter #2 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> $context = <default> ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -471,8 +473,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> string $filename ]
- Parameter #1 [ <optional> $context ]
- Parameter #2 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> $context = <default> ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -511,7 +513,7 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [2] {
Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
}
- Return [ array ]
}
@@ -520,7 +522,7 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [2] {
Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -551,7 +553,7 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\CompileException extends Exception implements Throwable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\CompileException extends Exception implements Stringable, Throwable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -563,52 +565,86 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:handlebars> class Handlebars\InvalidArgumentException extends RuntimeException implements Throwable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\InvalidArgumentException extends RuntimeException implements Throwable, Stringable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -620,52 +656,86 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:handlebars> class Handlebars\RuntimeException extends RuntimeException implements Throwable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\RuntimeException extends RuntimeException implements Throwable, Stringable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -677,52 +747,86 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
- Class [ <internal:handlebars> class Handlebars\InvalidBinaryStringException extends Exception implements Throwable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\InvalidBinaryStringException extends Exception implements Stringable, Throwable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -734,47 +838,81 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $message ]
- Property [ <default> protected $code ]
- Property [ <default> protected $file ]
- Property [ <default> protected $line ]
+ Property [ protected $message = '' ]
+ Property [ protected $code = 0 ]
+ Property [ protected $file = NULL ]
+ Property [ protected $line = NULL ]
}
- Methods [10] {
Method [ <internal:Core, inherits Exception, ctor> public method __construct ] {
- Parameters [3] {
- Parameter #0 [ <optional> $message ]
- Parameter #1 [ <optional> $code ]
- Parameter #2 [ <optional> $previous ]
+ Parameter #0 [ <optional> string $message = "" ]
+ Parameter #1 [ <optional> int $code = 0 ]
+ Parameter #2 [ <optional> ?Throwable $previous = null ]
}
}
Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+
+ - Parameters [0] {
+ }
+ - Return [ int ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?Throwable ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
- Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ Method [ <internal:Core, inherits Exception, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
}
}
}
@@ -791,8 +929,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [2] {
- Property [ <default> public $opcode ]
- Property [ <default> public $args ]
+ Property [ public string $opcode ]
+ Property [ public array $args ]
}
- Methods [1] {
@@ -818,21 +956,21 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [8] {
- Property [ <default> public $ids ]
- Property [ <default> public $hashIds ]
- Property [ <default> public $hashTypes ]
- Property [ <default> public $hashContexts ]
- Property [ <default> public $types ]
- Property [ <default> public $contexts ]
- Property [ <default> public $args ]
- Property [ <default> public $partial ]
+ Property [ public $ids = NULL ]
+ Property [ public $hashIds = NULL ]
+ Property [ public $hashTypes = NULL ]
+ Property [ public $hashContexts = NULL ]
+ Property [ public $types = NULL ]
+ Property [ public $contexts = NULL ]
+ Property [ public $args = NULL ]
+ Property [ public $partial = NULL ]
}
- Methods [7] {
Method [ <internal:handlebars, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <required> array or NULL $props ]
+ Parameter #0 [ <required> ?array $props ]
}
}
@@ -924,16 +1062,16 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [10] {
- Property [ <default> public $opcodes ]
- Property [ <default> public $children ]
- Property [ <default> public $decorators ]
- Property [ <default> public $isSimple ]
- Property [ <default> public $useDepths ]
- Property [ <default> public $usePartial ]
- Property [ <default> public $useDecorators ]
- Property [ <default> public $blockParams ]
- Property [ <default> public $stringParams ]
- Property [ <default> public $trackIds ]
+ Property [ public $opcodes = NULL ]
+ Property [ public $children = NULL ]
+ Property [ public $decorators = NULL ]
+ Property [ public $isSimple = false ]
+ Property [ public $useDepths = false ]
+ Property [ public $usePartial = false ]
+ Property [ public $useDecorators = false ]
+ Property [ public $blockParams = 0 ]
+ Property [ public $stringParams = false ]
+ Property [ public $trackIds = false ]
}
- Methods [1] {
@@ -942,7 +1080,7 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> array $opcodes ]
Parameter #1 [ <required> array $children ]
- Parameter #2 [ <optional> int $blockParams ]
+ Parameter #2 [ <optional> int $blockParams = <default> ]
}
}
}
@@ -960,7 +1098,7 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [1] {
- Property [ <default> protected $value ]
+ Property [ protected string $value ]
}
- Methods [2] {
@@ -992,8 +1130,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [2] {
- Property [ <default> public $name ]
- Property [ <default> public $text ]
+ Property [ public string $name ]
+ Property [ public string $text ]
}
- Methods [1] {
@@ -1142,17 +1280,17 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ <default> protected $logger ]
- Property [ <default> protected $decorators ]
- Property [ <default> protected $helpers ]
- Property [ <default> protected $partials ]
+ Property [ protected ?Psr\Log\LoggerInterface $logger ]
+ Property [ protected ?Handlebars\Registry $decorators ]
+ Property [ protected ?Handlebars\Registry $helpers ]
+ Property [ protected ?Handlebars\Registry $partials ]
}
- Methods [13] {
Method [ <internal:handlebars, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <required> array or NULL $options ]
+ Parameter #0 [ <required> ?array $options ]
}
}
@@ -1176,7 +1314,7 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [2] {
Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -1185,8 +1323,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> $context ]
- Parameter #2 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> $context = <default> ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -1195,8 +1333,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> string $filename ]
- Parameter #1 [ <optional> $context ]
- Parameter #2 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> $context = <default> ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -1205,8 +1343,8 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [3] {
Parameter #0 [ <required> string $binaryString ]
- Parameter #1 [ <optional> $context ]
- Parameter #2 [ <optional> array or NULL $options ]
+ Parameter #1 [ <optional> $context = <default> ]
+ Parameter #2 [ <optional> ?array $options = <default> ]
}
- Return [ string ]
}
@@ -1215,28 +1353,28 @@ Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method getPartials ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method getDecorators ] {
- Parameters [0] {
}
- - Return [ Handlebars\Registry or NULL ]
+ - Return [ ?Handlebars\Registry ]
}
Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method getLogger ] {
- Parameters [0] {
}
- - Return [ Psr\Logger\LoggerInterface or NULL ]
+ - Return [ ?Psr\Logger\LoggerInterface ]
}
Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method setDecorators ] {
diff --git a/php-pecl-handlebars.spec b/php-pecl-handlebars.spec
index 67a50a8..175b621 100644
--- a/php-pecl-handlebars.spec
+++ b/php-pecl-handlebars.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-pecl-handlebars
#
-# Copyright (c) 2017-2020 Remi Collet
+# Copyright (c) 2017-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -29,6 +29,7 @@ License: BSD
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
@@ -206,12 +207,15 @@ cd NTS
--modules | grep '^%{pecl_name}$'
%if %{with tests}
+OPT="-q -P --show-diff"
+%if "%{php_version}" > "7.4"
+OPT="$OPT %{?_smp_mflags}"
+%endif
+
# Upstream test suite
-TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php --show-diff
+%{__php} -n run-tests.php $OPT
%endif
%if %{with_zts}
@@ -223,11 +227,9 @@ cd ../ZTS
%if %{with tests}
# Upstream test suite
-TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
-NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php --show-diff
+%{__ztsphp} -n run-tests.php $OPY
%endif
%endif