summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-07 10:56:15 +0100
committerRemi Collet <remi@remirepo.net>2020-12-07 10:56:15 +0100
commitbdeede603c8cc5b0c08842526eea11326c5d121f (patch)
tree546a73ab348e9d053392106c8def6c963bfb659f
parent6b2b102954dffa103093ea525ca8206761c93d4a (diff)
update to 0.9.2
-rw-r--r--.gitignore2
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION33
-rw-r--r--php-pecl-handlebars.spec32
4 files changed, 44 insertions, 29 deletions
diff --git a/.gitignore b/.gitignore
index 1ab5c4f..01f0400 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,7 @@
+clog
package-*.xml
*.tgz
+*.tar.bz2
*.tar.gz
*.tar.xz
*.tar.xz.asc
diff --git a/PHPINFO b/PHPINFO
index 5407502..ba6242c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,12 +1,12 @@
handlebars
-Version => 0.9.1
-Released => 2020-04-18
+Version => 0.9.2
+Released => 2020-12-06
Authors => John Boehr <jbboehr@gmail.com> (lead)
Spec Version => 4.0.5
PSR support => active
-libhandlebars Version => 0.7.1
+libhandlebars Version => 0.7.3
libhandlebars Handlebars Spec Version => 4.0.5
libhandlebars Mustache Spec Version => 1.1.3
xxhash version => 0.7.3
diff --git a/REFLECTION b/REFLECTION
index 19803d5..34e0890 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #113 handlebars version 0.9.1 ] {
+Extension [ <persistent> extension #117 handlebars version 0.9.2 ] {
- Dependencies {
Dependency [ psr (Optional) ]
@@ -36,8 +36,8 @@ Extension [ <persistent> extension #113 handlebars version 0.9.1 ] {
- Constants [4] {
Constant [ int Handlebars\PSR ] { 1 }
- Constant [ string Handlebars\VERSION ] { 0.9.1 }
- Constant [ string Handlebars\LIBVERSION ] { 0.7.1 }
+ Constant [ string Handlebars\VERSION ] { 0.9.2 }
+ Constant [ string Handlebars\LIBVERSION ] { 0.7.3 }
Constant [ null Handlebars\CACHE_BACKEND ] { }
}
@@ -112,7 +112,7 @@ Extension [ <persistent> extension #113 handlebars version 0.9.1 ] {
- Properties [0] {
}
- - Methods [22] {
+ - Methods [25] {
Method [ <internal:SPL, inherits ArrayObject, ctor> public method __construct ] {
- Parameters [3] {
@@ -234,6 +234,25 @@ Extension [ <persistent> extension #113 handlebars version 0.9.1 ] {
}
}
+ Method [ <internal:SPL, inherits ArrayObject> public method __unserialize ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $serialized ]
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method __serialize ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:SPL, inherits ArrayObject> public method __debugInfo ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:SPL, inherits ArrayObject, prototype IteratorAggregate> public method getIterator ] {
- Parameters [0] {
@@ -243,7 +262,7 @@ Extension [ <persistent> extension #113 handlebars version 0.9.1 ] {
Method [ <internal:SPL, inherits ArrayObject> public method exchangeArray ] {
- Parameters [1] {
- Parameter #0 [ <required> $array ]
+ Parameter #0 [ <required> $input ]
}
}
@@ -430,7 +449,7 @@ Extension [ <persistent> extension #113 handlebars version 0.9.1 ] {
- Return [ Handlebars\Impl ]
}
- Method [ <internal:handlebars, prototype Handlebars\Impl> public method setLogger ] {
+ Method [ <internal:handlebars, prototype Psr\Log\LoggerAwareInterface> public method setLogger ] {
- Parameters [1] {
Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
@@ -1228,7 +1247,7 @@ Extension [ <persistent> extension #113 handlebars version 0.9.1 ] {
- Return [ Handlebars\Impl ]
}
- Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method setLogger ] {
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Psr\Log\LoggerAwareInterface> public method setLogger ] {
- Parameters [1] {
Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
diff --git a/php-pecl-handlebars.spec b/php-pecl-handlebars.spec
index 6089f8a..67a50a8 100644
--- a/php-pecl-handlebars.spec
+++ b/php-pecl-handlebars.spec
@@ -11,13 +11,14 @@
%scl_package php-pecl-handlebars
%endif
+%bcond_without tests
+
%global pecl_name handlebars
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
# After 40-psr.ini
%global ini_name 50-%{pecl_name}.ini
-%global with_tests 0%{!?_without_tests:1}
-%global upstream_version 0.9.1
+%global upstream_version 0.9.2
#global upstream_prever RC2
Summary: Handlebars templating language
@@ -50,24 +51,17 @@ Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{rele
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
%endif
-%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php72w-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-Obsoletes: php73w-pecl-%{pecl_name} <= %{version}
%endif
%if "%{php_version}" > "7.4"
Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-Obsoletes: php74w-pecl-%{pecl_name} <= %{version}
%endif
+%if "%{php_version}" > "8.0"
+Obsoletes: php80-pecl-%{pecl_name} <= %{version}
%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
%endif
@@ -205,16 +199,13 @@ fi
%check
-# see https://github.com/jbboehr/php-handlebars/issues/70
-rm ?TS/tests/vm/renderFromBinaryString.phpt
-
: Minimal load test for NTS extension
cd NTS
%{__php} --no-php-ini \
--define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
-%if %{with_tests}
+%if %{with tests}
# Upstream test suite
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
@@ -228,9 +219,9 @@ REPORT_EXIT_STATUS=1 \
cd ../ZTS
%{__ztsphp} --no-php-ini \
--define extension=modules/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
-%if %{with_tests}
+%if %{with tests}
# Upstream test suite
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
@@ -266,6 +257,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 0.9.2-1
+- update to 0.9.2
+
* Sun Apr 19 2020 Remi Collet <remi@remirepo.net> - 0.9.1-1
- update to 0.9.1
- drop patch merged upstream