summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-11-28 11:12:06 +0100
committerRemi Collet <remi@php.net>2022-11-28 11:12:06 +0100
commit687b033847a5d483dfb56a2fc423c2a362ddab19 (patch)
tree6d6a103a68767c0eb3fea757795590dae891243c
parentc6f5881d8b1b4b8572268c8c8806e66650410057 (diff)
update to 1.0.0
raise dependency on libhandlebars 1.0.0
-rw-r--r--PHPINFO15
-rw-r--r--REFLECTION483
-rw-r--r--php-pecl-handlebars.spec85
3 files changed, 313 insertions, 270 deletions
diff --git a/PHPINFO b/PHPINFO
index ba6242c..7b51f6a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -1,19 +1,20 @@
handlebars
-Version => 0.9.2
-Released => 2020-12-06
+Version => 1.0.0
+Released => 2022-11-27
Authors => John Boehr <jbboehr@gmail.com> (lead)
-Spec Version => 4.0.5
-PSR support => active
-libhandlebars Version => 0.7.3
-libhandlebars Handlebars Spec Version => 4.0.5
+Spec Version => 4.7.7
+PSR support => inactive
+libhandlebars Version => 1.0.0
+libhandlebars Version (compile-time) => 1.0.0
+libhandlebars Handlebars Spec Version => 4.7.7
libhandlebars Mustache Spec Version => 1.1.3
xxhash version => 0.7.3
Local memory usage => 48
Directive => Local Value => Master Value
-handlebars.pool_size => 128k => 128k
+handlebars.pool_size => 0 => 0
handlebars.cache.enable => On => On
handlebars.cache.enable_cli => Off => Off
handlebars.cache.backend => mmap => mmap
diff --git a/REFLECTION b/REFLECTION
index 6237c3e..fe6ff29 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
+Extension [ <persistent> extension #110 handlebars version 1.0.0 ] {
- Dependencies {
Dependency [ psr (Optional) ]
@@ -6,7 +6,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
- INI {
Entry [ handlebars.pool_size <ALL> ]
- Current = '128k'
+ Current = '0'
}
Entry [ handlebars.cache.enable <SYSTEM> ]
Current = '1'
@@ -34,10 +34,11 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- - Constants [4] {
- Constant [ int Handlebars\PSR ] { 1 }
- Constant [ string Handlebars\VERSION ] { 0.9.2 }
- Constant [ string Handlebars\LIBVERSION ] { 0.7.3 }
+ - Constants [5] {
+ Constant [ int Handlebars\PSR ] { 0 }
+ Constant [ string Handlebars\VERSION ] { 1.0.0 }
+ Constant [ string Handlebars\LIBVERSION ] { 1.0.0 }
+ Constant [ string Handlebars\LIBVERSION2 ] { 1.0.0 }
Constant [ null Handlebars\CACHE_BACKEND ] { }
}
@@ -283,7 +284,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Interface [ <internal:handlebars> interface Handlebars\Impl extends Psr\Log\LoggerAwareInterface ] {
+ Interface [ <internal:handlebars> interface Handlebars\Impl ] {
- Constants [0] {
}
@@ -350,7 +351,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
- Return [ Handlebars\Impl ]
}
- Method [ <internal:handlebars, prototype Psr\Log\LoggerAwareInterface> abstract public method setLogger ] {
+ Method [ <internal:handlebars> abstract public method setLogger ] {
- Parameters [1] {
Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
@@ -380,7 +381,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> abstract class Handlebars\BaseImpl implements Handlebars\Impl, Psr\Log\LoggerAwareInterface ] {
+ Class [ <internal:handlebars> abstract class Handlebars\BaseImpl implements Handlebars\Impl ] {
- Constants [0] {
}
@@ -392,10 +393,10 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ protected ?Psr\Log\LoggerInterface $logger ]
- Property [ protected ?Handlebars\Registry $decorators ]
- Property [ protected ?Handlebars\Registry $helpers ]
- Property [ protected ?Handlebars\Registry $partials ]
+ Property [ protected $logger = NULL ]
+ Property [ protected $decorators = NULL ]
+ Property [ protected $helpers = NULL ]
+ Property [ protected $partials = NULL ]
}
- Methods [10] {
@@ -451,7 +452,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
- Return [ Handlebars\Impl ]
}
- Method [ <internal:handlebars, prototype Psr\Log\LoggerAwareInterface> public method setLogger ] {
+ Method [ <internal:handlebars, prototype Handlebars\Impl> public method setLogger ] {
- Parameters [1] {
Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
@@ -481,60 +482,6 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\Compiler ] {
-
- - Constants [19] {
- Constant [ public int NONE ] { 0 }
- Constant [ public int USE_DEPTHS ] { 1 }
- Constant [ public int STRING_PARAMS ] { 2 }
- Constant [ public int TRACK_IDS ] { 4 }
- Constant [ public int NO_ESCAPE ] { 8 }
- Constant [ public int KNOWN_HELPERS_ONLY ] { 16 }
- Constant [ public int PREVENT_INDENT ] { 32 }
- Constant [ public int EXPLICIT_PARTIAL_CONTEXT ] { 128 }
- Constant [ public int IGNORE_STANDALONE ] { 256 }
- Constant [ public int ALTERNATE_DECORATORS ] { 512 }
- Constant [ public int STRICT ] { 1024 }
- Constant [ public int ASSUME_OBJECTS ] { 2048 }
- Constant [ public int MUSTACHE_STYLE_LAMBDAS ] { 4096 }
- Constant [ public int COMPAT ] { 1 }
- Constant [ public int ALL ] { 8191 }
- Constant [ public int USE_PARTIAL ] { 2 }
- Constant [ public int IS_SIMPLE ] { 4 }
- Constant [ public int USE_DECORATORS ] { 8 }
- Constant [ public int RESULT_ALL ] { 15 }
- }
-
- - Static properties [0] {
- }
-
- - Static methods [2] {
- Method [ <internal:handlebars> static public method compile ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> ?array $options = <default> ]
- }
- - Return [ array ]
- }
-
- Method [ <internal:handlebars> static public method compilePrint ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $tmpl ]
- Parameter #1 [ <optional> ?array $options = <default> ]
- }
- - Return [ string ]
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
Interface [ <internal:handlebars> interface Handlebars\Exception ] {
- Constants [0] {
@@ -553,7 +500,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\CompileException extends Exception implements Stringable, Throwable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\CompileException extends Exception implements Throwable, Stringable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -644,7 +591,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\InvalidArgumentException extends RuntimeException implements Throwable, Stringable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\InvalidArgumentException extends RuntimeException implements Stringable, Throwable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -735,7 +682,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\RuntimeException extends RuntimeException implements Throwable, Stringable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\RuntimeException extends RuntimeException implements Stringable, Throwable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -826,7 +773,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\InvalidBinaryStringException extends Exception implements Stringable, Throwable, Handlebars\Exception ] {
+ Class [ <internal:handlebars> class Handlebars\InvalidBinaryStringException extends Exception implements Throwable, Stringable, Handlebars\Exception ] {
- Constants [0] {
}
@@ -917,33 +864,6 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\Opcode ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [2] {
- Property [ public string $opcode ]
- Property [ public array $args ]
- }
-
- - Methods [1] {
- Method [ <internal:handlebars, ctor> public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $opcode ]
- Parameter #1 [ <required> array $args ]
- }
- }
- }
- }
-
Class [ <internal:handlebars> class Handlebars\Options implements ArrayAccess ] {
- Constants [0] {
@@ -955,7 +875,13 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
- Static methods [0] {
}
- - Properties [8] {
+ - Properties [14] {
+ Property [ public $name = NULL ]
+ Property [ public $hash = NULL ]
+ Property [ public $fn = NULL ]
+ Property [ public $inverse = NULL ]
+ Property [ public $scope = NULL ]
+ Property [ public $data = NULL ]
Property [ public $ids = NULL ]
Property [ public $hashIds = NULL ]
Property [ public $hashTypes = NULL ]
@@ -966,7 +892,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
Property [ public $partial = NULL ]
}
- - Methods [7] {
+ - Methods [8] {
Method [ <internal:handlebars, ctor> public method __construct ] {
- Parameters [1] {
@@ -1014,79 +940,18 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
Parameter #0 [ <required> $prop ]
}
}
- }
- }
-
- Class [ <internal:handlebars> class Handlebars\Parser ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [2] {
- Method [ <internal:handlebars> static public method parse ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $tmpl ]
- }
- - Return [ array ]
- }
-
- Method [ <internal:handlebars> static public method parsePrint ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $tmpl ]
- }
- - Return [ string ]
- }
- }
-
- - Properties [0] {
- }
- - Methods [0] {
- }
- }
+ Method [ <internal:handlebars> public method lookupProperty ] {
- Class [ <internal:handlebars> class Handlebars\Program ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [10] {
- Property [ public $opcodes = NULL ]
- Property [ public $children = NULL ]
- Property [ public $decorators = NULL ]
- Property [ public $isSimple = false ]
- Property [ public $useDepths = false ]
- Property [ public $usePartial = false ]
- Property [ public $useDecorators = false ]
- Property [ public $blockParams = 0 ]
- Property [ public $stringParams = false ]
- Property [ public $trackIds = false ]
- }
-
- - Methods [1] {
- Method [ <internal:handlebars, ctor> public method __construct ] {
-
- - Parameters [3] {
- Parameter #0 [ <required> array $opcodes ]
- Parameter #1 [ <required> array $children ]
- Parameter #2 [ <optional> int $blockParams = <default> ]
+ - Parameters [2] {
+ Parameter #0 [ <required> $objOrArray ]
+ Parameter #1 [ <required> string $field ]
}
}
}
}
- Class [ <internal:handlebars> class Handlebars\SafeString ] {
+ Class [ <internal:handlebars> class Handlebars\SafeString implements Stringable ] {
- Constants [0] {
}
@@ -1109,7 +974,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Method [ <internal:handlebars> public method __toString ] {
+ Method [ <internal:handlebars, prototype Stringable> public method __toString ] {
- Parameters [0] {
}
@@ -1118,66 +983,6 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\Token ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [2] {
- Property [ public string $name ]
- Property [ public string $text ]
- }
-
- - Methods [1] {
- Method [ <internal:handlebars, ctor> public method __construct ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $name ]
- Parameter #1 [ <required> string $text ]
- }
- }
- }
- }
-
- Class [ <internal:handlebars> class Handlebars\Tokenizer ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [2] {
- Method [ <internal:handlebars> static public method lex ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $tmpl ]
- }
- - Return [ array ]
- }
-
- Method [ <internal:handlebars> static public method lexPrint ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> string $tmpl ]
- }
- - Return [ string ]
- }
- }
-
- - Properties [0] {
- }
-
- - Methods [0] {
- }
- }
-
Class [ <internal:handlebars> class Handlebars\Utils ] {
- Constants [0] {
@@ -1268,7 +1073,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
- Class [ <internal:handlebars> class Handlebars\VM extends Handlebars\BaseImpl implements Psr\Log\LoggerAwareInterface, Handlebars\Impl ] {
+ Class [ <internal:handlebars> class Handlebars\VM extends Handlebars\BaseImpl implements Handlebars\Impl ] {
- Constants [0] {
}
@@ -1280,10 +1085,10 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
- Properties [4] {
- Property [ protected ?Psr\Log\LoggerInterface $logger ]
- Property [ protected ?Handlebars\Registry $decorators ]
- Property [ protected ?Handlebars\Registry $helpers ]
- Property [ protected ?Handlebars\Registry $partials ]
+ Property [ protected $logger = NULL ]
+ Property [ protected $decorators = NULL ]
+ Property [ protected $helpers = NULL ]
+ Property [ protected $partials = NULL ]
}
- Methods [13] {
@@ -1385,7 +1190,7 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
- Return [ Handlebars\Impl ]
}
- Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Psr\Log\LoggerAwareInterface> public method setLogger ] {
+ Method [ <internal:handlebars, inherits Handlebars\BaseImpl, prototype Handlebars\Impl> public method setLogger ] {
- Parameters [1] {
Parameter #0 [ <required> Psr\Log\LoggerInterface $logger ]
@@ -1394,6 +1199,216 @@ Extension [ <persistent> extension #108 handlebars version 0.9.2 ] {
}
}
}
+
+ Class [ <internal:handlebars> class Handlebars\Compiler ] {
+
+ - Constants [19] {
+ Constant [ public int NONE ] { 0 }
+ Constant [ public int USE_DEPTHS ] { 1 }
+ Constant [ public int STRING_PARAMS ] { 2 }
+ Constant [ public int TRACK_IDS ] { 4 }
+ Constant [ public int NO_ESCAPE ] { 8 }
+ Constant [ public int KNOWN_HELPERS_ONLY ] { 16 }
+ Constant [ public int PREVENT_INDENT ] { 32 }
+ Constant [ public int EXPLICIT_PARTIAL_CONTEXT ] { 128 }
+ Constant [ public int IGNORE_STANDALONE ] { 256 }
+ Constant [ public int ALTERNATE_DECORATORS ] { 512 }
+ Constant [ public int STRICT ] { 1024 }
+ Constant [ public int ASSUME_OBJECTS ] { 2048 }
+ Constant [ public int MUSTACHE_STYLE_LAMBDAS ] { 4096 }
+ Constant [ public int COMPAT ] { 1 }
+ Constant [ public int ALL ] { 8191 }
+ Constant [ public int USE_PARTIAL ] { 2 }
+ Constant [ public int IS_SIMPLE ] { 4 }
+ Constant [ public int USE_DECORATORS ] { 8 }
+ Constant [ public int RESULT_ALL ] { 15 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:handlebars> static public method compile ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $tmpl ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:handlebars> static public method compilePrint ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $tmpl ]
+ Parameter #1 [ <optional> ?array $options = <default> ]
+ }
+ - Return [ string ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Opcode ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ public string $opcode ]
+ Property [ public array $args ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $opcode ]
+ Parameter #1 [ <required> array $args ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Parser ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:handlebars> static public method parse ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tmpl ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:handlebars> static public method parsePrint ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tmpl ]
+ }
+ - Return [ string ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Program ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [10] {
+ Property [ public $opcodes = NULL ]
+ Property [ public $children = NULL ]
+ Property [ public $decorators = NULL ]
+ Property [ public $isSimple = false ]
+ Property [ public $useDepths = false ]
+ Property [ public $usePartial = false ]
+ Property [ public $useDecorators = false ]
+ Property [ public $blockParams = 0 ]
+ Property [ public $stringParams = false ]
+ Property [ public $trackIds = false ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> array $opcodes ]
+ Parameter #1 [ <required> array $children ]
+ Parameter #2 [ <optional> int $blockParams = <default> ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Token ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [2] {
+ Property [ public string $name ]
+ Property [ public string $text ]
+ }
+
+ - Methods [1] {
+ Method [ <internal:handlebars, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $name ]
+ Parameter #1 [ <required> string $text ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:handlebars> class Handlebars\Tokenizer ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:handlebars> static public method lex ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tmpl ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:handlebars> static public method lexPrint ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string $tmpl ]
+ }
+ - Return [ string ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
}
}
diff --git a/php-pecl-handlebars.spec b/php-pecl-handlebars.spec
index 175b621..fe771ec 100644
--- a/php-pecl-handlebars.spec
+++ b/php-pecl-handlebars.spec
@@ -1,13 +1,12 @@
# remirepo spec file for php-pecl-handlebars
#
-# Copyright (c) 2017-2021 Remi Collet
+# Copyright (c) 2017-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-pecl-handlebars
%endif
@@ -18,11 +17,11 @@
# After 40-psr.ini
%global ini_name 50-%{pecl_name}.ini
-%global upstream_version 0.9.2
+%global upstream_version 1.0.0
#global upstream_prever RC2
Summary: Handlebars templating language
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: BSD
@@ -33,7 +32,7 @@ BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.2
BuildRequires: %{?scl_prefix}php-pear
-BuildRequires: libhandlebars-devel
+BuildRequires: libhandlebars-devel >= 1.0.0
BuildRequires: libtalloc-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -47,23 +46,6 @@ Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-# Other third party repo stuff
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
%description
@@ -78,10 +60,6 @@ Summary: %{name} developer files (header)
Group: Development/Libraries
Requires: %{name}%{?_isa} = %{version}-%{release}
Requires: %{?scl_prefix}php-devel%{?_isa}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
-%endif
%description devel
These are the files needed to compile programs using %{name}.
@@ -96,6 +74,9 @@ mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
+# Honours RPM build options
+sed -e '/ LDFLAGS=/d;/ CFLAGS=/d;' -i config.m4
+
# Sanity check, really often broken
extver=$(sed -n '/PHP_HANDLEBARS_VERSION/{s/.* "//;s/".*$//;p}' php_handlebars.h)
if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
@@ -115,7 +96,7 @@ cat << 'EOF' | tee %{ini_name}
extension=%{pecl_name}.so
; Configuration
-;handlebars.pool_size = '128k'
+;handlebars.pool_size = 0
;handlebars.cache.enable = 1
;handlebars.cache.enable_cli = 0
;handlebars.cache.backend = 'mmap'
@@ -135,6 +116,7 @@ cd NTS
%configure \
--enable-handlebars \
--disable-handlebars-psr \
+ --enable-handlebars-ast \
--with-libdir=%{_lib} \
--with-php-config=%{_bindir}/php-config
@@ -146,6 +128,7 @@ cd ../ZTS
%configure \
--enable-handlebars \
--disable-handlebars-psr \
+ --enable-handlebars-ast \
--with-libdir=%{_lib} \
--with-php-config=%{_bindir}/zts-php-config
@@ -208,10 +191,50 @@ cd NTS
%if %{with tests}
OPT="-q -P --show-diff"
-%if "%{php_version}" > "7.4"
+%if "%{php_version}" >= "7.4"
OPT="$OPT %{?_smp_mflags}"
%endif
+%if "%{php_version}" >= "8.1"
+rm ../?TS/tests/handlebars/export/helpers/050.phpt
+rm ../?TS/tests/handlebars/export/helpers/051.phpt
+rm ../?TS/tests/handlebars/export/helpers/053.phpt
+rm ../?TS/tests/handlebars/export/helpers/054.phpt
+rm ../?TS/tests/handlebars/export/helpers/055.phpt
+rm ../?TS/tests/handlebars/export/helpers/056.phpt
+rm ../?TS/tests/handlebars/export/helpers/064.phpt
+rm ../?TS/tests/handlebars/export/partials/007.phpt
+rm ../?TS/tests/handlebars/export/partials/008.phpt
+rm ../?TS/tests/handlebars/export/partials/054.phpt
+rm ../?TS/tests/handlebars/export/strict/005.phpt
+rm ../?TS/tests/handlebars/export/string-params/001.phpt
+rm ../?TS/tests/handlebars/export/string-params/002.phpt
+rm ../?TS/tests/handlebars/export/string-params/003.phpt
+rm ../?TS/tests/handlebars/export/string-params/004.phpt
+rm ../?TS/tests/handlebars/export/string-params/005.phpt
+rm ../?TS/tests/handlebars/export/string-params/006.phpt
+rm ../?TS/tests/handlebars/export/string-params/007.phpt
+rm ../?TS/tests/handlebars/export/string-params/008.phpt
+rm ../?TS/tests/handlebars/export/subexpressions/015.phpt
+rm ../?TS/tests/handlebars/export/subexpressions/016.phpt
+rm ../?TS/tests/handlebars/export/track-ids/002.phpt
+rm ../?TS/tests/handlebars/export/track-ids/003.phpt
+rm ../?TS/tests/handlebars/export/track-ids/004.phpt
+rm ../?TS/tests/handlebars/export/track-ids/005.phpt
+rm ../?TS/tests/handlebars/export/track-ids/006.phpt
+rm ../?TS/tests/handlebars/export/track-ids/007.phpt
+rm ../?TS/tests/handlebars/export/track-ids/008.phpt
+rm ../?TS/tests/handlebars/export/track-ids/009.phpt
+rm ../?TS/tests/handlebars/export/track-ids/010.phpt
+rm ../?TS/tests/handlebars/export/track-ids/011.phpt
+rm ../?TS/tests/handlebars/export/track-ids/012.phpt
+rm ../?TS/tests/handlebars/export/track-ids/013.phpt
+rm ../?TS/tests/handlebars/export/track-ids/014.phpt
+rm ../?TS/tests/handlebars/export/track-ids/015.phpt
+rm ../?TS/tests/handlebars/export/track-ids/016.phpt
+rm ../?TS/tests/handlebars/export/track-ids/017.phpt
+%endif
+
# Upstream test suite
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
@@ -229,7 +252,7 @@ cd ../ZTS
# Upstream test suite
TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php $OPY
+%{__ztsphp} -n run-tests.php $OPT
%endif
%endif
@@ -259,6 +282,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Nov 28 2022 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- update to 1.0.0
+- raise dependency on libhandlebars 1.0.0
+
* Mon Dec 7 2020 Remi Collet <remi@remirepo.net> - 0.9.2-1
- update to 0.9.2