summaryrefslogtreecommitdiffstats
path: root/php-pecl-ecma-intl.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-29 17:33:47 +0200
committerRemi Collet <remi@php.net>2023-08-29 17:33:47 +0200
commit7ac36cab3239970c55e9158f8681085da8d37b50 (patch)
tree55d3432ecae08dfc663330ed7d6aeb652e15afe9 /php-pecl-ecma-intl.spec
update to 0.1.2
Diffstat (limited to 'php-pecl-ecma-intl.spec')
-rw-r--r--php-pecl-ecma-intl.spec198
1 files changed, 198 insertions, 0 deletions
diff --git a/php-pecl-ecma-intl.spec b/php-pecl-ecma-intl.spec
new file mode 100644
index 0000000..e1fc155
--- /dev/null
+++ b/php-pecl-ecma-intl.spec
@@ -0,0 +1,198 @@
+# remirepo spec file for php-pecl-ecma-intl
+#
+# Copyright (c) 2023 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%{?scl:%scl_package php-pecl-ecma-intl}
+
+%bcond_without tests
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name ecma_intl
+%global ini_name 40-%{pecl_name}.ini
+
+%global upstream_version 0.1.2
+#global upstream_prever RC
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
+
+Summary: i18n and l10n extension for PHP
+Name: %{?scl_prefix}php-pecl-ecma-intl
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+License: BSD-3-Clause
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 8.2
+BuildRequires: %{?scl_prefix}php-devel < 8.2.99
+BuildRequires: %{?scl_prefix}php-pear
+# Upstream requires 70.1
+# We require 72.1 to ensure we use the same version than PHP
+BuildRequires: pkgconfig(icu-uc) >= 72.1
+BuildRequires: pkgconfig(icu-i18n) >= 72.1
+BuildRequires: pkgconfig(icu-io) >= 72.1
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+# Notice pecl_name != name
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+
+%description
+%{pecl_name} is a PHP implementation of the ECMA-402 11th Edition
+Internationalization API Specification.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd %{sources}
+sed -e '/PHP_ECMA_INTL_VERSION/s/0.1.0/%{version}/' -i src/php/ecma_intl.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_ECMA_INTL_VERSION/{s/.* "//;s/".*$//;p}' src/php/ecma_intl.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
+ exit 1
+fi
+cd ..
+
+mkdir NTS
+%if %{with_zts}
+mkdir ZTS
+%endif
+
+# Create configuration files
+cat << 'EOF' | tee %{ini_name}
+; Enable %{pecl_name} extension modules
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+%configure \
+ --enable-ecma_intl \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%configure \
+ --enable-ecma_intl \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__ztsphpconfig}
+make %{?_smp_mflags}
+%endif
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd %{sources}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f $i ] && install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd %{sources}
+
+: Minimal load test for NTS extensions
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with tests}
+# Upstream test suite for NTS extension
+TEST_PHP_ARGS=" -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php $OPT %{?_smp_mflags} -q --show-diff
+%endif
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license %{sources}/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Aug 29 2023 Remi Collet <remi@remirepo.net> - 0.1.2-1
+- update to 0.1.2
+
+* Mon Aug 28 2023 Remi Collet <remi@remirepo.net> - 0.1.1-1
+- initial package, version 0.1.1 (alpha)