summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-29 17:33:47 +0200
committerRemi Collet <remi@php.net>2023-08-29 17:33:47 +0200
commit7ac36cab3239970c55e9158f8681085da8d37b50 (patch)
tree55d3432ecae08dfc663330ed7d6aeb652e15afe9
update to 0.1.2
-rw-r--r--.gitignore9
-rw-r--r--Makefile5
-rw-r--r--PHPINFO9
-rw-r--r--REFLECTION471
-rw-r--r--php-pecl-ecma-intl.spec198
5 files changed, 692 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d5c5f4d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,5 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
+
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..5a35d6c
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,9 @@
+
+ecma_intl
+
+Internationalization Support, Ecma-style (ECMA-402) => enabled
+ecma_intl version => 0.1.2
+ICU version => 72.1
+ICU Data version => 72.1
+ICU TZData version => 2022e
+ICU Unicode version => 15.0
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..538de81
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,471 @@
+Extension [ <persistent> extension #59 ecma_intl version 0.1.2 ] {
+
+ - Classes [8] {
+ Class [ <internal:ecma_intl> final class Ecma\Intl ] {
+
+ - Constants [2] {
+ Constant [ public string ICU_VERSION ] { 72.1 }
+ Constant [ public string UNICODE_VERSION ] { 15.0 }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [2] {
+ Method [ <internal:ecma_intl> static public method getCanonicalLocales ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Traversable|Stringable|array|string|null $locales ]
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl> static public method supportedValuesOf ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Ecma\Intl\Category $category ]
+ }
+ - Return [ array ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:ecma_intl, ctor> private method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:ecma_intl> class Ecma\Intl\Category implements BackedEnum, UnitEnum ] {
+
+ - Constants [6] {
+ Constant [ public Ecma\Intl\Category Calendar ] { Object }
+ Constant [ public Ecma\Intl\Category Collation ] { Object }
+ Constant [ public Ecma\Intl\Category Currency ] { Object }
+ Constant [ public Ecma\Intl\Category NumberingSystem ] { Object }
+ Constant [ public Ecma\Intl\Category TimeZone ] { Object }
+ Constant [ public Ecma\Intl\Category Unit ] { Object }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:ecma_intl, prototype UnitEnum> static public method cases ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl, prototype BackedEnum> static public method from ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string|int $value ]
+ }
+ - Return [ static ]
+ }
+
+ Method [ <internal:ecma_intl, prototype BackedEnum> static public method tryFrom ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string|int $value ]
+ }
+ - Return [ ?static ]
+ }
+ }
+
+ - Properties [2] {
+ Property [ public readonly string $name ]
+ Property [ public readonly string $value ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:ecma_intl> readonly class Ecma\Intl\Locale implements Stringable, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [18] {
+ Property [ public readonly ?string $baseName ]
+ Property [ public readonly ?string $calendar ]
+ Property [ public readonly array $calendars ]
+ Property [ public readonly ?string $caseFirst ]
+ Property [ public readonly ?string $collation ]
+ Property [ public readonly array $collations ]
+ Property [ public readonly array $currencies ]
+ Property [ public readonly ?string $hourCycle ]
+ Property [ public readonly array $hourCycles ]
+ Property [ public readonly ?string $language ]
+ Property [ public readonly ?string $numberingSystem ]
+ Property [ public readonly array $numberingSystems ]
+ Property [ public readonly bool $numeric ]
+ Property [ public readonly ?string $region ]
+ Property [ public readonly ?string $script ]
+ Property [ public readonly Ecma\Intl\Locale\TextInfo $textInfo ]
+ Property [ public readonly ?array $timeZones ]
+ Property [ public readonly Ecma\Intl\Locale\WeekInfo $weekInfo ]
+ }
+
+ - Methods [14] {
+ Method [ <internal:ecma_intl, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Stringable|string $tag ]
+ Parameter #1 [ <optional> ?Ecma\Intl\Locale\Options $options = null ]
+ }
+ }
+
+ Method [ <internal:ecma_intl, prototype Stringable> public method __toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:ecma_intl> public method getCalendars ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl> public method getCollations ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl> public method getCurrencies ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl> public method getHourCycles ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl> public method getNumberingSystems ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl> public method getTextInfo ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Ecma\Intl\Locale\TextInfo ]
+ }
+
+ Method [ <internal:ecma_intl> public method getTimeZones ] {
+
+ - Parameters [0] {
+ }
+ - Return [ ?array ]
+ }
+
+ Method [ <internal:ecma_intl> public method getWeekInfo ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Ecma\Intl\Locale\WeekInfo ]
+ }
+
+ Method [ <internal:ecma_intl, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object ]
+ }
+
+ Method [ <internal:ecma_intl> public method maximize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Ecma\Intl\Locale ]
+ }
+
+ Method [ <internal:ecma_intl> public method minimize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ Ecma\Intl\Locale ]
+ }
+
+ Method [ <internal:ecma_intl> public method toString ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+ }
+
+ Class [ <internal:ecma_intl> class Ecma\Intl\Locale\CharacterDirection implements BackedEnum, UnitEnum ] {
+
+ - Constants [2] {
+ Constant [ public Ecma\Intl\Locale\CharacterDirection LeftToRight ] { Object }
+ Constant [ public Ecma\Intl\Locale\CharacterDirection RightToLeft ] { Object }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:ecma_intl, prototype UnitEnum> static public method cases ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl, prototype BackedEnum> static public method from ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string|int $value ]
+ }
+ - Return [ static ]
+ }
+
+ Method [ <internal:ecma_intl, prototype BackedEnum> static public method tryFrom ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string|int $value ]
+ }
+ - Return [ ?static ]
+ }
+ }
+
+ - Properties [2] {
+ Property [ public readonly string $name ]
+ Property [ public readonly string $value ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:ecma_intl> <iterateable> readonly class Ecma\Intl\Locale\Options implements Iterator, Traversable, JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [9] {
+ Property [ public readonly ?string $calendar ]
+ Property [ public readonly ?string $caseFirst ]
+ Property [ public readonly ?string $collation ]
+ Property [ public readonly ?string $hourCycle ]
+ Property [ public readonly ?string $language ]
+ Property [ public readonly ?string $numberingSystem ]
+ Property [ public readonly ?bool $numeric ]
+ Property [ public readonly ?string $region ]
+ Property [ public readonly ?string $script ]
+ }
+
+ - Methods [7] {
+ Method [ <internal:ecma_intl, ctor> public method __construct ] {
+
+ - Parameters [9] {
+ Parameter #0 [ <optional> Stringable|string|null $calendar = null ]
+ Parameter #1 [ <optional> Stringable|string|false|null $caseFirst = null ]
+ Parameter #2 [ <optional> Stringable|string|null $collation = null ]
+ Parameter #3 [ <optional> Stringable|string|null $hourCycle = null ]
+ Parameter #4 [ <optional> Stringable|string|null $language = null ]
+ Parameter #5 [ <optional> Stringable|string|null $numberingSystem = null ]
+ Parameter #6 [ <optional> ?bool $numeric = null ]
+ Parameter #7 [ <optional> Stringable|string|null $region = null ]
+ Parameter #8 [ <optional> Stringable|string|null $script = null ]
+ }
+ }
+
+ Method [ <internal:ecma_intl, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object ]
+ }
+
+ Method [ <internal:ecma_intl, prototype Iterator> public method current ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string|bool ]
+ }
+
+ Method [ <internal:ecma_intl, prototype Iterator> public method next ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:ecma_intl, prototype Iterator> public method key ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:ecma_intl, prototype Iterator> public method valid ] {
+
+ - Parameters [0] {
+ }
+ - Return [ bool ]
+ }
+
+ Method [ <internal:ecma_intl, prototype Iterator> public method rewind ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+ }
+ }
+
+ Class [ <internal:ecma_intl> readonly class Ecma\Intl\Locale\TextInfo implements JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [1] {
+ Property [ public readonly Ecma\Intl\Locale\CharacterDirection $direction ]
+ }
+
+ - Methods [2] {
+ Method [ <internal:ecma_intl, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Ecma\Intl\Locale\CharacterDirection $direction ]
+ }
+ }
+
+ Method [ <internal:ecma_intl, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object ]
+ }
+ }
+ }
+
+ Class [ <internal:ecma_intl> class Ecma\Intl\Locale\WeekDay implements BackedEnum, UnitEnum ] {
+
+ - Constants [7] {
+ Constant [ public Ecma\Intl\Locale\WeekDay Monday ] { Object }
+ Constant [ public Ecma\Intl\Locale\WeekDay Tuesday ] { Object }
+ Constant [ public Ecma\Intl\Locale\WeekDay Wednesday ] { Object }
+ Constant [ public Ecma\Intl\Locale\WeekDay Thursday ] { Object }
+ Constant [ public Ecma\Intl\Locale\WeekDay Friday ] { Object }
+ Constant [ public Ecma\Intl\Locale\WeekDay Saturday ] { Object }
+ Constant [ public Ecma\Intl\Locale\WeekDay Sunday ] { Object }
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [3] {
+ Method [ <internal:ecma_intl, prototype UnitEnum> static public method cases ] {
+
+ - Parameters [0] {
+ }
+ - Return [ array ]
+ }
+
+ Method [ <internal:ecma_intl, prototype BackedEnum> static public method from ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string|int $value ]
+ }
+ - Return [ static ]
+ }
+
+ Method [ <internal:ecma_intl, prototype BackedEnum> static public method tryFrom ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> string|int $value ]
+ }
+ - Return [ ?static ]
+ }
+ }
+
+ - Properties [2] {
+ Property [ public readonly string $name ]
+ Property [ public readonly int $value ]
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Class [ <internal:ecma_intl> readonly class Ecma\Intl\Locale\WeekInfo implements JsonSerializable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [3] {
+ Property [ public readonly Ecma\Intl\Locale\WeekDay $firstDay ]
+ Property [ public readonly int $minimalDays ]
+ Property [ public readonly array $weekend ]
+ }
+
+ - Methods [2] {
+ Method [ <internal:ecma_intl, ctor> public method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> Ecma\Intl\Locale\WeekDay $firstDay ]
+ Parameter #1 [ <required> array $weekend ]
+ Parameter #2 [ <required> int $minimalDays ]
+ }
+ }
+
+ Method [ <internal:ecma_intl, prototype JsonSerializable> public method jsonSerialize ] {
+
+ - Parameters [0] {
+ }
+ - Return [ object ]
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pecl-ecma-intl.spec b/php-pecl-ecma-intl.spec
new file mode 100644
index 0000000..e1fc155
--- /dev/null
+++ b/php-pecl-ecma-intl.spec
@@ -0,0 +1,198 @@
+# remirepo spec file for php-pecl-ecma-intl
+#
+# Copyright (c) 2023 Remi Collet
+# License: CC-BY-SA-4.0
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%{?scl:%scl_package php-pecl-ecma-intl}
+
+%bcond_without tests
+
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name ecma_intl
+%global ini_name 40-%{pecl_name}.ini
+
+%global upstream_version 0.1.2
+#global upstream_prever RC
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
+
+Summary: i18n and l10n extension for PHP
+Name: %{?scl_prefix}php-pecl-ecma-intl
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+
+License: BSD-3-Clause
+URL: https://pecl.php.net/package/%{pecl_name}
+Source0: https://pecl.php.net/get/%{sources}.tgz
+
+BuildRequires: make
+BuildRequires: %{?dtsprefix}gcc
+BuildRequires: %{?scl_prefix}php-devel >= 8.2
+BuildRequires: %{?scl_prefix}php-devel < 8.2.99
+BuildRequires: %{?scl_prefix}php-pear
+# Upstream requires 70.1
+# We require 72.1 to ensure we use the same version than PHP
+BuildRequires: pkgconfig(icu-uc) >= 72.1
+BuildRequires: pkgconfig(icu-i18n) >= 72.1
+BuildRequires: pkgconfig(icu-io) >= 72.1
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+
+Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
+Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
+Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
+# Notice pecl_name != name
+Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
+Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
+
+
+%description
+%{pecl_name} is a PHP implementation of the ECMA-402 11th Edition
+Internationalization API Specification.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+# Don't install/register tests
+sed -e 's/role="test"/role="src"/' \
+ %{?_licensedir:-e '/LICENSE/s/role="doc"/role="src"/' } \
+ -i package.xml
+
+cd %{sources}
+sed -e '/PHP_ECMA_INTL_VERSION/s/0.1.0/%{version}/' -i src/php/ecma_intl.h
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_ECMA_INTL_VERSION/{s/.* "//;s/".*$//;p}' src/php/ecma_intl.h)
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever}.
+ exit 1
+fi
+cd ..
+
+mkdir NTS
+%if %{with_zts}
+mkdir ZTS
+%endif
+
+# Create configuration files
+cat << 'EOF' | tee %{ini_name}
+; Enable %{pecl_name} extension modules
+extension=%{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+%configure \
+ --enable-ecma_intl \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__phpconfig}
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%configure \
+ --enable-ecma_intl \
+ --with-libdir=%{_lib} \
+ --with-php-config=%{__ztsphpconfig}
+make %{?_smp_mflags}
+%endif
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+# Install XML package description
+install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+# Documentation
+cd %{sources}
+for i in $(grep 'role="doc"' ../package.xml | sed -e 's/^.*name="//;s/".*$//')
+do [ -f $i ] && install -Dpm 644 $i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+done
+
+
+%check
+cd %{sources}
+
+: Minimal load test for NTS extensions
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+
+%if %{with tests}
+# Upstream test suite for NTS extension
+TEST_PHP_ARGS=" -d extension=%{buildroot}/%{php_extdir}/%{pecl_name}.so" \
+%{__php} -n run-tests.php $OPT %{?_smp_mflags} -q --show-diff
+%endif
+
+%if %{with_zts}
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep '^%{pecl_name}$'
+%endif
+
+
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
+# when pear installed alone, after us
+%triggerin -- %{?scl_prefix}php-pear
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+# posttrans as pear can be installed after us
+%posttrans
+if [ -x %{__pecl} ] ; then
+ %{pecl_install} %{pecl_xmldir}/%{name}.xml >/dev/null || :
+fi
+
+%postun
+if [ $1 -eq 0 -a -x %{__pecl} ] ; then
+ %{pecl_uninstall} %{pecl_name} >/dev/null || :
+fi
+%endif
+
+
+%files
+%{?_licensedir:%license %{sources}/LICENSE}
+%doc %{pecl_docdir}/%{pecl_name}
+%{pecl_xmldir}/%{name}.xml
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Aug 29 2023 Remi Collet <remi@remirepo.net> - 0.1.2-1
+- update to 0.1.2
+
+* Mon Aug 28 2023 Remi Collet <remi@remirepo.net> - 0.1.1-1
+- initial package, version 0.1.1 (alpha)