summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--0001-fix-missing-return-after-exception.patch39
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION220
-rw-r--r--php-pecl-ds.spec112
4 files changed, 185 insertions, 188 deletions
diff --git a/0001-fix-missing-return-after-exception.patch b/0001-fix-missing-return-after-exception.patch
deleted file mode 100644
index 68b3a99..0000000
--- a/0001-fix-missing-return-after-exception.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 465cf909d98eb4f7c00c13ecb73e3d4c50e22e91 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 3 Nov 2020 10:34:40 +0100
-Subject: [PATCH 1/2] fix missing return after exception
-
----
- src/php/handlers/php_common_handlers.c | 4 +++-
- 1 file changed, 3 insertions(+), 1 deletion(-)
-
-diff --git a/src/php/handlers/php_common_handlers.c b/src/php/handlers/php_common_handlers.c
-index 7d84dfb..e2441b2 100644
---- a/src/php/handlers/php_common_handlers.c
-+++ b/src/php/handlers/php_common_handlers.c
-@@ -38,6 +38,7 @@ zval *php_ds_read_dimension_by_key_not_supported
- (zval *obj, zval *offset, int type, zval *rv) {
- #endif
- ARRAY_ACCESS_BY_KEY_NOT_SUPPORTED();
-+ return NULL;
- }
-
- int php_ds_has_dimension_by_key_not_supported
-@@ -47,6 +48,7 @@ int php_ds_has_dimension_by_key_not_supported
- (zval *obj, zval *offset, int check_empty) {
- #endif
- ARRAY_ACCESS_BY_KEY_NOT_SUPPORTED();
-+ return 0;
- }
-
- void php_ds_unset_dimension_by_key_not_supported
-@@ -56,4 +58,4 @@ void php_ds_unset_dimension_by_key_not_supported
- (zval *obj, zval *offset) {
- #endif
- ARRAY_ACCESS_BY_KEY_NOT_SUPPORTED();
--}
-\ No newline at end of file
-+}
---
-2.25.4
-
diff --git a/PHPINFO b/PHPINFO
index a6135e2..9eba475 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
ds
ds support => enabled
-ds version => 1.3.0
+ds version => 1.5.0
diff --git a/REFLECTION b/REFLECTION
index e7c5f64..842258a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 ds version 1.3.0 ] {
+Extension [ <persistent> extension #63 ds version 1.5.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -80,18 +80,24 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
}
Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ Traversable ]
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:json, inherits JsonSerializable> abstract public method jsonSerialize ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
}
}
@@ -136,7 +142,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> abstract public method filter ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $callback ]
+ Parameter #0 [ <optional> ?callable $callback = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -172,7 +178,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> abstract public method join ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $glue ]
+ Parameter #0 [ <optional> string $glue = <default> ]
}
- Return [ string ]
}
@@ -216,7 +222,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> callable $callback ]
- Parameter #1 [ <optional> $initial ]
+ Parameter #1 [ <optional> $initial = <default> ]
}
}
@@ -258,7 +264,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> int $index ]
- Parameter #1 [ <optional> int or NULL $length ]
+ Parameter #1 [ <optional> ?int $length = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -266,7 +272,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> abstract public method sort ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
}
@@ -305,47 +311,57 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
}
Method [ <internal:Core, inherits IteratorAggregate> abstract public method getIterator ] {
+
+ - Parameters [0] {
+ }
+ - Tentative return [ Traversable ]
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:json, inherits JsonSerializable> abstract public method jsonSerialize ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
}
}
@@ -369,7 +385,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $values ]
+ Parameter #0 [ <optional> $values = <default> ]
}
}
@@ -377,7 +393,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
- - Return [ Traversable or NULL ]
+ - Return [ Traversable ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method allocate ] {
@@ -412,7 +428,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method filter ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $callback ]
+ Parameter #0 [ <optional> ?callable $callback = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -448,7 +464,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method join ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $glue ]
+ Parameter #0 [ <optional> string $glue = <default> ]
}
- Return [ string ]
}
@@ -486,23 +502,26 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
@@ -522,7 +541,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> callable $callback ]
- Parameter #1 [ <optional> $initial ]
+ Parameter #1 [ <optional> $initial = <default> ]
}
}
@@ -571,7 +590,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> int $index ]
- Parameter #1 [ <optional> int or NULL $length ]
+ Parameter #1 [ <optional> ?int $length = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -579,14 +598,14 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
}
Method [ <internal:ds> public method sorted ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -635,6 +654,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -665,7 +685,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $values ]
+ Parameter #0 [ <optional> $values = <default> ]
}
}
@@ -673,7 +693,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
- - Return [ Traversable or NULL ]
+ - Return [ Traversable ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -707,6 +727,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -748,7 +769,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method filter ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $callback ]
+ Parameter #0 [ <optional> ?callable $callback = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -784,7 +805,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method join ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $glue ]
+ Parameter #0 [ <optional> string $glue = <default> ]
}
- Return [ string ]
}
@@ -822,23 +843,26 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
@@ -858,7 +882,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> callable $callback ]
- Parameter #1 [ <optional> $initial ]
+ Parameter #1 [ <optional> $initial = <default> ]
}
}
@@ -907,7 +931,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> int $index ]
- Parameter #1 [ <optional> int or NULL $length ]
+ Parameter #1 [ <optional> ?int $length = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -915,14 +939,14 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype Ds\Sequence> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
}
Method [ <internal:ds> public method sorted ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
- Return [ Ds\Sequence ]
}
@@ -960,7 +984,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $values ]
+ Parameter #0 [ <optional> $values = <default> ]
}
}
@@ -1001,7 +1025,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
- - Return [ Traversable or NULL ]
+ - Return [ Traversable ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
@@ -1015,23 +1039,26 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1065,6 +1092,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1076,7 +1104,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Queue implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Queue implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate, ArrayAccess ] {
- Constants [1] {
Constant [ public int MIN_CAPACITY ] { 8 }
@@ -1095,7 +1123,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $values ]
+ Parameter #0 [ <optional> $values = <default> ]
}
}
@@ -1136,10 +1164,10 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
- - Return [ Traversable or NULL ]
+ - Return [ Traversable ]
}
- Method [ <internal:ds> public method offsetExists ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
@@ -1147,26 +1175,29 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Return [ bool ]
}
- Method [ <internal:ds> public method offsetGet ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
- Method [ <internal:ds> public method offsetSet ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
- Method [ <internal:ds> public method offsetUnset ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1200,6 +1231,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1230,7 +1262,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $values ]
+ Parameter #0 [ <optional> $values = <default> ]
}
}
@@ -1266,7 +1298,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> public method filter ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $callback ]
+ Parameter #0 [ <optional> ?callable $callback = <default> ]
}
- Return [ Ds\Map ]
}
@@ -1282,7 +1314,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $default ]
+ Parameter #1 [ <optional> $default = <default> ]
}
}
@@ -1320,14 +1352,14 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> public method ksort ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
}
Method [ <internal:ds> public method ksorted ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
- Return [ Ds\Map ]
}
@@ -1381,7 +1413,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> callable $callback ]
- Parameter #1 [ <optional> $initial ]
+ Parameter #1 [ <optional> $initial = <default> ]
}
}
@@ -1389,7 +1421,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $default ]
+ Parameter #1 [ <optional> $default = <default> ]
}
}
@@ -1418,7 +1450,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> int $index ]
- Parameter #1 [ <optional> int or NULL $length ]
+ Parameter #1 [ <optional> ?int $length = <default> ]
}
- Return [ Ds\Map ]
}
@@ -1426,14 +1458,14 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
}
Method [ <internal:ds> public method sorted ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
- Return [ Ds\Map ]
}
@@ -1471,7 +1503,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
- - Return [ Traversable or NULL ]
+ - Return [ Traversable ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
@@ -1485,23 +1517,26 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1535,6 +1570,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1546,7 +1582,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
}
}
- Class [ <internal:ds> <iterateable> final class Ds\Set implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate ] {
+ Class [ <internal:ds> <iterateable> final class Ds\Set implements Ds\Collection, JsonSerializable, Countable, Traversable, IteratorAggregate, ArrayAccess ] {
- Constants [1] {
Constant [ public int MIN_CAPACITY ] { 8 }
@@ -1565,7 +1601,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [1] {
- Parameter #0 [ <optional> $values ]
+ Parameter #0 [ <optional> $values = <default> ]
}
}
@@ -1609,7 +1645,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> public method filter ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $predicate ]
+ Parameter #0 [ <optional> ?callable $predicate = <default> ]
}
- Return [ Ds\Set ]
}
@@ -1638,7 +1674,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> public method join ] {
- Parameters [1] {
- Parameter #0 [ <optional> string $glue ]
+ Parameter #0 [ <optional> string $glue = <default> ]
}
}
@@ -1668,7 +1704,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> callable $callback ]
- Parameter #1 [ <optional> $initial ]
+ Parameter #1 [ <optional> $initial = <default> ]
}
}
@@ -1696,7 +1732,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [2] {
Parameter #0 [ <required> int $index ]
- Parameter #1 [ <optional> int or NULL $length ]
+ Parameter #1 [ <optional> ?int $length = <default> ]
}
- Return [ Ds\Set ]
}
@@ -1704,14 +1740,14 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
Method [ <internal:ds> public method sort ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
}
Method [ <internal:ds> public method sorted ] {
- Parameters [1] {
- Parameter #0 [ <optional> callable or NULL $comparator ]
+ Parameter #0 [ <optional> ?callable $comparator = <default> ]
}
- Return [ Ds\Set ]
}
@@ -1742,10 +1778,10 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
- - Return [ Traversable or NULL ]
+ - Return [ Traversable ]
}
- Method [ <internal:ds> public method offsetExists ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetExists ] {
- Parameters [1] {
Parameter #0 [ <required> $offset ]
@@ -1753,26 +1789,29 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Return [ bool ]
}
- Method [ <internal:ds> public method offsetGet ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetGet ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
- Method [ <internal:ds> public method offsetSet ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
- Parameters [2] {
- Parameter #0 [ <required> $offset ]
- Parameter #1 [ <required> $value ]
+ Parameter #0 [ <required> mixed $offset ]
+ Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
- Method [ <internal:ds> public method offsetUnset ] {
+ Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
- Parameters [1] {
- Parameter #0 [ <required> $offset ]
+ Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1806,6 +1845,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1877,7 +1917,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
- - Return [ Traversable or NULL ]
+ - Return [ Traversable ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1911,6 +1951,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1934,16 +1975,16 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
}
- Properties [2] {
- Property [ <default> public $key ]
- Property [ <default> public $value ]
+ Property [ public $key = NULL ]
+ Property [ public $value = NULL ]
}
- Methods [4] {
Method [ <internal:ds, ctor> public method __construct ] {
- Parameters [2] {
- Parameter #0 [ <optional> $key ]
- Parameter #1 [ <optional> $value ]
+ Parameter #0 [ <optional> $key = <default> ]
+ Parameter #1 [ <optional> $value = <default> ]
}
}
@@ -1958,6 +1999,7 @@ Extension [ <persistent> extension #117 ds version 1.3.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds> public method toArray ] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index a130037..b9156b5 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -1,18 +1,14 @@
# remirepo spec file for php-pecl-ds
#
-# Copyright (c) 2016-2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2016-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-# we don't want -z defs linker flag
-%undefine _strict_symbol_defs_build
-
%if 0%{?scl:1}
%scl_package php-pecl-ds
-%global sub_prefix %{scl_prefix}
# No phpunit in SCL
%bcond_with tests
%else
@@ -23,34 +19,36 @@
%global pecl_name ds
# After json
%global ini_name 40-%{pecl_name}.ini
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit 5323dffd6130d733b308e53cc8017eb41d278f3a
+# version 1.5.1
+%global gh_commit 3d14aa6f8c25d38d79c90924150c51636544e4a8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
Summary: Data Structures for PHP
-Name: %{?sub_prefix}php-pecl-%{pecl_name}
-Version: 1.3.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Name: %{?scl_prefix}php-pecl-%{pecl_name}
+Version: 1.5.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# Only use for tests during the build, no value to be packaged separately
-# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
+# in composer.json: "require-dev": { "php-ds/tests": "^1.5.0" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
-Patch0: 0001-fix-missing-return-after-exception.patch
-
+BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-json
%if %{with tests}
-BuildRequires: %{_bindir}/phpunit6
+BuildRequires: %{_bindir}/phpunit9
BuildRequires: %{_bindir}/phpab
%endif
#BuildRequires: php-debuginfo
@@ -59,34 +57,11 @@ BuildRequires: %{_bindir}/phpab
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
Requires: %{?scl_prefix}php-json%{?_isa}
-%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
Provides: %{?scl_prefix}php-%{pecl_name} = %{version}
Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
-
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-%if "%{php_version}" > "7.3"
-Obsoletes: php73-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%endif
-
-%if 0%{?fedora} < 20 && 0%{?rhel} < 7
-# Filter shared private
-%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
-%{?filter_setup}
-%endif
%description
@@ -98,15 +73,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -q -c -a 1
-mv %{pecl_name}-%{version} NTS
mv %{gh_project}-%{gh_commit} tests
# Don't install/register tests, install examples as doc
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-cd NTS
-%patch0 -p1
-
+cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DS_VERSION/{s/.* "//;s/".*$//;p}' php_ds.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -115,9 +87,9 @@ if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
fi
cd ..
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -138,14 +110,15 @@ peclbuild() {
make %{?_smp_mflags}
}
-cd NTS
-%{_bindir}/phpize
-peclbuild %{_bindir}/php-config
+cd %{sources}
+%{__phpize}
+
+cd ../NTS
+peclbuild %{__phpconfig}
%if %{with_zts}
cd ../ZTS
-%{_bindir}/zts-phpize
-peclbuild %{_bindir}/zts-php-config
+peclbuild %{__ztsphpconfig}
%endif
@@ -170,7 +143,7 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Documentation
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -195,24 +168,21 @@ fi
%check
-modules="-d extension=json.so"
+[ -f %{php_extdir}/json.so ] && modules="-d extension=json.so"
-cd NTS
: Minimal load test for NTS extension
%{__php} --no-php-ini \
$modules \
--define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%if %{with_zts}
-cd ../ZTS
: Minimal load test for ZTS extension
%{__ztsphp} --no-php-ini \
$modules \
--define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
- --modules | grep %{pecl_name}
+ --modules | grep '^%{pecl_name}$'
%endif
-cd ..
%if %{with tests}
: Generate autoloader for tests
@@ -223,14 +193,15 @@ cd ..
: Run upstream test suite
%{_bindir}/php \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- %{_bindir}/phpunit6 \
+ %{_bindir}/phpunit9 \
+ --do-not-cache-result \
--bootstrap tests/autoload.php \
- tests
+ --verbose tests
%endif
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%{!?_licensedir:%doc %{pecl_docdir}/%{pecl_name}}
%{pecl_xmldir}/%{name}.xml
@@ -244,6 +215,29 @@ cd ..
%changelog
+* Wed Dec 20 2023 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.4.0-3
+- rebuild for PHP 8.3.0RC1
+
+* Wed Jul 12 2023 Remi Collet <remi@remirepo.net> - 1.4.0-2
+- build out of sources tree
+- add upstream patch for PHP 8.3
+
+* Tue Dec 14 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- raise dependency on PHP 7.3
+- drop all patches merged upstream
+- switch to phpunit8
+
+* Wed Nov 3 2021 Remi Collet <remi@remirepo.net> - 1.3.0-6
+- add patches for PHP 8.1 from upstream and from
+ https://github.com/php-ds/ext-ds/pull/187
+
+* Fri Mar 26 2021 Remi Collet <remi@remirepo.net> - 1.3.0-4
+- switch to phpunit7
+
* Tue Nov 3 2020 Remi Collet <remi@remirepo.net> - 1.3.0-2
- fix segfault using patch from
https://github.com/php-ds/ext-ds/pull/165