summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-20 09:30:16 +0100
committerRemi Collet <remi@php.net>2023-12-20 09:30:16 +0100
commite6ba1308001e01a5b3c5c1391ab18e152ee19b53 (patch)
treee80547648f7cce93d9fd75ccf07ca7f7497503d4
parentb880ff7f17f64c6a8aa4b4f2cdc29c972222c14e (diff)
update to 1.5.0HEADmaster
-rw-r--r--0001-fast_add_function-removed-in-PHP-8.3-use-add_functio.patch44
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION38
-rw-r--r--php-pecl-ds.spec23
4 files changed, 49 insertions, 58 deletions
diff --git a/0001-fast_add_function-removed-in-PHP-8.3-use-add_functio.patch b/0001-fast_add_function-removed-in-PHP-8.3-use-add_functio.patch
deleted file mode 100644
index 56f2bd9..0000000
--- a/0001-fast_add_function-removed-in-PHP-8.3-use-add_functio.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From d6ad43ee713b4b57111462309358c97e0b43cab3 Mon Sep 17 00:00:00 2001
-From: Jan Ehrhardt <github@ehrhardt.nl>
-Date: Sun, 18 Jun 2023 01:48:54 +0200
-Subject: [PATCH] fast_add_function removed in PHP 8.3, use add_function
-
----
- src/common.h | 14 ++++++++++++++
- 1 file changed, 14 insertions(+)
-
-diff --git a/src/common.h b/src/common.h
-index 5ff8cd4..509a6bb 100644
---- a/src/common.h
-+++ b/src/common.h
-@@ -84,6 +84,7 @@ do { \
- /**
- * Adds the given zval "val" to "sum".
- */
-+#if PHP_MAJOR_VERSION < 8 || PHP_MAJOR_VERSION == 8 && PHP_MINOR_VERSION < 3
- #define DS_ADD_TO_SUM(val, sum) \
- do { \
- if (Z_TYPE_P(val) == IS_LONG || Z_TYPE_P(val) == IS_DOUBLE) { \
-@@ -95,6 +96,19 @@ do { \
- fast_add_function(sum, sum, &_num); \
- } \
- } while (0)
-+#else
-+#define DS_ADD_TO_SUM(val, sum) \
-+do { \
-+ if (Z_TYPE_P(val) == IS_LONG || Z_TYPE_P(val) == IS_DOUBLE) { \
-+ add_function(sum, sum, val); \
-+ } else { \
-+ zval _num; \
-+ ZVAL_COPY(&_num, val); \
-+ convert_scalar_to_number(&_num); \
-+ add_function(sum, sum, &_num); \
-+ } \
-+} while (0)
-+#endif
-
- /**
- * Used to replace a buffer with a new one.
---
-2.41.0
-
diff --git a/PHPINFO b/PHPINFO
index 4d84f2a..9eba475 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,4 +2,4 @@
ds
ds support => enabled
-ds version => 1.4.0
+ds version => 1.5.0
diff --git a/REFLECTION b/REFLECTION
index 72e5e16..842258a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 ds version 1.4.0 ] {
+Extension [ <persistent> extension #63 ds version 1.5.0 ] {
- Dependencies {
Dependency [ json (Required) ]
@@ -83,18 +83,21 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ Traversable ]
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:json, inherits JsonSerializable> abstract public method jsonSerialize ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
}
}
@@ -311,18 +314,21 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ Traversable ]
}
Method [ <internal:Core, inherits Countable> abstract public method count ] {
- Parameters [0] {
}
+ - Tentative return [ int ]
}
Method [ <internal:json, inherits JsonSerializable> abstract public method jsonSerialize ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetExists ] {
@@ -330,6 +336,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ bool ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetGet ] {
@@ -337,6 +344,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetSet ] {
@@ -345,6 +353,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits ArrayAccess> abstract public method offsetUnset ] {
@@ -352,6 +361,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
}
}
@@ -494,6 +504,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
@@ -502,6 +513,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
@@ -509,6 +521,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
@@ -641,6 +654,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -713,6 +727,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -830,6 +845,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
@@ -838,6 +854,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
@@ -845,6 +862,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Sequence> public method pop ] {
@@ -1023,6 +1041,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
@@ -1031,6 +1050,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
@@ -1038,6 +1058,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1071,6 +1092,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1158,6 +1180,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
@@ -1166,6 +1189,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
@@ -1173,6 +1197,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1206,6 +1231,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1493,6 +1519,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
@@ -1501,6 +1528,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
@@ -1508,6 +1536,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1541,6 +1570,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1764,6 +1794,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetSet ] {
@@ -1772,6 +1803,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
Parameter #0 [ <required> mixed $offset ]
Parameter #1 [ <required> mixed $value ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype ArrayAccess> public method offsetUnset ] {
@@ -1779,6 +1811,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [1] {
Parameter #0 [ <required> mixed $offset ]
}
+ - Tentative return [ void ]
}
Method [ <internal:ds, prototype Ds\Collection> public method clear ] {
@@ -1812,6 +1845,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1917,6 +1951,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds, prototype Ds\Collection> public method toArray ] {
@@ -1964,6 +1999,7 @@ Extension [ <persistent> extension #120 ds version 1.4.0 ] {
- Parameters [0] {
}
+ - Tentative return [ mixed ]
}
Method [ <internal:ds> public method toArray ] {
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 87302d3..b9156b5 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -23,7 +23,8 @@
%global _configure ../%{sources}/configure
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit d4f0a9123a82764841d57aa59b2cf1172a413f1d
+# version 1.5.1
+%global gh_commit 3d14aa6f8c25d38d79c90924150c51636544e4a8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -31,26 +32,23 @@
Summary: Data Structures for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.4.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.5.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# Only use for tests during the build, no value to be packaged separately
-# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
+# in composer.json: "require-dev": { "php-ds/tests": "^1.5.0" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
-# Upstream patch for 8.3
-Patch0: 0001-fast_add_function-removed-in-PHP-8.3-use-add_functio.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.3
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-json
%if %{with tests}
-BuildRequires: %{_bindir}/phpunit8
+BuildRequires: %{_bindir}/phpunit9
BuildRequires: %{_bindir}/phpab
%endif
#BuildRequires: php-debuginfo
@@ -81,8 +79,6 @@ mv %{gh_project}-%{gh_commit} tests
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd %{sources}
-%patch -P0 -p1 -b .up
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DS_VERSION/{s/.* "//;s/".*$//;p}' php_ds.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -197,7 +193,7 @@ fi
: Run upstream test suite
%{_bindir}/php \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- %{_bindir}/phpunit8 \
+ %{_bindir}/phpunit9 \
--do-not-cache-result \
--bootstrap tests/autoload.php \
--verbose tests
@@ -219,6 +215,9 @@ fi
%changelog
+* Wed Dec 20 2023 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.4.0-3
- rebuild for PHP 8.3.0RC1