summaryrefslogtreecommitdiffstats
path: root/php-pecl-ds.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-ds.spec')
-rw-r--r--php-pecl-ds.spec23
1 files changed, 11 insertions, 12 deletions
diff --git a/php-pecl-ds.spec b/php-pecl-ds.spec
index 87302d3..b9156b5 100644
--- a/php-pecl-ds.spec
+++ b/php-pecl-ds.spec
@@ -23,7 +23,8 @@
%global _configure ../%{sources}/configure
# For test suite, see https://github.com/php-ds/tests/commits/master
-%global gh_commit d4f0a9123a82764841d57aa59b2cf1172a413f1d
+# version 1.5.1
+%global gh_commit 3d14aa6f8c25d38d79c90924150c51636544e4a8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner php-ds
%global gh_project tests
@@ -31,26 +32,23 @@
Summary: Data Structures for PHP
Name: %{?scl_prefix}php-pecl-%{pecl_name}
-Version: 1.4.0
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.5.0
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}.tgz
# Only use for tests during the build, no value to be packaged separately
-# in composer.json: "require-dev": { "php-ds/tests": "dev-master" }
+# in composer.json: "require-dev": { "php-ds/tests": "^1.5.0" }
Source1: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{gh_short}.tar.gz
-# Upstream patch for 8.3
-Patch0: 0001-fast_add_function-removed-in-PHP-8.3-use-add_functio.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel >= 7.3
+BuildRequires: %{?scl_prefix}php-devel >= 7.4
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-json
%if %{with tests}
-BuildRequires: %{_bindir}/phpunit8
+BuildRequires: %{_bindir}/phpunit9
BuildRequires: %{_bindir}/phpab
%endif
#BuildRequires: php-debuginfo
@@ -81,8 +79,6 @@ mv %{gh_project}-%{gh_commit} tests
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd %{sources}
-%patch -P0 -p1 -b .up
-
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_DS_VERSION/{s/.* "//;s/".*$//;p}' php_ds.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -197,7 +193,7 @@ fi
: Run upstream test suite
%{_bindir}/php \
-d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
- %{_bindir}/phpunit8 \
+ %{_bindir}/phpunit9 \
--do-not-cache-result \
--bootstrap tests/autoload.php \
--verbose tests
@@ -219,6 +215,9 @@ fi
%changelog
+* Wed Dec 20 2023 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.4.0-3
- rebuild for PHP 8.3.0RC1