summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-01 17:32:49 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-01 17:32:49 +0100
commitdaf6c4adcd1f1e445b07e52e078f6d0f48ed4b9d (patch)
tree50141d570d6c206b94707451aca7ad7ff3a32573
parentbdb8f4810ecebcb21116d78122a01bc20ba0bc53 (diff)
php-pecl-amqp: 1.8.0beta1
-rw-r--r--REFLECTION-DEV281
-rw-r--r--php-pecl-amqp-dev.spec20
2 files changed, 270 insertions, 31 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index 46c8f4c..d87b673 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
+Extension [ <persistent> extension #72 amqp version 1.8.0beta1 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -43,6 +43,18 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
Entry [ amqp.heartbeat <ALL> ]
Current = '0'
}
+ Entry [ amqp.cacert <ALL> ]
+ Current = ''
+ }
+ Entry [ amqp.cert <ALL> ]
+ Current = ''
+ }
+ Entry [ amqp.key <ALL> ]
+ Current = ''
+ }
+ Entry [ amqp.verify <ALL> ]
+ Current = '1'
+ }
}
- Constants [22] {
@@ -70,7 +82,7 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
Constant [ integer PHP_AMQP_MAX_CHANNELS ] { 256 }
}
- - Classes [10] {
+ - Classes [11] {
Class [ <internal:amqp> class AMQPConnection ] {
- Constants [0] {
@@ -82,7 +94,7 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
- Static methods [0] {
}
- - Properties [11] {
+ - Properties [15] {
Property [ <default> private $login ]
Property [ <default> private $password ]
Property [ <default> private $host ]
@@ -94,9 +106,13 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
Property [ <default> private $channel_max ]
Property [ <default> private $frame_max ]
Property [ <default> private $heartbeat ]
+ Property [ <default> private $cacert ]
+ Property [ <default> private $key ]
+ Property [ <default> private $cert ]
+ Property [ <default> private $verify ]
}
- - Methods [29] {
+ - Methods [37] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
@@ -279,6 +295,58 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
- Parameters [0] {
}
}
+
+ Method [ <internal:amqp> public method getCACert ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setCACert ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cacert ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getCert ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setCert ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $cert ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getKey ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setKey ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $key ]
+ }
+ }
+
+ Method [ <internal:amqp> public method getVerify ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method setVerify ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $verify ]
+ }
+ }
}
}
@@ -299,7 +367,7 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
Property [ <default> private $prefetch_size ]
}
- - Methods [13] {
+ - Methods [19] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [1] {
@@ -313,6 +381,12 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
}
}
+ Method [ <internal:amqp> public method close ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:amqp> public method getChannelId ] {
- Parameters [0] {
@@ -383,6 +457,41 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
Parameter #0 [ <optional> $requeue ]
}
}
+
+ Method [ <internal:amqp> public method confirmSelect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method waitForConfirm ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
+
+ Method [ <internal:amqp> public method setConfirmCallback ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $ack_callback ]
+ Parameter #1 [ <optional> $nack_callback ]
+ }
+ }
+
+ Method [ <internal:amqp> public method setReturnCallback ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $return_callback ]
+ }
+ }
+
+ Method [ <internal:amqp> public method waitForBasicReturn ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> $timeout ]
+ }
+ }
}
}
@@ -755,7 +864,7 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
}
}
- Class [ <internal:amqp> class AMQPEnvelope ] {
+ Class [ <internal:amqp> class AMQPBasicProperties ] {
- Constants [0] {
}
@@ -766,12 +875,7 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
- Static methods [0] {
}
- - Properties [18] {
- Property [ <default> private $body ]
- Property [ <default> private $delivery_tag ]
- Property [ <default> private $is_redelivery ]
- Property [ <default> private $exchange_name ]
- Property [ <default> private $routing_key ]
+ - Properties [14] {
Property [ <default> private $content_type ]
Property [ <default> private $content_encoding ]
Property [ <default> private $headers ]
@@ -785,28 +889,29 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
Property [ <default> private $type ]
Property [ <default> private $user_id ]
Property [ <default> private $app_id ]
+ Property [ <default> private $cluster_id ]
}
- - Methods [21] {
+ - Methods [15] {
Method [ <internal:amqp, ctor> public method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getBody ] {
+ Method [ <internal:amqp> public method getContentType ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getRoutingKey ] {
+ Method [ <internal:amqp> public method getContentEncoding ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getDeliveryTag ] {
+ Method [ <internal:amqp> public method getHeaders ] {
- Parameters [0] {
}
@@ -818,31 +923,31 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
}
}
- Method [ <internal:amqp> public method getExchangeName ] {
+ Method [ <internal:amqp> public method getPriority ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method isRedelivery ] {
+ Method [ <internal:amqp> public method getCorrelationId ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getContentType ] {
+ Method [ <internal:amqp> public method getReplyTo ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getContentEncoding ] {
+ Method [ <internal:amqp> public method getExpiration ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getType ] {
+ Method [ <internal:amqp> public method getMessageId ] {
- Parameters [0] {
}
@@ -854,49 +959,83 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
}
}
- Method [ <internal:amqp> public method getPriority ] {
+ Method [ <internal:amqp> public method getType ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getExpiration ] {
+ Method [ <internal:amqp> public method getUserId ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getUserId ] {
+ Method [ <internal:amqp> public method getAppId ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getAppId ] {
+ Method [ <internal:amqp> public method getClusterId ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:amqp> class AMQPEnvelope extends AMQPBasicProperties ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [5] {
+ Property [ <default> private $body ]
+ Property [ <default> private $delivery_tag ]
+ Property [ <default> private $is_redelivery ]
+ Property [ <default> private $exchange_name ]
+ Property [ <default> private $routing_key ]
+ }
+
+ - Methods [22] {
+ Method [ <internal:amqp, overwrites AMQPBasicProperties, ctor> public method __construct ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getMessageId ] {
+ Method [ <internal:amqp> public method getBody ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getReplyTo ] {
+ Method [ <internal:amqp> public method getRoutingKey ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getCorrelationId ] {
+ Method [ <internal:amqp> public method getDeliveryTag ] {
- Parameters [0] {
}
}
- Method [ <internal:amqp> public method getHeaders ] {
+ Method [ <internal:amqp> public method getExchangeName ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp> public method isRedelivery ] {
- Parameters [0] {
}
@@ -915,6 +1054,90 @@ Extension [ <persistent> extension #72 amqp version 1.7.1 ] {
Parameter #0 [ <required> $name ]
}
}
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getContentType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getContentEncoding ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getHeaders ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getDeliveryMode ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getPriority ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getCorrelationId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getReplyTo ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getExpiration ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getMessageId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getTimestamp ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getType ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getUserId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getAppId ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:amqp, inherits AMQPBasicProperties> public method getClusterId ] {
+
+ - Parameters [0] {
+ }
+ }
}
}
diff --git a/php-pecl-amqp-dev.spec b/php-pecl-amqp-dev.spec
index 908a494..4b5b834 100644
--- a/php-pecl-amqp-dev.spec
+++ b/php-pecl-amqp-dev.spec
@@ -26,16 +26,22 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
+%global prever beta1
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
-Version: 1.7.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.8.0
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source1: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_basic_properties.c
+Source2: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_basic_properties.h
+Source3: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_methods_handling.c
+Source4: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_methods_handling.h
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel > 5.3.0
BuildRequires: %{?scl_prefix}php-pear
@@ -111,6 +117,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
mv %{pecl_name}-%{version}%{?prever} NTS
+cp %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} NTS
+
cd NTS
sed -e 's/CFLAGS="-I/CFLAGS="-fPIC -I/' -i config.m4
@@ -161,6 +169,11 @@ extension = %{pecl_name}.so
;amqp.channel_max = 256
;amqp.frame_max = 131072
;amqp.heartbeat = 0
+
+;amqp.cacert = ''
+;amqp.cert = ''
+;amqp.key = ''
+;amqp.verify = ''
EOF
%if %{with_zts}
@@ -297,6 +310,9 @@ fi
%changelog
+* Tue Nov 1 2016 Remi Collet <remi@fedoraproject.org> - 1.8.0-0.1.beta1
+- update to 1.8.0beta1
+
* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 1.7.1-2
- rebuild for PHP 7.1 new API version