summaryrefslogtreecommitdiffstats
path: root/php-pecl-amqp-dev.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pecl-amqp-dev.spec')
-rw-r--r--php-pecl-amqp-dev.spec20
1 files changed, 18 insertions, 2 deletions
diff --git a/php-pecl-amqp-dev.spec b/php-pecl-amqp-dev.spec
index 908a494..4b5b834 100644
--- a/php-pecl-amqp-dev.spec
+++ b/php-pecl-amqp-dev.spec
@@ -26,16 +26,22 @@
%else
%global ini_name 40-%{pecl_name}.ini
%endif
+%global prever beta1
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
-Version: 1.7.1
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.8.0
+Release: 0.1.%{prever}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
Group: Development/Languages
URL: http://pecl.php.net/package/amqp
Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Source1: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_basic_properties.c
+Source2: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_basic_properties.h
+Source3: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_methods_handling.c
+Source4: https://raw.githubusercontent.com/pdezwart/php-amqp/v1.8.0beta1/amqp_methods_handling.h
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel > 5.3.0
BuildRequires: %{?scl_prefix}php-pear
@@ -111,6 +117,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
mv %{pecl_name}-%{version}%{?prever} NTS
+cp %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} NTS
+
cd NTS
sed -e 's/CFLAGS="-I/CFLAGS="-fPIC -I/' -i config.m4
@@ -161,6 +169,11 @@ extension = %{pecl_name}.so
;amqp.channel_max = 256
;amqp.frame_max = 131072
;amqp.heartbeat = 0
+
+;amqp.cacert = ''
+;amqp.cert = ''
+;amqp.key = ''
+;amqp.verify = ''
EOF
%if %{with_zts}
@@ -297,6 +310,9 @@ fi
%changelog
+* Tue Nov 1 2016 Remi Collet <remi@fedoraproject.org> - 1.8.0-0.1.beta1
+- update to 1.8.0beta1
+
* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 1.7.1-2
- rebuild for PHP 7.1 new API version