summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-01 17:30:05 +0100
committerRemi Collet <remi@php.net>2023-02-01 17:30:05 +0100
commit522166f3c362125750be456307748c80279319ca (patch)
tree082e3e60a4b7a333ea21aeae254ff8082599e1d9
parent3e68bad1ec3ef2dcdc73663c1d9b73e803322fc2 (diff)
refresh refl
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION55
-rw-r--r--php-pecl-amqp.spec4
3 files changed, 34 insertions, 27 deletions
diff --git a/PHPINFO b/PHPINFO
index e28b8ea..4ac98b4 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,7 +5,7 @@ Version => 1.11.0
Revision => release
Compiled => Dec 1 2021 @ 00:00:00
AMQP protocol version => 0-9-1
-librabbitmq version => 0.11.0
+librabbitmq version => 0.12.0
Default max channels per connection => 256
Default max frame size => 131072
Default heartbeats interval => 0
diff --git a/REFLECTION b/REFLECTION
index 2da1c25..bd5f0fc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
+Extension [ <persistent> extension #120 amqp version 1.11.0 ] {
- INI {
Entry [ amqp.host <ALL> ]
@@ -1243,7 +1243,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> final class AMQPTimestamp ] {
+ Class [ <internal:amqp> final class AMQPTimestamp implements Stringable ] {
- Constants [2] {
Constant [ public string MAX ] { 18446744073709551616 }
@@ -1274,7 +1274,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Method [ <internal:amqp> public method __toString ] {
+ Method [ <internal:amqp, prototype Stringable> public method __toString ] {
- Parameters [0] {
}
@@ -1326,7 +1326,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> class AMQPException extends Exception implements Stringable, Throwable ] {
+ Class [ <internal:amqp> class AMQPException extends Exception implements Throwable, Stringable ] {
- Constants [0] {
}
@@ -1340,8 +1340,8 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -1358,6 +1358,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1417,7 +1418,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> class AMQPConnectionException extends AMQPException implements Throwable, Stringable ] {
+ Class [ <internal:amqp> class AMQPConnectionException extends AMQPException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1431,8 +1432,8 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -1449,6 +1450,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1508,7 +1510,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> class AMQPChannelException extends AMQPException implements Throwable, Stringable ] {
+ Class [ <internal:amqp> class AMQPChannelException extends AMQPException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1522,8 +1524,8 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -1540,6 +1542,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1599,7 +1602,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> class AMQPQueueException extends AMQPException implements Throwable, Stringable ] {
+ Class [ <internal:amqp> class AMQPQueueException extends AMQPException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1613,8 +1616,8 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -1631,6 +1634,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1690,7 +1694,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> class AMQPEnvelopeException extends AMQPException implements Throwable, Stringable ] {
+ Class [ <internal:amqp> class AMQPEnvelopeException extends AMQPException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1704,8 +1708,8 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Properties [5] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
Property [ public $envelope = NULL ]
}
@@ -1723,6 +1727,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1782,7 +1787,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> class AMQPExchangeException extends AMQPException implements Throwable, Stringable ] {
+ Class [ <internal:amqp> class AMQPExchangeException extends AMQPException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1796,8 +1801,8 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -1814,6 +1819,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
@@ -1873,7 +1879,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
}
}
- Class [ <internal:amqp> class AMQPValueException extends AMQPException implements Throwable, Stringable ] {
+ Class [ <internal:amqp> class AMQPValueException extends AMQPException implements Stringable, Throwable ] {
- Constants [0] {
}
@@ -1887,8 +1893,8 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Properties [4] {
Property [ protected $message = '' ]
Property [ protected $code = 0 ]
- Property [ protected $file = NULL ]
- Property [ protected $line = NULL ]
+ Property [ protected string $file = '' ]
+ Property [ protected int $line = 0 ]
}
- Methods [10] {
@@ -1905,6 +1911,7 @@ Extension [ <persistent> extension #119 amqp version 1.11.0 ] {
- Parameters [0] {
}
+ - Tentative return [ void ]
}
Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index 3a92fe9..243cb6a 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -3,8 +3,8 @@
#
# Fedora spec file for php-pecl-amqp
#
-# Copyright (c) 2012-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2012-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries