summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-17 14:12:31 +0200
committerRemi Collet <remi@php.net>2022-06-17 14:12:31 +0200
commit3e68bad1ec3ef2dcdc73663c1d9b73e803322fc2 (patch)
tree3757db5ec5a646ae650943a858d907bf2553afde
parent9839d6d032f755b3805171294a1e5ff1a1f6a4bf (diff)
add patch for test suite with 8.2 from
https://github.com/php-amqp/php-amqp/pull/418
-rw-r--r--418.patch31
-rw-r--r--php-pecl-amqp.spec13
2 files changed, 42 insertions, 2 deletions
diff --git a/418.patch b/418.patch
new file mode 100644
index 0000000..3a09262
--- /dev/null
+++ b/418.patch
@@ -0,0 +1,31 @@
+From ad6e2ddaf8421e992fea2d2e77c491255d6a035b Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 17 Jun 2022 14:00:36 +0200
+Subject: [PATCH] Fix: Deprecated: Creation of dynamic property (8.2)
+
+---
+ tests/bug_62354.phpt | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/tests/bug_62354.phpt b/tests/bug_62354.phpt
+index d2a173b3..6330476c 100644
+--- a/tests/bug_62354.phpt
++++ b/tests/bug_62354.phpt
+@@ -4,7 +4,9 @@ Constructing AMQPQueue with AMQPConnection segfaults
+ <?php if (!extension_loaded("amqp")) print "skip"; ?>
+ --FILE--
+ <?php
+-class Amqptest {};
++class Amqptest {
++ public $conn = NULL;
++};
+ $o = new Amqptest();
+ $o->conn = new AMQPConnection();
+ $funcs = array(
+@@ -20,4 +22,4 @@ getLogin => 'guest'
+ getPassword => 'guest'
+ getPort => 5672
+ getVHost => '/'
+-isConnected => false
+\ No newline at end of file
++isConnected => false
diff --git a/php-pecl-amqp.spec b/php-pecl-amqp.spec
index cebc784..3a92fe9 100644
--- a/php-pecl-amqp.spec
+++ b/php-pecl-amqp.spec
@@ -3,7 +3,7 @@
#
# Fedora spec file for php-pecl-amqp
#
-# Copyright (c) 2012-2021 Remi Collet
+# Copyright (c) 2012-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -32,11 +32,13 @@
Summary: Communicate with any AMQP compliant server
Name: %{?sub_prefix}php-pecl-amqp
Version: %{upstream_version}%{?upstream_prever:~%{upstream_lower}}
-Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://pecl.php.net/package/amqp
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_version}%{?upstream_prever}.tgz
+Patch0: https://patch-diff.githubusercontent.com/raw/php-amqp/php-amqp/pull/418.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 5.6
@@ -107,6 +109,8 @@ sed -e 's/role="test"/role="src"/' \
mv %{pecl_name}-%{upstream_version}%{?upstream_prever} NTS
cd NTS
+%patch0 -p1 -b .php82
+
sed -e 's/CFLAGS="-I/CFLAGS="-fPIC -I/' -i config.m4
# Upstream often forget to change this
@@ -228,6 +232,7 @@ done
%if %{with tests}
mkdir log run base
: Launch the RabbitMQ service
+export LANG=C.UTF-8
export RABBITMQ_PID_FILE=$PWD/run/pid
export RABBITMQ_LOG_BASE=$PWD/log
export RABBITMQ_MNESIA_BASE=$PWD/base
@@ -296,6 +301,10 @@ fi
%changelog
+* Fri Jun 17 2022 Remi Collet <remi@remirepo.net> - 1.11.0-2
+- add patch for test suite with 8.2 from
+ https://github.com/php-amqp/php-amqp/pull/418
+
* Wed Dec 1 2021 Remi Collet <remi@remirepo.net> - 1.11.0-1
- update to 1.11.0