summaryrefslogtreecommitdiffstats
path: root/php-pear-Image-Text.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-pear-Image-Text.spec')
-rw-r--r--php-pear-Image-Text.spec61
1 files changed, 31 insertions, 30 deletions
diff --git a/php-pear-Image-Text.spec b/php-pear-Image-Text.spec
index 5535d85..0c629d7 100644
--- a/php-pear-Image-Text.spec
+++ b/php-pear-Image-Text.spec
@@ -5,12 +5,18 @@
Name: php-pear-Image-Text
Version: 0.6.1
Release: 1%{?dist}
-Summary: Image_Text - Advanced text maipulations in images
+Summary: Advanced text manipulations in images
Group: Development/Libraries
-License: PHP License
+License: PHP
URL: http://pear.php.net/package/Image_Text
-Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
+# remove tests which use non-free stuff (fonts)
+# pear download Image_Text-%{version}
+# ./strip.sh %{version}
+Source0: %{pear_name}-%{version}-strip.tgz
+Source1: strip.sh
+# https://pear.php.net/bugs/19789
+Source2: LICENSE
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -18,9 +24,13 @@ BuildRequires: php-pear(PEAR)
Requires(post): %{__pear}
Requires(postun): %{__pear}
+Requires: php-gd
+Requires: php-pcre
Requires: php-pear(PEAR)
+
Provides: php-pear(Image_Text) = %{version}
+
%description
Image_Text provides a comfortable interface to text manipulations in GD
images. Beside common Freetype2 functionality it offers to handle texts
@@ -29,12 +39,18 @@ texts inside a text box, rotation (around the top left corner of a text
box or it's center point) and the automatic measurizement of the optimal
font size for a given text box.
+
%prep
%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
+
+cp %{SOURCE1} LICENSE
cd %{pear_name}-%{version}
+# remove README (how to install and run test)
+# remove make_doc*.sh (packaging stuff)
+sed -e '/README/d' \
+ -e '/make_doc/d' \
+ ../package.xml >%{name}.xml
%build
@@ -43,20 +59,20 @@ cd %{pear_name}-%{version}
%install
+rm -rf %{buildroot}
cd %{pear_name}-%{version}
-rm -rf $RPM_BUILD_ROOT
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%post
@@ -72,28 +88,13 @@ fi
%files
%defattr(-,root,root,-)
+%doc LICENSE
%doc %{pear_docdir}/%{pear_name}
-
-
%{pear_xmldir}/%{name}.xml
-# Expand this as needed to avoid owning dirs owned by our dependencies
-# and to avoid unowned dirs
+%dir %{pear_phpdir}/Image
%{pear_phpdir}/Image/Text.php
-%{pear_phpdir}/tests/testimages/5x10-gradient.jpg
-%{pear_phpdir}/tests/testimages/5x10-gradient.png
-%{pear_phpdir}/tests/testimages/5x10-red-254.jpg
-%{pear_phpdir}/tests/testimages/5x10-red-254.png
-%{pear_phpdir}/tests/testimages/5x10-red-index.png
-%{pear_phpdir}/tests/testimages/5x10-red.png
-%{pear_phpdir}/tests/testimages/10x5-red.png
-%{pear_phpdir}/tests/testimages/10x5-white-grey.png
-%{pear_phpdir}/tests/testimages/10x5-white-index.png
-%{pear_phpdir}/tests/testimages/10x5-white.png
-%{pear_phpdir}/tests/testimages/test-background-red.png
-%{pear_phpdir}/tests/testimages/test-background-transparent.png
-%{pear_phpdir}/tests/testimages/test-construct.png
-%{pear_datadir}/Image_Text
-%{pear_testdir}/Image_Text
%changelog
+* Wed Jan 16 2013 Remi Collet <remi@fedoraproject.org> - 0.6.1-1
+- Initial package