summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--LICENSE68
-rw-r--r--Makefile4
-rw-r--r--php-pear-Image-Text.spec61
-rwxr-xr-xstrip.sh22
4 files changed, 125 insertions, 30 deletions
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 0000000..6c1c170
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,68 @@
+--------------------------------------------------------------------
+ The PHP License, version 3.0
+Copyright (c) 1999 - 2006 The PHP Group. All rights reserved.
+--------------------------------------------------------------------
+
+Redistribution and use in source and binary forms, with or without
+modification, is permitted provided that the following conditions
+are met:
+
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in
+ the documentation and/or other materials provided with the
+ distribution.
+
+ 3. The name "PHP" must not be used to endorse or promote products
+ derived from this software without prior written permission. For
+ written permission, please contact group@php.net.
+
+ 4. Products derived from this software may not be called "PHP", nor
+ may "PHP" appear in their name, without prior written permission
+ from group@php.net. You may indicate that your software works in
+ conjunction with PHP by saying "Foo for PHP" instead of calling
+ it "PHP Foo" or "phpfoo"
+
+ 5. The PHP Group may publish revised and/or new versions of the
+ license from time to time. Each version will be given a
+ distinguishing version number.
+ Once covered code has been published under a particular version
+ of the license, you may always continue to use it under the terms
+ of that version. You may also choose to use such covered code
+ under the terms of any subsequent version of the license
+ published by the PHP Group. No one other than the PHP Group has
+ the right to modify the terms applicable to covered code created
+ under this License.
+
+ 6. Redistributions of any form whatsoever must retain the following
+ acknowledgment:
+ "This product includes PHP, freely available from
+ <http://www.php.net/>".
+
+THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
+ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
+THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
+PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
+DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
+INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
+SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
+STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
+OF THE POSSIBILITY OF SUCH DAMAGE.
+
+--------------------------------------------------------------------
+
+This software consists of voluntary contributions made by many
+individuals on behalf of the PHP Group.
+
+The PHP Group can be contacted via Email at group@php.net.
+
+For more information on the PHP Group and the PHP project,
+please see <http://www.php.net>.
+
+This product includes the Zend Engine, freely available at
+<http://www.zend.com>.
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-pear-Image-Text.spec b/php-pear-Image-Text.spec
index 5535d85..0c629d7 100644
--- a/php-pear-Image-Text.spec
+++ b/php-pear-Image-Text.spec
@@ -5,12 +5,18 @@
Name: php-pear-Image-Text
Version: 0.6.1
Release: 1%{?dist}
-Summary: Image_Text - Advanced text maipulations in images
+Summary: Advanced text manipulations in images
Group: Development/Libraries
-License: PHP License
+License: PHP
URL: http://pear.php.net/package/Image_Text
-Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
+# remove tests which use non-free stuff (fonts)
+# pear download Image_Text-%{version}
+# ./strip.sh %{version}
+Source0: %{pear_name}-%{version}-strip.tgz
+Source1: strip.sh
+# https://pear.php.net/bugs/19789
+Source2: LICENSE
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -18,9 +24,13 @@ BuildRequires: php-pear(PEAR)
Requires(post): %{__pear}
Requires(postun): %{__pear}
+Requires: php-gd
+Requires: php-pcre
Requires: php-pear(PEAR)
+
Provides: php-pear(Image_Text) = %{version}
+
%description
Image_Text provides a comfortable interface to text manipulations in GD
images. Beside common Freetype2 functionality it offers to handle texts
@@ -29,12 +39,18 @@ texts inside a text box, rotation (around the top left corner of a text
box or it's center point) and the automatic measurizement of the optimal
font size for a given text box.
+
%prep
%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
+
+cp %{SOURCE1} LICENSE
cd %{pear_name}-%{version}
+# remove README (how to install and run test)
+# remove make_doc*.sh (packaging stuff)
+sed -e '/README/d' \
+ -e '/make_doc/d' \
+ ../package.xml >%{name}.xml
%build
@@ -43,20 +59,20 @@ cd %{pear_name}-%{version}
%install
+rm -rf %{buildroot}
cd %{pear_name}-%{version}
-rm -rf $RPM_BUILD_ROOT
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%post
@@ -72,28 +88,13 @@ fi
%files
%defattr(-,root,root,-)
+%doc LICENSE
%doc %{pear_docdir}/%{pear_name}
-
-
%{pear_xmldir}/%{name}.xml
-# Expand this as needed to avoid owning dirs owned by our dependencies
-# and to avoid unowned dirs
+%dir %{pear_phpdir}/Image
%{pear_phpdir}/Image/Text.php
-%{pear_phpdir}/tests/testimages/5x10-gradient.jpg
-%{pear_phpdir}/tests/testimages/5x10-gradient.png
-%{pear_phpdir}/tests/testimages/5x10-red-254.jpg
-%{pear_phpdir}/tests/testimages/5x10-red-254.png
-%{pear_phpdir}/tests/testimages/5x10-red-index.png
-%{pear_phpdir}/tests/testimages/5x10-red.png
-%{pear_phpdir}/tests/testimages/10x5-red.png
-%{pear_phpdir}/tests/testimages/10x5-white-grey.png
-%{pear_phpdir}/tests/testimages/10x5-white-index.png
-%{pear_phpdir}/tests/testimages/10x5-white.png
-%{pear_phpdir}/tests/testimages/test-background-red.png
-%{pear_phpdir}/tests/testimages/test-background-transparent.png
-%{pear_phpdir}/tests/testimages/test-construct.png
-%{pear_datadir}/Image_Text
-%{pear_testdir}/Image_Text
%changelog
+* Wed Jan 16 2013 Remi Collet <remi@fedoraproject.org> - 0.6.1-1
+- Initial package
diff --git a/strip.sh b/strip.sh
new file mode 100755
index 0000000..4878b74
--- /dev/null
+++ b/strip.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+name=Image_Text
+list=$(mktemp)
+
+if [ -f $name-$1.tgz ]
+then
+ tar xif $name-$1.tgz
+ tar tf $name-$1.tgz >$list.old
+
+ rm -r $name-$1/tests
+ sed -e '/tests/d' -i package.xml
+
+ tar czf $name-$1-strip.tgz package.xml $name-$1
+ tar tf $name-$1-strip.tgz | grep -v '/$' >$list.new
+
+ diff $list.old $list.new
+ rm -rf $name-$1 package.xml
+else
+ echo "usage $0 <version>"
+fi
+rm -f $list*